OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Using Bitbake Gives: Note: Exceptions.syntaxerror:
colin
post Apr 12 2006, 12:07 PM
Post #1





Group: Members
Posts: 7
Joined: 6-October 04
Member No.: 4,893



Hi,

I am trying to set up bitbake to do some oz developement. I think I have followed the instructions on the OpenEmbedded "Getting Started" Wiki. When I try "bitbake nano" all I get is lots of complaints about:

quote
NOTE: exceptions.SyntaxError:EOL while scanning single-quoted string (line 1) while evaluating:
unquote

(there is more of the output at the end of the post if it helps.)

I have tried org.openembedded.dev and org.openembedded.oz354fam083.
I have tried bitbake -rHead, -r394 and the bitbake tarball at ewi546.ewi.utwente.nl. Using earlier versins of bitbake just gives me complaints about sanity.conf file.

I have hunted around and seen others struggle with this, not found a solution that works. Any help appreciated.

Cheers,

Colin


colin@dredd:~/zaurus/openembedded/build$ bitbake nano
NOTE: Psyco JIT Compiler (http://psyco.sf.net) not available. Install it to increase performance.
NOTE: Using cache in '/home/colin/zaurus/openembedded/build/tmp/cache'
NOTE: Handling BitBake files: / (0002/2903) [ 0 %]NOTE: exceptions.SyntaxError:EOL while scanning single-quoted string (line 1) while evaluating:
${@base_set_filespath([ "/home/colin/zaurus/openembedded/org.openembedded.oz354fam083/packages/bl/bl-0.0cvs${CVSDATE}-r0", "/home/colin/zaurus/openembedded/org.openembedded.oz354fam083/packages/bl/bl-0.0cvs${CVSDATE}", "/home/colin/zaurus/openembedded/org.openembedded.oz354fam083/packages/bl/bl", "/home/colin/zaurus/openembedded/org.openembedded.oz354fam083/packages/bl/files", "/home/colin/zaurus/openembedded/org.openembedded.oz354fam083/packages/bl" ], d)}
NOTE: exceptions.SyntaxError:EOL while scanning single-quoted string (line 1) while evaluating:
${@bb.which(bb.data.getVar('FILESPATH', d, 1), '.')}
NOTE: exceptions.SyntaxError:EOL while scanning single-quoted string (line 1) while evaluating:
${FILESDIR}/manifest
.
.
.
Go to the top of the page
 
+Quote Post
colin
post Apr 13 2006, 01:45 PM
Post #2





Group: Members
Posts: 7
Joined: 6-October 04
Member No.: 4,893



Hi,

OK reply to myself. Looks like it was one or more of
mismatching bitbake to org.openembedded.xxx
an error in my local.conf, (BBFILES with double quotes ")
copying the hole of the conf directory from the org.openembedded.xxx directory and not just the conf/local.conf

Any way started from scratch and it all worked this time.

Cheers,

Colin
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th December 2014 - 02:53 PM