OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Update Packages
PrOtOn
post May 31 2005, 07:07 PM
Post #1





Group: Members
Posts: 85
Joined: 5-May 05
Member No.: 7,080



I added the line src/gz machine http://www.openzaurus.org/official/unstabl.../machine/collie to my 5500 and then I tried to updated the packages through the "package manager" and I got an error downloading packages or something like that.
Sorry for the mistake. I got the packages updated successfully now.
Also I change the path to another dir(I created one) to free space on my zaurus.(so I read).

However I can't install the upgrade packages or neither wellenreiter(see below).


Also I donwloaded the wellenreiter ipkg and put in my CF card. When I try to install to "root"(destination) I get the "An error ocurred. return value:22" "Perhaps you need to run ipkg update".
Where should I install the pkg? root, cf, sd or ram? I know for cf and sd, I need respective cards and link afterwards.

Thanks in advance.
Go to the top of the page
 
+Quote Post
lardman
post Jun 1 2005, 01:05 AM
Post #2





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
Where should I install the pkg? root, cf, sd or ram?


Any should be fine (make sure you actually have a RAM dest on your machine if you plan on using that).

QUOTE
Also I donwloaded the wellenreiter ipkg and put in my CF card. When I try to install to "root"(destination) I get the "An error ocurred. return value:22" "Perhaps you need to run ipkg update".


First off, make sure you gave the path to the wellenreiter ipk (whether a full path or a ./ on the front of the filename).

Secondly, try making the output more verbose (run 'ipkg' and look at the options - I think it's something like -v 2)


Si
Go to the top of the page
 
+Quote Post
PrOtOn
post Jun 1 2005, 12:07 PM
Post #3





Group: Members
Posts: 85
Joined: 5-May 05
Member No.: 7,080



Thanks lardamn, but I got most of the ipkg to work. I didn't know the packages would connect the internet in order to install. So I put my CF wireless card and all went good.
The only three I haven't been able to install are, Kismet , Opera and Dsniff. It hangs when trying to install them.

What do you mean by
QUOTE
"Any should be fine (make sure you actually have a RAM dest on your machine if you plan on using that)."

How do I do that?

Also, I think I found a bug, but I will post it in the right section.
Thanks for everything.
Go to the top of the page
 
+Quote Post
lardman
post Jun 2 2005, 01:48 AM
Post #4





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
What do you mean by
QUOTE

"Any should be fine (make sure you actually have a RAM dest on your machine if you plan on using that)."


How do I do that?


Which memory configuration did you choose when you selected your zImage?

Some configurations split the main memory into memory & a RAM-disk. You can (obviously) only use the RAM-disk if you flashed the appropriate kernel (personally I don't use RAM-disks as I want as much memory as possible).


Si
Go to the top of the page
 
+Quote Post
PrOtOn
post Jun 2 2005, 03:59 AM
Post #5





Group: Members
Posts: 85
Joined: 5-May 05
Member No.: 7,080



I'm using the 48-16, should I go with 64-0?
Go to the top of the page
 
+Quote Post
lardman
post Jun 2 2005, 05:51 AM
Post #6





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



I would, but it's really up to you.

Do you have a storage card which you can format as ext2 and leave in the machine (you have a CF, but do you need to use the slot for wifi etc.?)?


Si
Go to the top of the page
 
+Quote Post
PrOtOn
post Jun 2 2005, 06:20 PM
Post #7





Group: Members
Posts: 85
Joined: 5-May 05
Member No.: 7,080



Yes, I just got a SD 512MB(Kingston) card.
So, I will load the 64-0 opie image. And all applications should go on my sd card instead of ram, right?
And for installing ipkg, do I need internet or not? It seems it downloads off of the internet when using the package manager.
Go to the top of the page
 
+Quote Post
lardman
post Jun 3 2005, 02:43 AM
Post #8





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
And all applications should go on my sd card instead of ram, right?


Yes, select SD for the destination when you use ipkg.

QUOTE
And for installing ipkg, do I need internet or not?


ipkg is installed already, it's what the GUI package-manger uses, however it appears that there are some minor issues with the GUI package-manager.

I always use ipkg from the command line.

QUOTE
It seems it downloads off of the internet when using the package manager.


ipkg does this, yes, if you have internet access, it means you don't need to carry the entire feed around with you, you can just access it at will.

You were trying to install wellenreiter - try running: 'ipkg update && ipkg install -d sd wellenreiter' (that said I don't know whether it's in the feed, but you'll find soon out).


Si
Go to the top of the page
 
+Quote Post
PrOtOn
post Jun 3 2005, 07:16 PM
Post #9





Group: Members
Posts: 85
Joined: 5-May 05
Member No.: 7,080



Many thanks lardman.
I will start using the terminal to update and install ipkgs.
Now, what do I need to get the ipkg in the sd card?
I know I have to change the /ect/config, but don't know exactly the changes. Could you help me with that?
I think I have to edit for the ipkg new feed and for the sd location, so the zaurus will see everytime it boots up.

Many thanks again.
Go to the top of the page
 
+Quote Post
lardman
post Jun 5 2005, 07:09 AM
Post #10





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
Now, what do I need to get the ipkg in the sd card?


You need to add the following line to /etc/ipkg.conf (if it's not there already):

dest sd /media/card


Si
Go to the top of the page
 
+Quote Post
PrOtOn
post Jun 5 2005, 05:51 PM
Post #11





Group: Members
Posts: 85
Joined: 5-May 05
Member No.: 7,080



I have this:

QUOTE
dest root /
dest cf /media/cf/packages/
dest sd /media/card/packages/
dest ram /media/ram/packages/

I think that will do it, or I will have to take the "packages/" outta there?
Also I have to add the new feed link, right?
Thanks lardman, as I'm typing I'm updating my zaurus.
Go to the top of the page
 
+Quote Post
lardman
post Jun 6 2005, 02:08 AM
Post #12





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Those dest entries are fine (I forgot to add the packages to the end).

Regarding the feed link, look to see whether there's a conf file for it in /etc/ipkg/*.conf, if not copy and alter one of those to point to the new feed (make sure you change the name in front of the URL though - I forgot this and spent ages wondering why it wouldn't work).


Si
Go to the top of the page
 
+Quote Post
PrOtOn
post Jun 9 2005, 07:42 PM
Post #13





Group: Members
Posts: 85
Joined: 5-May 05
Member No.: 7,080



Thanks.
I have those entries on my /ect/ipkg.conf
QUOTE

I guess this should do it.

Now, I'm running into another problem. Everytime I try to install something else, I get this:
QUOTE
root@collie:~# ipkg install -d sd opie-wellenreiter-help-en
Installing opie-wellenreiter-help-en (1.2.0-r0) to sd...
Downloading http://openzaurus.org/official/unstable/3....ie/opie-wellenr
Installing opie-help-en (1.2.0-r0) to sd...
Downloading http://openzaurus.org/official/unstable/3....ie/opie-help-en
Configuring opie-help-en
Configuring opie-wellenreiter-help-en
ipkg_conf_write_status_files: Can't open status file: //usr/lib/ipkg/status for
ipkg_conf_write_status_files: Can't open status file: /media/cf/packages//usr/li
ipkg_conf_write_status_files: Can't open status file: /media/ram/packages//usr/l
root@collie:~#

In that example, I was trying to install the wellenreiter help ipkg, as you can see.
I also tried to install the new theme ipkg made by some forum user(sorry, I forgot his name), and got a "no space available" message.
Even specifying the "tmp" location on my sd card, didn't work. It says "could not creat the specified directory" or something like that.
What is the best way to correct this error?

Thanks in advance.
Go to the top of the page
 
+Quote Post
lardman
post Jun 10 2005, 12:47 AM
Post #14





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Looks like your flash is full (/).

Try removing some stuff before you install anything else (you may need to do this by hand before ipkg will be able to work again).


Si
Go to the top of the page
 
+Quote Post
PrOtOn
post Jun 10 2005, 08:01 PM
Post #15





Group: Members
Posts: 85
Joined: 5-May 05
Member No.: 7,080



I thought everything in flash would get erased once the device is rebooted.
How do I remove useless stuff from flash?
I'm current using 64-0 image and a 512MB SD card. I thought that was the way I had to go if I had a large SD card like I do.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st August 2014 - 02:30 AM