OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Cacko 1.21A keyboard problem
DReymann
post Apr 25 2004, 08:57 AM
Post #1





Group: Members
Posts: 30
Joined: 10-January 04
Member No.: 1,407



Hi,

first of all, thanks a lot for the great ROM.

I am using Cacko ROM 1.21 with hotfix A. Really the only problem which is left for me is a small problem with the keyboard. I use a modified german keyboard-file for cyrillica (I posted this one some weeks ago). I do not use the keyhelper-app (I did khctl disable). All Qtopia-Apps work fine with all special characters I need (Umlaut etc.) But in a console window these special characters do not work. Either nothing happens or some fancy reactions like "(arg: 6)" appearing on the screen when I try to get "ö".

Since I did not have this problem there must be some change between Cacko ROM 1.20 and 1.21 responsible for that.

Any idea?

Detlev
Go to the top of the page
 
+Quote Post
Rado
post Apr 25 2004, 11:18 AM
Post #2





Group: Members
Posts: 8
Joined: 1-April 04
Member No.: 2,598



QUOTE
Either nothing happens or some fancy reactions like "(arg: 6)" appearing on the screen when I try to get "ö".


Wild guess, have you tried to play with the LC_LANG variable?

Try something like "export LC_LANG=de_DE" and see if that works..
Go to the top of the page
 
+Quote Post
DReymann
post Apr 25 2004, 11:44 AM
Post #3





Group: Members
Posts: 30
Joined: 10-January 04
Member No.: 1,407



Hi,

thanks for the hint, but there was no change to the language-variable. Adding the line "export LC_ ..." to .profile does not change anything.

I am not shure, but I think I had a similar problem after installing the keyhelper-application on the 1.20 ROM. Since there is no need for me to use this - is there a way to remove it from the 1.21 ROM manually? Would be worth a try.

Detlev
Go to the top of the page
 
+Quote Post
Stubear
post Apr 25 2004, 01:58 PM
Post #4





Group: Members
Posts: 1,164
Joined: 17-December 03
From: Melbourne, AUSTRALIA
Member No.: 1,219



Sounds like .profile is not being called then. Check that /bin/bash and NOT /bin/sh end the users line in /etc/passwd

Stu
Go to the top of the page
 
+Quote Post
fu-ga-zi
post Apr 26 2004, 07:23 AM
Post #5





Group: Members
Posts: 31
Joined: 30-January 04
From: Germany
Member No.: 1,616



On the other hand, as long as it is "just" the console; why would one need Umlauts there anyway? AFAIK, the clean way on console is always to use only the characters the original 7 bit character set offered.

Regards

Peter <- from Germany ;-)
Go to the top of the page
 
+Quote Post
DReymann
post Apr 26 2004, 07:24 AM
Post #6





Group: Members
Posts: 30
Joined: 10-January 04
Member No.: 1,407



Hi,

nope, the entry for the shell in /etc/passwd is ok.

To describe the problem more in detail:

After rebooting my zaurus neither in qtopia-apps nor in the console-window I have the keys which are defined in my "german"-file for cyrillica.

I have to disable the keyhelper-app via "khctl disable" and I have to reload the "german"-file via the keyboard-app in the settings-tab.

After that I have the correct keys in all qtopia-apps but not in the console-window.

Any idea?

Detlev
Go to the top of the page
 
+Quote Post
maslovsky
post Apr 28 2004, 02:31 AM
Post #7





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



Try this - open /home/zaurus/.profile in editor, find and comment the following line:

echo -n -e "33%G"

Also, can you send me your updated german keymap file? I will include in the next ROM hotfix.
Go to the top of the page
 
+Quote Post
DReymann
post Apr 28 2004, 09:18 AM
Post #8





Group: Members
Posts: 30
Joined: 10-January 04
Member No.: 1,407



Hello,

the modification changes the behaviour in the way, that the funny characters do not show up. But the Umlauts like ö or ä are still not available on the console (but in qtopia). I still suspect some "interweaving" between keyhelper-app and cyrillica ...

You find my modified keyboard-file on http://oek.fbl.fh-wiesbaden.de/zaurus/ - i called it "deutsch" to avoid naming-problems with your original file.

Detlev
Go to the top of the page
 
+Quote Post
PsionX
post Apr 28 2004, 10:42 AM
Post #9





Group: Members
Posts: 97
Joined: 1-April 04
From: Burgundy
Member No.: 2,597



QUOTE
..." appearing on the screen when I try to get "ö"...
Since I did not have this problem there must be some change between Cacko ROM 1.20 and 1.21 responsible for that.
Any idea?
Detlev

Fonts.. I have the same problem with french accent and Lcfont.. not with Fixed .
Go to the top of the page
 
+Quote Post
DReymann
post Apr 28 2004, 11:28 AM
Post #10





Group: Members
Posts: 30
Joined: 10-January 04
Member No.: 1,407



Hi,

nope, just checked this, it the same problem with all fonts ...

Detlev
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th May 2015 - 03:35 PM