OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Usb Webcams?, videodev.o anyone?
Raybot
post Oct 13 2005, 04:22 AM
Post #1





Group: Members
Posts: 21
Joined: 25-July 05
From: Sydney
Member No.: 7,683



Hi all!

It looks like my Zaurus will start doing double duty as a robot controller pretty soon (especially since I stumbled across Jonathan's USB serial drivers so I can actually talk to the robot's MCU now)!

The problem is the webcam. I've read various posts about webcams working/not working on this forum and getting horribly confused (you need to compile V4L, drivers don't exist, etc).

The strongest lead I have so far is Meanie's website, http://www.users.on.net/~hluc/myZaurus/custom.html#webcam and his usb-modules ipkg. I'm especially keen on this as the webcam in question (AFAIK) works with the standard PWC driver, a version of which is present in that package but when I install it then run "depmod -a", I get the following errors:

CODE
# depmod -a
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/dsbr100.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/ibmcam.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/ov511.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/pwc.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/se401.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/stv680.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/ultracam.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/vicam.o


I suspect this has something to do with me missing "videodev.o" especially as it seems to be the webcam drivers that have failed but I can't find it on my filesystem anywhere and I can't find this file anywhere on "official" websites (certainly none of the bigger Zaurus websites and forums that I've tried) ... the only reference I can find to this file through google that seems vaguely zaurus'y is http://www.paipai.org/~humorum/zaurus/modu...rs/media/video/ ... but I'm a little wary of trying it out as all the documentation for that website is in Japanese so I've got no idea if it's for a specific kernel or the like (and Bablefish doesn't seem to like it).

Anyone got any ideas? Meanie, got a moment to shed some light on this perhaps please? biggrin.gif


- Raymond
Go to the top of the page
 
+Quote Post
madeddie
post Oct 13 2005, 05:26 AM
Post #2





Group: Members
Posts: 11
Joined: 10-April 05
From: Amsterdam
Member No.: 6,834



QUOTE(Raybot @ Oct 13 2005, 02:22 PM)
Hi all!

It looks like my Zaurus will start doing double duty as a robot controller pretty soon (especially since I stumbled across Jonathan's USB serial drivers so I can actually talk to the robot's MCU now)!


How very cool smile.gif I will have to play more with my zaurus soon, been used as silly PDA for way too long now smile.gif

QUOTE(Raybot @ Oct 13 2005, 02:22 PM)
tried) ... the only reference I can find to this file through google that seems vaguely zaurus'y is http://www.paipai.org/~humorum/zaurus/modu...rs/media/video/ ... but I'm a little wary of trying it out as all the documentation for that website is in Japanese so I've got no idea if it's for a specific kernel or the like (and Bablefish doesn't seem to like it).


The module says it's for kernel_version=2.4.18-rmk7-pxa3-embedix, i will try to recompile a kernel with video/webcam support when i have some time this weekend.

--
edwin
Go to the top of the page
 
+Quote Post
Raybot
post Oct 13 2005, 05:57 PM
Post #3





Group: Members
Posts: 21
Joined: 25-July 05
From: Sydney
Member No.: 7,683



QUOTE(madeddie @ Oct 13 2005, 09:26 PM)
QUOTE(Raybot @ Oct 13 2005, 02:22 PM)
Hi all!

It looks like my Zaurus will start doing double duty as a robot controller pretty soon (especially since I stumbled across Jonathan's USB serial drivers so I can actually talk to the robot's MCU now)!


How very cool smile.gif I will have to play more with my zaurus soon, been used as silly PDA for way too long now smile.gif

*




Well, it's not quite there yet :-)

QUOTE(madeddie @ Oct 13 2005, 09:26 PM)
QUOTE(Raybot @ Oct 13 2005, 02:22 PM)
tried) ... the only reference I can find to this file through google that seems vaguely zaurus'y is http://www.paipai.org/~humorum/zaurus/modu...rs/media/video/ ... but I'm a little wary of trying it out as all the documentation for that website is in Japanese so I've got no idea if it's for a specific kernel or the like (and Bablefish doesn't seem to like it).


The module says it's for kernel_version=2.4.18-rmk7-pxa3-embedix, i will try to recompile a kernel with video/webcam support when i have some time this weekend.

--
edwin
*



I've just tried it anyway and it doesn't seem to have picked up the webcam ... but then again I can't find a /dev/video for instance so perhaps I'm missing something else as well. Anyone got any suggestions?

On a related note, how DOES one go about cross-compiling kernel modules? Then again perhaps I should actually set up my cross compile environment before asking that one ... heh


- Raymond
Go to the top of the page
 
+Quote Post
lpotter
post Oct 13 2005, 07:16 PM
Post #4





Group: Members
Posts: 451
Joined: 27-November 03
From: Brisbane, Australia
Member No.: 1,001



I use a logitech quickcam webcam on my zaurus
Go to the top of the page
 
+Quote Post
Meanie
post Oct 13 2005, 07:31 PM
Post #5





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



you get videodev.o if you enable V4L during kernel build. i actually asked tetsu to compile a version of his special kernel with that enabled which resulted in the 18b-hd kernel.
anyway, i have the file somewhere in my backups hopefully. you also would need to create a device node using mknod to create /dev/video but i don't know the exact number which needs to be passed to it (again, should be in my backups somewhere, I really hate the fact that my C3000 died just when I was about to finish the webcam driver package)
if you are interesting in compiling it yourself, i just finished rebuilding my on-board gcc compiler package (http://www.users.on.net/~hluc/myZaurus/custom.html#gcc) which is preconfigured for building 2.4.20 kernel modules and drivers as well as normal applications for qtopia as well.
i'll dig around in my backups for the videodev.o driver and node creation...
Go to the top of the page
 
+Quote Post
Raybot
post Oct 14 2005, 12:58 AM
Post #6





Group: Members
Posts: 21
Joined: 25-July 05
From: Sydney
Member No.: 7,683



QUOTE(Meanie @ Oct 14 2005, 11:31 AM)
you get videodev.o if you enable V4L during kernel build. i actually asked tetsu to compile a version of his special kernel with that enabled which resulted in the 18b-hd kernel.
*


Ah OK so this doesn't run on the default Sharp kernel? Or is that what you refer to below ...

QUOTE(Meanie @ Oct 14 2005, 11:31 AM)
anyway, i have the file somewhere in my backups hopefully.
*


... here as in the .o file can work with the default kernel?

QUOTE(Meanie @ Oct 14 2005, 11:31 AM)
you also would need to create a device node using mknod to create /dev/video but i don't know the exact number which needs to be passed to it (again, should be in my backups somewhere,
*


Great! I would be most grateful if you could somehow recover the details to get this working ... smile.gif


QUOTE(Meanie @ Oct 14 2005, 11:31 AM)
I really hate the fact that my C3000 died just when I was about to finish the webcam driver package)
*


I know how you feel ... I've had no less than 5 hard drives fail on me at different times, taking most of my working data along with them eacah time ... I keep backups but it's still really annoying especially if they're out of date (and if anyone was wondering how it managed to be 5, they were all the infamous IBM [Desk|Death]Star 75GXP - 1 standalone and 2 in RAID0, when the 2 in RAID0 died they were replaced under warranty ... by another 2 75GXPs which also died </rant>).


QUOTE(Meanie @ Oct 14 2005, 11:31 AM)
if you are interesting in compiling it yourself, i just finished rebuilding my on-board gcc compiler package (http://www.users.on.net/~hluc/myZaurus/custom.html#gcc) which is preconfigured for building 2.4.20 kernel modules and drivers as well as normal applications for qtopia as well.
*


Great! I'll have a look. I'm really interested in getting a development environment set up on my box to develop for this thing (well, I have to if I'm going to start trying to get things like a Player robot server running ...). One thing I haven't figured out though is how you use configure scripts or compile kernel modules and the like under a crosscompile environment ... anyone (Meanie in particular) have any hints to offer? smile.gif

QUOTE(Meanie @ Oct 14 2005, 11:31 AM)
i'll dig around in my backups for the videodev.o driver and node creation...
*


Cool! I wait with great anticipation biggrin.gif

Thanks!

- Raymond
Go to the top of the page
 
+Quote Post
Da_Blitz
post Oct 14 2005, 01:59 AM
Post #7





Group: Members
Posts: 1,565
Joined: 7-April 05
From: Sydney, Australia
Member No.: 6,806



i can see "terminator 4 powered by sharp zaurus", good luck thogh, will you put up some info on the net as i am looking at doing somthing simmilar (with Head mounted displays/vision augmentation
Go to the top of the page
 
+Quote Post
Raybot
post Oct 14 2005, 04:17 AM
Post #8





Group: Members
Posts: 21
Joined: 25-July 05
From: Sydney
Member No.: 7,683



QUOTE(Da_Blitz @ Oct 14 2005, 05:59 PM)
i can see "terminator 4  powered by sharp zaurus", good luck thogh, will you put up some info on the net as i am looking at doing somthing simmilar (with Head mounted displays/vision augmentation
*


I can see a scene from the first part of the Tomb Raider movie playing out ... a Zaurus-controlled robot running all over the place, then someone says "Stop!", pops the SD card out, plugs another one in and it starts playing music biggrin.gif

Don't worry, my robot is not of a size that would cause such destruction - if it was I wouldn't be trying to fit a Zaurus onto the back of it smile.gif I'll see if I can get some pictures put up somewhere once it's all done though ...

So you're using the Zaurus with a head mounted display? What sorta display are you using? Sounds interesting! (I presume more info is available on your website but, as you allude to, it seems to be down at the moment!)

- Raymond
Go to the top of the page
 
+Quote Post
Meanie
post Oct 15 2005, 02:45 AM
Post #9





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



I digged a bit around and found the required device numbers for the video device

you need to:

mknod /dev/video c 81 0
ln /dev/video /dev/video0
mknod /dev/video1 c 81 1

maybe you need more of these, so maybe do it up to 4

I have placed a work-in-progress ipk into http://www.users.on.net/~hluc/myZaurus/tmp/ unfortunately, some of the drivers still crash the Zaurus sad.gif but you will find videodev.o amongst the files)
Go to the top of the page
 
+Quote Post
Raybot
post Oct 15 2005, 04:26 AM
Post #10





Group: Members
Posts: 21
Joined: 25-July 05
From: Sydney
Member No.: 7,683



QUOTE(Meanie @ Oct 15 2005, 06:45 PM)
I digged a bit around and found the required device numbers for the video device

you need to:

mknod /dev/video c 81 0
ln /dev/video /dev/video0
mknod /dev/video1 c 81 1

maybe you need more of these, so maybe do it up to 4

I have placed a work-in-progress ipk into http://www.users.on.net/~hluc/myZaurus/tmp/ unfortunately, some of the drivers still crash the Zaurus  sad.gif but you will find videodev.o amongst the files)
*


Thanks for that! Unfortunately it doesn't seem to like it - the driver doesn't claim the webcam (a Logitech QuickCam Pro 4000 - under Red Hat at least it uses the stock PWC driver). I've got videodog compiling, when I point it at /dev/video[|0|1|2|3|4] it complains about "No such device":

# ./videodog -s -d /dev/video0
/dev/video0
open videodev: No such device



Curiously, I'm also getting the following errors when I go "depmod -a":

# depmod -a
depmod: cannot read ELF header from /hdd3/baddrivers/media/video/sonixcam.wip
depmod: cannot read ELF header from /hdd3/baddrivers/media/video/spca5.wip
depmod: cannot read ELF header from /hdd3/baddrivers/media/video/sweexcam.wip
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/media/video/ibmcam.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/media/video/ultracam.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/ibmcam.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/usb/ultracam.o

The procedure I followed was basically to install your usb-modules ipkg then this new ipkg of yours. For space reasons I symlinked the .o files into /lib/modules/2.4.20/kernel/drivers/usb and media/video (it didn't seem to like symlinking directories though).

Any suggestions as to where I might look?


On a related note, I figured I might try recompiling the drivers myself (thinking maybe an update to the PWC driver might be needed to support this webcam) but I hit an immediate snag - no kernel source! I presume the kernel source for the Sharp ROM is readily available somewhere ... is the process of getting it all up and running relatively painless or is a pile of mucking around involved?


Thanks,

- Raymond
Go to the top of the page
 
+Quote Post
kckong
post Oct 17 2005, 12:46 AM
Post #11





Group: Members
Posts: 29
Joined: 27-January 05
Member No.: 6,333



Sorry, I am lost here. Anyone can give step-by-step installation instruction. I am having Logitech WebCam + C3000 with usb host cable.

2nd question, what software should I run for the webCam on Zaurus? Any good video conferrencing software available between Zaurus to Window base?
Go to the top of the page
 
+Quote Post
tombraider
post Feb 6 2006, 03:55 PM
Post #12





Group: Members
Posts: 409
Joined: 23-November 04
From: Murphy, North Carolina USA
Member No.: 5,590



I know I am responding to a very old post, but just how are you able to "use" the webcam on your zaurus? What software do you use? My C1000 recognizes my Microsoft webcam but then what????

Thanks for any help.

QUOTE(lpotter @ Oct 14 2005, 03:16 AM)
I use a logitech quickcam webcam on my zaurus
*
Go to the top of the page
 
+Quote Post
Ling
post Mar 14 2007, 06:07 PM
Post #13





Group: Members
Posts: 352
Joined: 3-June 04
From: Virginia, US
Member No.: 3,563



I have found the small webcam I was looking for. I am interested in setting it up on my 3200 w/ pdaXii13 to vconf. I don't expect much, small window size with low frame rate is OK. Anyone had any success?
Go to the top of the page
 
+Quote Post
desertrat
post Mar 14 2007, 09:10 PM
Post #14





Group: Members
Posts: 742
Joined: 15-October 05
From: Gulag, Siberia
Member No.: 8,322



QUOTE(tombraider @ Feb 6 2006, 11:55 PM)
I know I am responding to a very old post,  but just how are you able to "use" the webcam on your zaurus?  What software do you use?  My C1000 recognizes my Microsoft webcam but then what????

If you're using the quickcam (as lpotter is) and you're using pdaXrom then you need gqcam.
Go to the top of the page
 
+Quote Post
dwagelaar
post Aug 2 2007, 08:18 AM
Post #15





Group: Members
Posts: 46
Joined: 26-July 04
From: Brussels, Belgium
Member No.: 4,106



Let's add some more to the mix: I've compiled video4linux and the spca5xx driver for Cacko 1.23. The spca5xx driver supports quite a lot of cameras (including my Logitech QuickCam Express). No need to do the mknod stuff manually, since that's taken care of by a /etc/hotplug/usb script. I've added the (experimental) spcaview viewer as well.

Anyway, you can try your luck. Here are the goods:
http://ssel.vub.ac.be/Members/DennisWagela...d/zaurus/cacko/

The packages are called "video4linux" and "spcaview".
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st November 2014 - 01:52 AM