OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Failing To Set-up A Build Environment...
larrycow
post Jan 27 2006, 05:56 AM
Post #1





Group: Members
Posts: 15
Joined: 9-October 05
Member No.: 8,280



I downloaded the OZ SDK from the 3.5.3/sdk directory, and uncompressed it. I followed the OE GettingStarted page. The only thing I'm not so sure about it is the version of Bitbake. I'm using 1.3.2, which may be a little too new for our "old" OE tree. Anyway...

I modified local.conf accordingly, setting my MACHINE as "collie" and my DISTRO as "openzaurus". I also set temp and cache dirs to something that makes sense.

I then export BBPATH to the root of my "sdk", and try to run a simple "bitbake nano". Sadly, I got the following output:

CODE
NOTE: Using cache in '/goinfre/openembedded-oz3.5.3/cache'
NOTE: Parsing finished. 2216 cached, 0 parsed, 47 skipped, 0 masked.
NOTE: build 200601271454: started

OE Build Configuration:
TARGET_ARCH   = "arm"
TARGET_OS     = "linux"
MACHINE       = "collie"
DISTRO        = "openzaurus"
TARGET_FPU    = "soft"

NOTE: package quilt-native-0.39: started
NOTE: package quilt-native-0.39-r0: task do_fetch: started
NOTE: package quilt-native-0.39-r0: task do_fetch: completed
NOTE: package quilt-native-0.39-r0: task do_unpack: started
NOTE: Unpacking /goinfre/openembedded-oz3.5.3/sources/quilt_savannah.nongnu.org_VER_0_39_.tar.gz to /goinfre/openembedded-oz3.5.3/tmp/work/quilt-native-0.39-r0/
tar: /goinfre/openembedded-oz3.5.3/sources/quilt_savannah.nongnu.org_VER_0_39_.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
NOTE: Task failed:
NOTE: package quilt-native-0.39-r0: task do_unpack: failed
ERROR: TaskFailed event exception, aborting
NOTE: package quilt-native-0.39: failed
ERROR: Build of nano failed


If anybody has an idea on what went wrong, or maybe knows which version of Bitbake I should use? Thanks alot.
Go to the top of the page
 
+Quote Post
Mickeyl
post Jan 27 2006, 12:29 PM
Post #2





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



Does adding 'INHERIT += patcher' in your local.conf help?
Go to the top of the page
 
+Quote Post
larrycow
post Jan 27 2006, 02:07 PM
Post #3





Group: Members
Posts: 15
Joined: 9-October 05
Member No.: 8,280



QUOTE(Mickeyl @ Jan 27 2006, 10:29 PM)
Does adding 'INHERIT += patcher' in your local.conf help?
*


I don't think so:

CODE
ERROR: function do_stage failed
ERROR: log data follows (/goinfre/openembedded-oz3.5.3/tmp/work/patcher-native-20040913-r1/temp/log.do_stage.25375)
| install: cannot stat `patcher.py': No such file or directory


What Bitbake version should I be using, btw? Thanks
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2014 - 02:18 AM