OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Help With Compile Enviroment Settings, Suse 9.3/10.0
zAlexandr
post Nov 29 2006, 02:07 PM
Post #1





Group: Members
Posts: 10
Joined: 15-December 05
From: Karlsruhe, Germany
Member No.: 8,716



Fresh installed Suse 9.3 (try with 10 too).
The packages was installed with Yast for qtopia development.

Installed Packages:
binutils-cross-arm-2.11.2-0.i386.rpm
gcc_old-2.95.3-7.i586.rpm
gcc-cross-sa1100-2.95.2-0.i386.rpm
glibc-arm-2.2.2-0.i386.rpm
linux-headers-arm-sa1100-2.4.6-3.i386.rpm
qtopia-free-1.7.0-1su82.i386.rpm
and
tmake-1.13.tar.gz


The enviroment script:
QPEDIR=/opt/Qtopia
QTDIR=/opt/Qtopia
PATH=/opt/gcc295/bin:$QTDIR/bin:$QPEDIR/bin:/opt/Qtopia/tmake-1.13:$PATH
TMAKEPATH=/opt/Qtopia/tmake-1.13/lib/qws/linux-x86-g++/
LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
export QPEDIR QTDIR PATH TMAKEPATH LD_LIBRARY_PATH PS1
echo "Altered environment for Sharp Zaurus Development x86"


When try to compile example, compiler showed errors:


g++ -c -pipe -DQWS -fno-exceptions -fno-rtti -Wall -W -O2 -fno-default-inline -DNO_DEBUG -I/opt/Qtopia/include -I/opt/Qtopia/include -o main.o main.cpp
In file included from /opt/Qtopia/include/qstring.h:43,
from /opt/Qtopia/include/qvariant.h:42,
from examplebase.h:12,
from example.h:3,
from main.cpp:1:
/opt/Qtopia/include/qcstring.h:50: string.h: No such file or directory
In file included from /opt/gcc295/lib/gcc-lib/i486-suse-linux/2.95.3/include/syslimits.h:7,
from /opt/gcc295/lib/gcc-lib/i486-suse-linux/2.95.3/include/limits.h:11,
from /opt/Qtopia/include/qwindowdefs.h:48,
from /opt/Qtopia/include/qwidget.h:42,
from examplebase.h:13,
from example.h:3,
from main.cpp:1:
/opt/gcc295/lib/gcc-lib/i486-suse-linux/2.95.3/include/limits.h:117: limits.h: No such file or directory
In file included from /opt/Qtopia/include/qtopia/qcom.h:33,
from /opt/Qtopia/include/qtopia/applicationinterface.h:24,
from /opt/Qtopia/include/qpe/qpeapplication.h:148,
from main.cpp:2:
/opt/Qtopia/include/qtopia/quuid.h:34: memory.h: No such file or directory
In file included from /opt/Qtopia/include/qstring.h:43,
from /opt/Qtopia/include/qvariant.h:42,
from examplebase.h:12,
from example.h:3,
from main.cpp:1:
/opt/Qtopia/include/qcstring.h: In function `int cstrncmp(const char *, const char *, unsigned int)':
/opt/Qtopia/include/qcstring.h:107: implicit declaration of function `int strncmp(...)'
In file included from /opt/Qtopia/include/qtopia/qcom.h:33,
from /opt/Qtopia/include/qtopia/applicationinterface.h:24,
from /opt/Qtopia/include/qpe/qpeapplication.h:148,
from main.cpp:2:
/opt/Qtopia/include/qtopia/quuid.h: In method `QUuid::QUuid()':
/opt/Qtopia/include/qtopia/quuid.h:56: implicit declaration of function `int memset(...)'
make: *** [main.o] Error 1


Some essential packages missing?
Thank you.
Go to the top of the page
 
+Quote Post
zAlexandr
post Dec 1 2006, 12:00 AM
Post #2





Group: Members
Posts: 10
Joined: 15-December 05
From: Karlsruhe, Germany
Member No.: 8,716



The first problem is fixed. laugh.gif
This was in "glibc" library i.e. it must be installed on Suse for development.
Go to the top of the page
 
+Quote Post
zAlexandr
post Dec 1 2006, 12:02 AM
Post #3





Group: Members
Posts: 10
Joined: 15-December 05
From: Karlsruhe, Germany
Member No.: 8,716



QUOTE(zAlexandr @ Dec 1 2006, 10:00 AM)
The first problem is fixed.  laugh.gif
This was in "glibc" library i.e. it must be installed on Suse for development.
*


But now I have linker problems it showed that "QPEAppplication::QPEAppplication()" not found and all members from QWidget.
Go to the top of the page
 
+Quote Post
zAlexandr
post Dec 8 2006, 12:01 AM
Post #4





Group: Members
Posts: 10
Joined: 15-December 05
From: Karlsruhe, Germany
Member No.: 8,716



QUOTE(zAlexandr @ Dec 1 2006, 10:02 AM)
QUOTE(zAlexandr @ Dec 1 2006, 10:00 AM)
The first problem is fixed.  laugh.gif
This was in "glibc" library i.e. it must be installed on Suse for development.
*


But now I have linker problems it showed that "QPEAppplication::QPEAppplication()" not found and all members from QWidget.
*



It works!!! biggrin.gif
The problem was: Qtopia 1.7 SDK binaries for x86 compiled with gcc 3.3.5. So, we don't need gcc 2.95 for linux compilation, we need it for cross-compilation ONLY!!!. biggrin.gif
Go to the top of the page
 
+Quote Post
InSearchOf
post Dec 8 2006, 12:34 AM
Post #5





Group: Admin
Posts: 1,209
Joined: 20-January 06
From: York, Pennsylvania
Member No.: 8,961



Isn't it just fun when you answer all your own questions :-)

Late
Go to the top of the page
 
+Quote Post
Cresho
post Dec 8 2006, 01:09 AM
Post #6





Group: Moderators
Posts: 1,619
Joined: 29-October 03
From: Los Angeles
Member No.: 809



laugh.gif
Go to the top of the page
 
+Quote Post
zAlexandr
post Dec 8 2006, 04:20 AM
Post #7





Group: Members
Posts: 10
Joined: 15-December 05
From: Karlsruhe, Germany
Member No.: 8,716



biggrin.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 09:07 PM