OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

4 Pages V  < 1 2 3 4 >  
Reply to this topicStart new topic
> Cacko Rom 1.23 With Full Japanese Language Support, a concise guide for C1000 and C860 ONLY
maslovsky
post May 30 2006, 11:39 AM
Post #31





Group: Members
Posts: 1,426
Joined: 22-October 03
Member No.: 89



Japanese kernels for Cacko ROM 1.23 have been released (for SL-CxK models only).

Please, visit http://cacko.biz/cacko/ for download links.
Go to the top of the page
 
+Quote Post
xotica
post Jul 7 2006, 09:36 PM
Post #32





Group: Members
Posts: 14
Joined: 30-March 05
Member No.: 6,738



QUOTE(xamindar @ Feb 8 2006, 09:52 PM)
Ok reflashed to the sharp rom and now I'm back in cacko with some usefull things. 

First of all, for any c3100 users out there who are doing this the "japanese-support-c3100_1.23_arm.ipk" is somewhat broken.  For some reason after it is installed qtopia will crash.  Thanks to meanie I learned that it is something to do with libCRIM that it installs.  I fixed it by deleting those libCRIM files that the support package installs and replacing them with the libCRIM files from my japanese sharp rom.  libCRIM is located in
/opt/QtPalmtop/plugins/inputmethods/

I attached libCRIM.tar so you c3100 users can just untar the libs and copy them to the above location.  "tar -xvf libCRIM.tar" should do it.


Second, the input method icons seem to be missing.  I don't know if this is a c3100 cacko problem or a universal one.  Anyway just untar the input_icons.tar package and copy the png files into /opt/QtPalmtop/pics144/ and then you have them. biggrin.gif
*


Hi xamindar, thanks for your guide.
I am having a little trouble setting up the Japanese fonts on my c3100. First I installed the two japanese support packages. Next (without rebooting) I replaced the old libCRIM files with the libCRIM files in the attatched .tar. After I reboot I am able to change the language input icon at the bottom of the screen to hiragana but cannot input japanese characters. Am I missing something obvious here? Any help would be welcomed.

Thanks,
Allen
Go to the top of the page
 
+Quote Post
moku
post Sep 8 2006, 01:21 AM
Post #33





Group: Members
Posts: 9
Joined: 26-June 06
Member No.: 10,255



QUOTE(xotica @ Jul 8 2006, 02:36 PM)
Hi xamindar, thanks for your guide.
I am having a little trouble setting up the Japanese fonts on my c3100.  First I installed the two japanese support packages.  Next (without rebooting) I replaced the old libCRIM files with the libCRIM files in the attatched .tar.  After I reboot I am able to change the language input icon at the bottom of the screen to hiragana but cannot input japanese characters.  Am I missing something obvious here?  Any help would be welcomed.

Thanks,
Allen
*



Like the above poster I am having the same problems. I can input japanese from CRIM but japanese keyboard input is a no go. When i press the kanji button next to the "-" button most programs just close. Ive tried both meanies japanese-suport ipk and the other one from this thread, neither have allowed me to enter japanese characters via the keyboard. I even reflashed cacko with the japanese kernel to no avail. Does anyone have any ideas? Ohh by the way this is on a c3100 and the ipks i installed were the ones made for the c3100.

Thanks in Advance
Go to the top of the page
 
+Quote Post
aaaweez
post Sep 24 2006, 01:05 PM
Post #34





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101



QUOTE(moku @ Sep 8 2006, 01:21 AM)
QUOTE(xotica @ Jul 8 2006, 02:36 PM)

Hi xamindar, thanks for your guide.
I am having a little trouble setting up the Japanese fonts on my c3100.  First I installed the two japanese support packages.  Next (without rebooting) I replaced the old libCRIM files with the libCRIM files in the attatched .tar.  After I reboot I am able to change the language input icon at the bottom of the screen to hiragana but cannot input japanese characters.  Am I missing something obvious here?  Any help would be welcomed.

Thanks,
Allen
*



Like the above poster I am having the same problems. I can input japanese from CRIM but japanese keyboard input is a no go. When i press the kanji button next to the "-" button most programs just close. Ive tried both meanies japanese-suport ipk and the other one from this thread, neither have allowed me to enter japanese characters via the keyboard. I even reflashed cacko with the japanese kernel to no avail. Does anyone have any ideas? Ohh by the way this is on a c3100 and the ipks i installed were the ones made for the c3100.

Thanks in Advance
*



Just finished following the instructions myself on my C3100 and I had the same problem. Most applications would just close if I opened the "50on" input method. I sshed in, ran netfront3 under strace and discovered that one of the Settings files had the wrong permissions. It was root:qpe instead of zaurus:qpe and that apparently was causing netfront to freak out. After changing it:

chown zaurus:qpe /home/zaurus/Settings/kogatagaku.da

Things seem to be working better now.

Just a quick summary of what I did:
Installed japanese-help_1.23_arm.ipk and japanese-support-c3100_1.23_arm.ipk
untarred input_icons.tar and libCRIM.tar as per the instructions in the earler post
changed lang=jp
restarted qtopia
fixed the permissions on the above mentioned file.
Go to the top of the page
 
+Quote Post
aaaweez
post Sep 24 2006, 01:33 PM
Post #35





Group: Members
Posts: 8
Joined: 9-February 06
Member No.: 9,101



QUOTE(aaaweez @ Sep 24 2006, 01:05 PM)
QUOTE(moku @ Sep 8 2006, 01:21 AM)
QUOTE(xotica @ Jul 8 2006, 02:36 PM)

Hi xamindar, thanks for your guide.
I am having a little trouble setting up the Japanese fonts on my c3100.  First I installed the two japanese support packages.  Next (without rebooting) I replaced the old libCRIM files with the libCRIM files in the attatched .tar.  After I reboot I am able to change the language input icon at the bottom of the screen to hiragana but cannot input japanese characters.  Am I missing something obvious here?  Any help would be welcomed.

Thanks,
Allen
*



Like the above poster I am having the same problems. I can input japanese from CRIM but japanese keyboard input is a no go. When i press the kanji button next to the "-" button most programs just close. Ive tried both meanies japanese-suport ipk and the other one from this thread, neither have allowed me to enter japanese characters via the keyboard. I even reflashed cacko with the japanese kernel to no avail. Does anyone have any ideas? Ohh by the way this is on a c3100 and the ipks i installed were the ones made for the c3100.

Thanks in Advance
*



Just finished following the instructions myself on my C3100 and I had the same problem. Most applications would just close if I opened the "50on" input method. I sshed in, ran netfront3 under strace and discovered that one of the Settings files had the wrong permissions. It was root:qpe instead of zaurus:qpe and that apparently was causing netfront to freak out. After changing it:

chown zaurus:qpe /home/zaurus/Settings/kogatagaku.da

Things seem to be working better now.

Just a quick summary of what I did:
Installed japanese-help_1.23_arm.ipk and japanese-support-c3100_1.23_arm.ipk
untarred input_icons.tar and libCRIM.tar as per the instructions in the earler post
changed lang=jp
restarted qtopia
fixed the permissions on the above mentioned file.
*



I spoke too soon. It turns out that netfront did not have focus or something when the keyboard was activated. As soon as I clicked on it, it disappeared. I will have to do some further looking.
Go to the top of the page
 
+Quote Post
kurochka
post Nov 3 2006, 02:02 PM
Post #36





Group: Members
Posts: 303
Joined: 6-February 04
Member No.: 1,740



QUOTE(aaaweez @ Sep 24 2006, 01:05 PM)
QUOTE(moku @ Sep 8 2006, 01:21 AM)
QUOTE(xotica @ Jul 8 2006, 02:36 PM)

Hi xamindar, thanks for your guide.
I am having a little trouble setting up the Japanese fonts on my c3100.  First I installed the two japanese support packages.  Next (without rebooting) I replaced the old libCRIM files with the libCRIM files in the attatched .tar.  After I reboot I am able to change the language input icon at the bottom of the screen to hiragana but cannot input japanese characters.  Am I missing something obvious here?  Any help would be welcomed.

Thanks,
Allen
*



Like the above poster I am having the same problems. I can input japanese from CRIM but japanese keyboard input is a no go. When i press the kanji button next to the "-" button most programs just close. Ive tried both meanies japanese-suport ipk and the other one from this thread, neither have allowed me to enter japanese characters via the keyboard. I even reflashed cacko with the japanese kernel to no avail. Does anyone have any ideas? Ohh by the way this is on a c3100 and the ipks i installed were the ones made for the c3100.

Thanks in Advance
*



Just finished following the instructions myself on my C3100 and I had the same problem. Most applications would just close if I opened the "50on" input method. I sshed in, ran netfront3 under strace and discovered that one of the Settings files had the wrong permissions. It was root:qpe instead of zaurus:qpe and that apparently was causing netfront to freak out. After changing it:

chown zaurus:qpe /home/zaurus/Settings/kogatagaku.da

Things seem to be working better now.

Just a quick summary of what I did:
Installed japanese-help_1.23_arm.ipk and japanese-support-c3100_1.23_arm.ipk
untarred input_icons.tar and libCRIM.tar as per the instructions in the earler post
changed lang=jp
restarted qtopia
fixed the permissions on the above mentioned file.
*




Can somebody confirm if this tutorial works to support Japanese input, dictionaries, etc. on Cacko on a C3100?

Is it required to install the Japanese kernels for Cacko 1.23 that maslovsky posted?

Will I be able to continue to use cyrillica input method and reading Cyrillic text after converting?
Go to the top of the page
 
+Quote Post
kurochka
post Nov 4 2006, 09:36 AM
Post #37





Group: Members
Posts: 303
Joined: 6-February 04
Member No.: 1,740



I have a C3100 running Cacko.

I think I followed all the steps and suggestions correctly. The only thing that I didn't do is to install Japanese kernel (I will try it next). As with others in this thread, Japanese input methods do not work - as soon as I open them the underlying program crashes, and with some inputs the Zaurus reboots. Could somebody who knows what he is doing look at this and give us simple step-by-step?

I wonder if there is a conflict with cyrillica input from Cacko? File permissions? Incorrect files in the package that rokudo supplied (he had C1000 but created a c3100 package as well). Please help.

Is the only way to get reliable Japanese input to go back to Sharp ROM? I like what maslovsky has done.
Go to the top of the page
 
+Quote Post
rokugo
post Nov 4 2006, 08:08 PM
Post #38





Group: Members
Posts: 130
Joined: 14-June 04
From: 1° 14' N 103° 55' E
Member No.: 3,678



QUOTE(kurochka @ Nov 5 2006, 01:36 AM)
Incorrect files in the package that rokudo supplied (he had C1000 but created a c3100 package as well).  Please help.

*



Perhaps you did not read my introductory post: I created this thread and the guide specifically for C860 and C1000.
These are the models I actually own so the packages I created have been tested and I know for certain that they work correctly.

Although I have tried my best to explain what each step of the conversion guide actually does, I have no idea if these steps work the same way with the newer models. And I did not make any packages for the C31000.


btw, forget about the Japanese kernel, it's meant for the earlier Cxx0 models (read post#21 to 28).
Go to the top of the page
 
+Quote Post
ShiroiKuma
post Nov 5 2006, 01:50 AM
Post #39





Group: Members
Posts: 902
Joined: 22-May 04
Member No.: 3,385



QUOTE(kurochka @ Nov 5 2006, 01:36 AM)
Incorrect files in the package that rokudo supplied (he had C1000 but created a c3100 package as well).  Please help.

*

I use Cacko 1.23 Japanese on an SL-C3200 without any problems. What I did and what I'd recommend for SL-C3100 users in view of these problems is:

With the Sharp ROM flashed tar the entire root.
Flash Cacko with the Japanese kernel.
Inspect the japanese-support file and recreate the ipk with the files in it taken from the Sharp ROM, I did this with the SL-C3200 since I saw they differed.
Then install the recreated ipk.
Then change the language to Japanese, reboot.

My SL-C3200 now works no probs this way, all the input methods and stuff.
Go to the top of the page
 
+Quote Post
kurochka
post Nov 7 2006, 02:39 PM
Post #40





Group: Members
Posts: 303
Joined: 6-February 04
Member No.: 1,740



QUOTE(rokugo @ Nov 4 2006, 08:08 PM)
Perhaps you did not read my introductory post: I created this thread and the guide specifically for C860 and C1000.
These are the models I actually own so the packages I created have been tested and I know for certain that they work correctly.
*


Rokugo, I apologize - I didn't put it right. I did read your post and its limitation and disclaimers. I have no complaints about your guide. I am sure it's great for C1000. I am just looking for solutions for 3100 from somebody else who has this unit. Similar to what ShiroiKuma is saying.

ShiroiKuma, I understand what you are saying. I am just afraid that I will not be able to do it on my own without breaking the system (I don't know how to make an ipk package and I am really bad with Linux commands). Can somebody more experienced and who has 3100 do what ShiroiKuma described and post an ipk for conversion? If nobody does it, then maybe I will venture on my own into the woods.


By the way, can I use the updated 1.02 rom to go back to Sharp ROM from Cacko?

http://support.ezaurus.com/sl-c3100/update...0updatecard.asp
http://64.233.179.104/translate_c?hl=en&u=...6lr%3D%26sa%3DG

Actually, I think I should use the rom from here: http://downloads.conics.net/pda/zaurus-sl-...iginal-backups/

I tried the rom from Trisoft but it is not the original Japanese rom, it was modified by them.
Go to the top of the page
 
+Quote Post
kwy
post Dec 6 2006, 01:45 AM
Post #41





Group: Members
Posts: 8
Joined: 20-April 05
Member No.: 6,942



Hi,
I have a question on installing Japanese support on my C1000

1) I've Flash with Full Cacko ROM 1.23
2) Install the Japanese support packages:
http://web.mol.ru/~zaurus/feed/japanese-help_1.23_arm.ipk , and then
http://web.mol.ru/~zaurus/feed/japanese-su...1k_1.23_arm.ipk

The Qtopia doesn't restart automatically and it reported error. However, it works but Japanese handwriting input gives a square for the selection. I remove, re-install the japanese-su...1k_1.23_arm.ipk but the problem still exists.

Is it correct to install the japanese-su...1k_1.23_arm.ipk , not the japanese-support_1.1_arm.ipk?

Please advise.

kwy
SL-C1000
Go to the top of the page
 
+Quote Post
Ezekiel
post Dec 6 2006, 04:51 AM
Post #42





Group: Members
Posts: 29
Joined: 24-May 04
From: Sweden
Member No.: 3,417



It's because the helvetica fonts used when locale is set to English is not a unicode font, and therefore can't display Japanese characters.

I think you have to either switch to Japanese locale (which means every program is in Japanese), or "remove" those fonts to force the system into using the unicode fonts.
Go to the top of the page
 
+Quote Post
rokugo
post Dec 7 2006, 07:29 AM
Post #43





Group: Members
Posts: 130
Joined: 14-June 04
From: 1° 14' N 103° 55' E
Member No.: 3,678



QUOTE(kwy @ Dec 6 2006, 05:45 PM)
Hi,
I have a question on installing Japanese support on my C1000

1) I've Flash with Full Cacko ROM 1.23
2) Install the Japanese support packages:
http://web.mol.ru/~zaurus/feed/japanese-help_1.23_arm.ipk , and then
http://web.mol.ru/~zaurus/feed/japanese-su...1k_1.23_arm.ipk

The Qtopia doesn't restart automatically and it reported error. However, it works but Japanese handwriting input gives a square for the selection. I remove, re-install the japanese-su...1k_1.23_arm.ipk but the problem still exists.

Is it correct to install the japanese-su...1k_1.23_arm.ipk , not the japanese-support_1.1_arm.ipk?

Please advise.

kwy
SL-C1000
*


Install the exact packages I have linked to.

In step 2, the order in which you install the packages isn't critical. And you can just manually reboot Qtopia.

Then go to step 3 and continue to the end.
Go to the top of the page
 
+Quote Post
kurochka
post Dec 7 2006, 02:34 PM
Post #44





Group: Members
Posts: 303
Joined: 6-February 04
Member No.: 1,740



I gave up on trying to have Japanese support on Cacko on 3100 and went back to stock Sharp Rom. I'd appreciate if anybody could help me with making Cacko and Japanese coexist on my 3100.
Go to the top of the page
 
+Quote Post
kwy
post Dec 12 2006, 02:31 AM
Post #45





Group: Members
Posts: 8
Joined: 20-April 05
Member No.: 6,942



Hi,

I'd like to share my experiences on installing Japanese support on my C1000 which is running Cacko ROM 1.23
I followed the instructions

1) I've Flash with Full Cacko ROM 1.23
2) Install the Japanese support packages:
http://web.mol.ru/~zaurus/feed/japanese-help_1.23_arm.ipk , and then
http://web.mol.ru/~zaurus/feed/japanese-su...1k_1.23_arm.ipk

I get an error on installing japanese-su...1k_1.23_arm.ipk but it still works. At least I can see Japanese Characters. I can keep the en locale, I can see the English program names, ...
The only drawback is a square box (it should show Japanese Characters) displayed in Japanese handwriting.
When I change the locale to jp or zh_TW, it works. As the author say, program names is not showing very well. Displayed fonts are not good.

I'll test Zstyle. I hope it can solve this problem.
Go to the top of the page
 
+Quote Post

4 Pages V  < 1 2 3 4 >
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th November 2014 - 01:25 AM