OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> 320x240 With Fn+ And Fn- How?, want 320x240 mode in rc10
realm
post Nov 11 2005, 11:54 AM
Post #1





Group: Members
Posts: 79
Joined: 5-July 04
Member No.: 3,923



i'm running rc10 on my c3000. I know in rc12 that Fn+ and Fn- work to zoom now, but getting rc10 working on my c3000 has been a pain, all i really need is to know what changes were made to what configs for it to work.

Anyone who knows what needs to be done i'd appriciate a reply on smile.gif
Go to the top of the page
 
+Quote Post
gab74
post Nov 11 2005, 01:09 PM
Post #2





Group: Members
Posts: 344
Joined: 24-May 04
Member No.: 3,411



.....FN+ FN- i try on RC12 and my C3100 ....but it doesent work ??? What do you mean as FN+ and FN- what keys may i press ??
Go to the top of the page
 
+Quote Post
urielka
post Nov 11 2005, 01:11 PM
Post #3





Group: Members
Posts: 178
Joined: 13-September 05
Member No.: 8,099



it`s Fn+1 for 640x480 and Fn+2 for 320x240
Go to the top of the page
 
+Quote Post
realm
post Nov 11 2005, 07:57 PM
Post #4





Group: Members
Posts: 79
Joined: 5-July 04
Member No.: 3,923



I'm pushing the right keys for it, the same as on my c860, yes they are Fn with 1 or Fn with 2, just used + and - because those are the blue ones above the numbers with the function key.

If anyone knows what config files need adjusted for that to work i'd appriciate it smile.gif

Realm
Go to the top of the page
 
+Quote Post
pgas
post Nov 11 2005, 10:11 PM
Post #5





Group: Members
Posts: 1,099
Joined: 17-December 03
From: Athens, Greece
Member No.: 1,210



the commands are xrandr -s 0 for fn +2 and xrandr -s 1 for fn+1.

the shortcuts are handled by openbox and can be defined in /etc/xdg/openbox/rc.xml

Backup this file before modifying it.
You might run into trouble if you use both the input setup from the menu
and modify this file manually.

try xrandr -s 0 and xrandr -s 1 in a terminal. I m not sure if this was supported in rc10
Go to the top of the page
 
+Quote Post
realm
post Nov 13 2005, 08:28 PM
Post #6





Group: Members
Posts: 79
Joined: 5-July 04
Member No.: 3,923



In case anyone else was wondering i found this is dependant on the config file, which is compiled into Xfbdev, so to make this work you have to use the version in rc12, the one in rc 10 only supports 480x640. The mappings already existed in rc10, the server didn't support it though.
Realm
Go to the top of the page
 
+Quote Post
sashz
post Nov 14 2005, 03:03 AM
Post #7





Group: Members
Posts: 388
Joined: 7-December 03
Member No.: 1,058



QUOTE(realm @ Nov 13 2005, 08:28 PM)
In case anyone else was wondering i found this is dependant on the config file, which is compiled into Xfbdev, so to make this work you have to use the version in rc12, the one in rc 10 only supports 480x640. The mappings already existed in rc10, the server didn't support it though.
Realm
*


install XServer from RC12
Go to the top of the page
 
+Quote Post
albertr
post Nov 14 2005, 04:42 AM
Post #8





Group: Members
Posts: 535
Joined: 7-March 04
Member No.: 2,195



`xrandr -s 1` gives me just a white screen. It's on rc11 with Xfbdev from rc12. Do I miss some libraries from rc12 to make it work?
-albertr
Go to the top of the page
 
+Quote Post
sashz
post Nov 14 2005, 06:35 AM
Post #9





Group: Members
Posts: 388
Joined: 7-December 03
Member No.: 1,058



QUOTE(albertr @ Nov 14 2005, 04:42 AM)
`xrandr -s 1` gives me just a white screen. It's on rc11 with Xfbdev from rc12. Do I miss some libraries from rc12 to make it work?
-albertr
*


kernel?
Go to the top of the page
 
+Quote Post
albertr
post Nov 14 2005, 06:03 PM
Post #10





Group: Members
Posts: 535
Joined: 7-March 04
Member No.: 2,195



It's C1K running sharp's 2.4.20 kernel with a few patches. The kernel is not the one that comes with pdaXrom. Do you have any randr-specific kernel code in pdaXrom?
-albertr
Go to the top of the page
 
+Quote Post
sashz
post Nov 15 2005, 12:01 AM
Post #11





Group: Members
Posts: 388
Joined: 7-December 03
Member No.: 1,058



QUOTE(albertr @ Nov 14 2005, 06:03 PM)
It's C1K running sharp's 2.4.20 kernel with a few patches. The kernel is not the one that comes with pdaXrom. Do you have any randr-specific kernel code in pdaXrom?
-albertr
*


i fixed QVGA mode problem in the original sharp 2.4.20 kernel, so you will need install it from latest pdaXrom (tools.tar + updater.sh)
Go to the top of the page
 
+Quote Post
albertr
post Nov 15 2005, 02:22 AM
Post #12





Group: Members
Posts: 535
Joined: 7-March 04
Member No.: 2,195



Any chance you can email me the patch?
-albertr
Go to the top of the page
 
+Quote Post
sashz
post Nov 15 2005, 02:47 AM
Post #13





Group: Members
Posts: 388
Joined: 7-December 03
Member No.: 1,058



QUOTE(albertr @ Nov 15 2005, 02:22 AM)
Any chance you can email me the patch?
-albertr
*


attached
Attached File(s)
Attached File  sharpsl_pxafb.c.diff.gz ( 551bytes ) Number of downloads: 101
 
Go to the top of the page
 
+Quote Post
albertr
post Nov 15 2005, 02:57 AM
Post #14





Group: Members
Posts: 535
Joined: 7-March 04
Member No.: 2,195



Thanks! I'll give it a try tonight.
-albertr
Go to the top of the page
 
+Quote Post
albertr
post Nov 15 2005, 07:26 PM
Post #15





Group: Members
Posts: 535
Joined: 7-March 04
Member No.: 2,195



It took care of it, thanks again!
-albertr
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 07:47 AM