OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Abookreader 0.9.0a, installed, but can't change setting file
brashley46
post Dec 27 2006, 06:10 PM
Post #1





Group: Members
Posts: 277
Joined: 29-May 05
From: Toronto
Member No.: 7,227



I downloaded the .ipk for this upgraded version of aBookReader from bam's site; also downloaded the abookreader.setting file to try to change the gui from Japanese to English, but I can't figure out how to overwrite this file on top of the old home/QtPalmtop/bin/abookreader.setting file. I tried to edit it in Zeditor and failed for lack of permissions. How can this be done? aBookreader works just fine, but I still can't read the settings.

I feel like a total noob. Help? blink.gif
Go to the top of the page
 
+Quote Post
bam
post Dec 27 2006, 10:51 PM
Post #2





Group: Members
Posts: 1,213
Joined: 9-June 05
From: Gobi Desert, Mongolia
Member No.: 7,306



QUOTE(brashley46 @ Dec 27 2006, 06:10 PM)
I downloaded the .ipk for this upgraded version of aBookReader from bam's site; also downloaded the abookreader.setting file to try to change the gui from Japanese to English, but I can't figure out how to overwrite this file on top of the old home/QtPalmtop/bin/abookreader.setting file. I tried to edit it in Zeditor and failed for lack of permissions. How can this be done? aBookreader works just fine, but I still can't read the settings.

I feel like a total noob. Help?  blink.gif
*


use tree!explorer, with run as root checked.
Go to the top of the page
 
+Quote Post
brashley46
post Dec 28 2006, 03:47 AM
Post #3





Group: Members
Posts: 277
Joined: 29-May 05
From: Toronto
Member No.: 7,227



QUOTE(bam @ Dec 28 2006, 01:51 AM)
use tree!explorer, with run as root checked.
*

Thanks!
Edit - got home from work this evening and still couldnt figure out how to move/copy this file from my documents directory to the QtPalmtop/bin directory; then I got a brainstorm and enabled "start as root" for Zeditor. Very carefully hand-editing the existing file to match yours worked; I now know which buttons to push! They're all in English. I'll let you know if any of them are mislabeled. Lovely so far, though. biggrin.gif
Go to the top of the page
 
+Quote Post
seiichiro0185
post Dec 30 2006, 05:04 AM
Post #4





Group: Members
Posts: 29
Joined: 23-August 05
From: Germany
Member No.: 7,931



For anyone who is interested: I've made an ipk of version 0.9.1 with English settings file. Get it from here: my feed

seiichiro0185
Go to the top of the page
 
+Quote Post
Jon_J
post Dec 30 2006, 08:47 AM
Post #5





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



seiichiro0185, have you gotten MimeTypes to work with abookreader?
I changed my mimetypes in the .desktop file for abookreader, and removed mimetype refrences from the default imagepad .desktop file.
Then I restarted Qtopia.
When I click an image in the Qtopia Files tab, it opens abookreader, but doesn't launch the image. It just opens up with it's internal filebrowser.
Is it possible to get abookreader to just open the selected file, and not it's filebrowser?
I looked in the many settings in the configuration pages, and "advanced settings", I don't see a way to disable the filebrowser from opening automatically.

Thank you,
Jon
Go to the top of the page
 
+Quote Post
seiichiro0185
post Dec 30 2006, 09:19 AM
Post #6





Group: Members
Posts: 29
Joined: 23-August 05
From: Germany
Member No.: 7,931



QUOTE(Jon_J @ Dec 30 2006, 06:47 PM)
seiichiro0185, have you gotten MimeTypes to work with abookreader?
I changed my mimetypes in the .desktop file for abookreader, and removed mimetype refrences from the default imagepad .desktop file.
Then I restarted Qtopia.
When I click an image in the Qtopia Files tab, it opens abookreader, but doesn't launch the image. It just opens up with it's internal filebrowser.
Is it possible to get abookreader to just open the selected file, and not it's filebrowser?
I looked in the many settings in the configuration pages, and "advanced settings", I don't see a way to disable the filebrowser from opening automatically.

Thank you,
Jon
*


I think its simply not implemented in the current version. From my understanding of the code (I'm by no means a professional c/c++ programmer, but I know the basics) aBookReader ignores all commandline arguments (basically if you set the mimetype the app gets called with app <file> when the file is clicked) and so it just starts as if run from the normal app-icon. So to get it to work we need someone who can implement this (or can speak japanese to convince the original author to implement it ^^).

seiichiro0185

PS.: As i said I only know the basics of programming c/c++, so if someone finds that my post is false, feel free to correct me ^^
Go to the top of the page
 
+Quote Post
Jon_J
post Dec 30 2006, 09:38 AM
Post #7





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



Thank you for explaining this to me! smile.gif
I'll just change it back to Imagepad for now.
This must also be the reason I cannot make Picsel Browser launch filetypes by using the MimeType function.
Picsel launches when I click a PDF file, but then I have to open it's internal filebrowser to open the file.

Thanks again, this just answered two things that have been bugging me for awhile. smile.gif
Go to the top of the page
 
+Quote Post
brashley46
post Dec 31 2006, 08:04 PM
Post #8





Group: Members
Posts: 277
Joined: 29-May 05
From: Toronto
Member No.: 7,227



QUOTE(seiichiro0185 @ Dec 30 2006, 08:04 AM)
For anyone who is interested: I've made an ipk of version 0.9.1 with English settings file. Get it from here:  my feed

seiichiro0185
*

Thanks, I guess I'll have to give that a try too, at some point. What's the lowdown on the version change?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2014 - 08:19 PM