OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Help On Sharprom Dependencies...
penguinsam
post Aug 19 2005, 11:17 AM
Post #1





Group: Members
Posts: 51
Joined: 15-March 04
Member No.: 2,316



Two days ago, I have posted a thread here saying that I can't run opie-camera properly on Cacko 1.22a.

I mailed Michael already and very sorry to hear that he has stopped the work on sharproms...

I am wondering can any linux genius help to deal with the dependencies of opie-camera on sharproms?

I really appreciate, thanks! laugh.gif

P.S. the opie packages can be found here:

1.0.1-r0
1.2.0-r0
Go to the top of the page
 
+Quote Post
dhns
post Aug 20 2005, 04:52 AM
Post #2





Group: Members
Posts: 699
Joined: 26-February 04
From: near Munich, Germany
Member No.: 2,043



QUOTE(penguinsam @ Aug 19 2005, 08:17 PM)
Two days ago, I have posted a thread here saying that I can't run opie-camera properly on Cacko 1.22a.

The first thing if nothing happens is to try to launch from a terminal.

The best way to do so IMHO is to ssh into the Zaurus. Then, type "ps -ef" but not yet return. Then, launch the application on the Zaurus with the pen and press immediately return on your host. This should show the full launch command of the application - if that fails.

Then, you can try to run the same command manually and look for messages on the screen or in dmesg.

Another step could be to install gdb and ncurses5 and launch the program in gdb.

This all might help to find out about compatibilities.

Hope that helps a little.

-- hns
Go to the top of the page
 
+Quote Post
lardman
post Aug 20 2005, 07:39 AM
Post #3





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Run ldd on the binary, that will tell you the deps.

You'll have troubles running that opie binary on a Sharp based system. Have you looked in mickeyl's opie-for-sharp-rom feed (assuming it still exists...)?


Si
Go to the top of the page
 
+Quote Post
penguinsam
post Aug 21 2005, 07:19 AM
Post #4





Group: Members
Posts: 51
Joined: 15-March 04
Member No.: 2,316



QUOTE(dhns @ Aug 20 2005, 08:52 PM)
QUOTE(penguinsam @ Aug 19 2005, 08:17 PM)
Two days ago, I have posted a thread here saying that I can't run opie-camera properly on Cacko 1.22a.

The first thing if nothing happens is to try to launch from a terminal.

The best way to do so IMHO is to ssh into the Zaurus. Then, type "ps -ef" but not yet return. Then, launch the application on the Zaurus with the pen and press immediately return on your host. This should show the full launch command of the application - if that fails.

Then, you can try to run the same command manually and look for messages on the screen or in dmesg.

Another step could be to install gdb and ncurses5 and launch the program in gdb.

This all might help to find out about compatibilities.

Hope that helps a little.

-- hns
*


it looks so difficult...but i better try it out as long as i want to run this app sad.gif
Go to the top of the page
 
+Quote Post
penguinsam
post Aug 21 2005, 07:20 AM
Post #5





Group: Members
Posts: 51
Joined: 15-March 04
Member No.: 2,316



QUOTE(lardman @ Aug 20 2005, 11:39 PM)
Run ldd on the binary, that will tell you the deps.

You'll have troubles running that opie binary on a Sharp based system. Have you looked in mickeyl's opie-for-sharp-rom feed (assuming it still exists...)?


Si
*

yes, the best is to find a ipk for sharprom...but i think the opie-for-sharrom feed has already gone....
Go to the top of the page
 
+Quote Post
penguinsam
post Aug 21 2005, 08:50 AM
Post #6





Group: Members
Posts: 51
Joined: 15-March 04
Member No.: 2,316



ph34r.gif news updated ph34r.gif

I tried to launch opie-camera under console, the following message prompted:

camera: error while loading shared libraries: /home/QtPalmtop/lib/libcamera.so.1: undefined symbol: _ZN7QObject5eventEP6QEvent

what does this mean??
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2014 - 04:50 AM