OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Wifi Connection Not Working? - Use Wifi-radar, This is how I connected zubuntu for the 1rst time.
Jon_J
post Jan 1 2009, 11:05 AM
Post #1





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I was having a difficult time getting my Z to connect using wifi.
Someone suggested that I blacklist hostap and use orinoco. I wanted to use hostap, instead.
I use hostap in three other zaurus distros with WPA.
I finally found where the "feed" is located for zubuntu and I just downloaded wifi-radar to my desktop machine.
I placed it on a CF card and installed it with dpkg.
It's a python app. Guess what? All dependencies are already installed in zubuntu. smile.gif
There was one message about an old version of "python-glade2"
It was recommended that I uninstall this, but I haven't yet.
Using wifi-radar, I needed to make a static connection, DHCP didn't work.
First I tried to use the IP, subnet, and gateway shown on my router's "status" page. These numbers didn't work for me.
(I would get one ping, then following pings would not reach the server).
Then, in windows, I just used the numbers shown when you use "ipconfig /all" in a commandline. I'm finally connected! smile.gif
I couldn't use any of my three ethernet adapters because, two of them draw more than the 150mA limit through USB, and the other one hasn't gotten a driver compiled for it yet.

BTW, I still don't have WPA working yet. I have to disable WPA on my router to connect with zubuntu. Hopefully I'll fix this later.

Edit:
Launching wifi-radar from the commandline causes it to scan for APs. I get error messages about scanning not supported.
Quick fix is to use the disconnect button, as "I think" it is connected to 127.0.0.1
I don't remember now as I'm online and its IP is shown.
If you want to launch wifi-radar from the menu, you'll need to edit its *.desktop file. I just took out the extra switches in this line and made it like this:
Exec=wifi-radar
The original setting was:
Exec=gksudo -S wifi-radar

Edit2: edited title to be more descriptive

This post has been edited by Jon_J: Jan 2 2009, 08:04 AM
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 07:10 AM