OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Installing Python + Offlineimap, Missing files
henrysviper
post Apr 26 2005, 09:02 AM
Post #1





Group: Members
Posts: 76
Joined: 4-May 04
From: Athens, Greece
Member No.: 3,136



Hello everybody

I tried earlier today to install offlineimap (a very nice program for synchronizing mail with an IMAP server). Offlineimap is written in python so, "ipkg" brought in python-core as a dependency. However offlineimap needed more python modules. Some of them were in the feed, some were not. I found the missing modules on my linux box, copied them over and now offlineimap works nicely. Regarding this, I have three remarks:

- offlineimap complained about not finding modules "traceback" and "linecache" (and maybe 1-2 more which I don't remember now). I have OE/bitbake (latest versions) installed and I see that there is a file "python-2.4.1-manifest.inc" that gets included by python_2.4.1.bb, and has these two modules listed. Why don't they appear in the final python-core package?

- offlineimap after installation had an error in the first line (trying to run something like ..../staging/.../python instead of /usr/bin/python)

- OE contains a .bb file for an older version of offlineimap. I updated the version, fixed the dependencies and produced a working .ipk. What is the proper way to contribute it to the OE/bitbake team? (And, in general what is the proper way to contribute small fixes?)

Thanks for your time.
Go to the top of the page
 
+Quote Post
grog
post May 16 2005, 11:50 AM
Post #2





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



I just tried installing python-core (2.4.1-ml2) & offlineimap (4.0.3) on OZ-OPIE (3.5.3), & after removing all of the references to '/local/pkg/oe/collie/tmp/work/offlineimap-4.0.3-r0/image/' I still get:

CODE
root@grond[~]# offlineimap
Fatal Python error: PyString_InternInPlace: strings only please!
Aborted

Any ideas what I need to get this running? thks
Go to the top of the page
 
+Quote Post
Hrw
post May 16 2005, 12:04 PM
Post #3





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



send patches, bb recipes to OE malinglist
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st August 2014 - 05:55 AM