OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Rc11 Gcc [solved, Pls Don't Read], Compile succeed but nothing happened!
Fatty
post Sep 30 2005, 06:26 AM
Post #1





Group: Members
Posts: 94
Joined: 22-September 05
From: Hong Kong
Member No.: 8,168



Hi all.

I'm using RC11 with XFCE4 + GCC/header from the RC11 feed.

When I compile really simple/single file program (like the hello world stuff) with 'gcc -o test test.c', the program can be compiled to executable but nothing happen when run. Any suggestion?

[Solved] sorry for such stupid question. Tried all possible solution but missed out the most obvious one... no path pointed to my /home and it requires ./test to run tongue.gif
Go to the top of the page
 
+Quote Post
pgas
post Sep 30 2005, 11:04 AM
Post #2





Group: Members
Posts: 1,099
Joined: 17-December 03
From: Athens, Greece
Member No.: 1,210



ehe, not so stupid ;-)

I think it happens to a lot of people (I've done exactly the same) because:

* the current dir is not in the path (while it is the case under DOS/Windows)

but more vicious is the fact that

* 'test' is a valid command that does not output anything.

and thus you end up running 50 times /usr/bin /test instead of your program, trying to change the output doing all sort of things without even getting an error...
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 04:51 PM