OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Angstrom 2007.12 Pcmcia Issue, Can't get my PCMCIA Wlan Card up and running
x75
post Jan 1 2008, 11:01 AM
Post #1





Group: Members
Posts: 2
Joined: 1-January 08
Member No.: 21,145



Hi there,

i just installed the new Angstrom x11 Image on my SimPad SLC. Works nice.
But i can't find a way to get my Wlan Card up and running. The card works, I used it under familiar before.

If I click on "PC/CF Cards" under Settings, I get an error message "PCMCIA initialisation failed No PCMCIA driver in '/proc/devices'"
If i open the "Root shell" and type in "pccardctl ident" it finds the card at Socket 0 and knows it's a function 6 (network) card.

What am I missing here? Can someone point me to a manual somewhere, that explains how to get the pcmcia card running under angstrom?

Thanks
Johannes
Go to the top of the page
 
+Quote Post
ofels
post Jan 4 2008, 02:47 AM
Post #2





Group: Members
Posts: 142
Joined: 4-December 06
From: Lake Constance, Germany
Member No.: 13,087



QUOTE(x75 @ Jan 1 2008, 08:01 PM) *
Hi there,

i just installed the new Angstrom x11 Image on my SimPad SLC. Works nice.
But i can't find a way to get my Wlan Card up and running. The card works, I used it under familiar before.

If I click on "PC/CF Cards" under Settings, I get an error message "PCMCIA initialisation failed No PCMCIA driver in '/proc/devices'"
If i open the "Root shell" and type in "pccardctl ident" it finds the card at Socket 0 and knows it's a function 6 (network) card.

What am I missing here? Can someone point me to a manual somewhere, that explains how to get the pcmcia card running under angstrom?


Are the corresponding modules loaded (hostap, hermes or whatever is fitting your card) or installed ? I guess not.

A) The modules are not installed. If this is the case you will have to look in the Simpad feeds for the modules and manually install them.
cool.gif The modules are installed but not loaded, in this case you can use modprobe manuall to check whether something changes when loading the modules.

It all dependes on the type of your card so it would be a good idea to have more details.

Oliver
Go to the top of the page
 
+Quote Post
Martin
post Jan 6 2008, 04:21 AM
Post #3





Group: Members
Posts: 138
Joined: 5-October 04
From: konstanz, germany
Member No.: 4,874



Hi :-)

I try to test it too with my Simpad SL4 ... GREAT WORK

... first issue are the basic functions ...

- flashing with serial console vie USB / serial adapter work fine (little slow with serial) ...
- on first startup to set clock and timezone no virtual keyboard available ...
- missing berlin/german timezone / german localization (maybe I am able to help!)
- missing usbnet support on Simpad ...

... second with some enhanced features ...

- my SIEMENS I-GATE 11M WLAN card is not recognized ... no WPA :-( for wlan / networl setting applet
- how to get my serial little keyboard work (DATACOMP Model DPK62AV V3.1) ... at the moment I need the port for serial terminal connection (login)
- sound missing
- some software missing ... (maybe via ipkg repos later)

- add sd/mmc slot
- add bluetooth dongle (but problem to get one with simple usb for "serial" connection only (maybe someone knows where to buy one in germany?)

I attach a logfile later today ...

Martin
Go to the top of the page
 
+Quote Post
mr_nice
post Jan 10 2008, 11:14 AM
Post #4





Group: Members
Posts: 156
Joined: 21-September 05
Member No.: 8,161



hi,
thanks for testing the images smile.gif.
please report those bugs to the bugtracker [1].

-sound is not working atm. because there is no driver for it in 2.6 [2]

-serial keyboard should work with kbdd [3]. but I am not shure if there isn't a kernel side driver for your keyboard so that you even don't need kbdd.
But please report this also to the bugtracker because kbdd is not in angstrom feeds [4].

- some wireless drivers are missing in the feeds. i need to check that. but please also send it to the bugtracker smile.gif.

best regards
mr nice

1 http://bugs.openembedded.org/
2 http://bugs.openembedded.org/show_bug.cgi?id=2319
3 http://www.handhelds.org/moin/moin.cgi/kbdd
4 http://www.angstrom-distribution.org/repo/...p;action=search
Go to the top of the page
 
+Quote Post
mister_data
post Jan 13 2008, 07:07 AM
Post #5





Group: Members
Posts: 21
Joined: 1-March 06
From: Leipzig, Germany
Member No.: 9,257



QUOTE(Martin @ Jan 6 2008, 01:21 PM) *
Hi :-)

I try to test it too with my Simpad SL4 ... GREAT WORK

... first issue are the basic functions ...

- flashing with serial console vie USB / serial adapter work fine (little slow with serial) ...
- on first startup to set clock and timezone no virtual keyboard available ...
- missing berlin/german timezone / german localization (maybe I am able to help!)
- missing usbnet support on Simpad ...

... second with some enhanced features ...

- my SIEMENS I-GATE 11M WLAN card is not recognized ... no WPA :-( for wlan / networl setting applet
- how to get my serial little keyboard work (DATACOMP Model DPK62AV V3.1) ... at the moment I need the port for serial terminal connection (login)
- sound missing
- some software missing ... (maybe via ipkg repos later)

- add sd/mmc slot
- add bluetooth dongle (but problem to get one with simple usb for "serial" connection only (maybe someone knows where to buy one in germany?)

I attach a logfile later today ...

Martin


Hi Martin,

-> serial keyboard (DATACOMP Model DPK62AV V3.1) works with angstrom !!!

i build for myself the kbdd_0.12 ipk.

Extra work is neccessary:

1. install kbdd ipk (if avaialable) with ipkg install kbdd

2. edit /etc/inittab , insert "#" for # S:2345:respawn:/sbin/getty ttySA0 115200 vt100 , save file

3. on Simpad try Settings -> Keys and Buttons
-> External Keyb.
-> External Keyboard Port: /dev/ttySA0
-> External Keyboard Type: Flexis

4. Simpad - restart (reboot, reset)

5. connect simpad with serial-keyboard

6. After restart, console -> modprobe uinput

7. /etc/init.d/kbdd stop

8. /etc/init.d/kbdd start

Now, try if serial-keyboard input is possible.

It works for me.

For serial-terminal login, reverse change of /etc/inittab (remove "#") and reboot.

mrdata
Go to the top of the page
 
+Quote Post
fredyd
post Jan 17 2008, 01:37 AM
Post #6





Group: Members
Posts: 38
Joined: 4-April 05
Member No.: 6,787



Thanks Berhardt and others, this is very (mr_)nice work!

The main problem right now is with PCMCIA, which prevents any kind of networking:
- a CF card adapter is recognized properly and mounted
- my old ethernet card (Linksys EC2T) which is supported by pcnet_cs and works in Familiar is not recognized when inserted. I only get the message "pccard: PCMCIA card inserted into slot 0" in the console. Loading the module pcnet_cs before or after inserting the card doesn't fix that (the module is included in the jffs2 images)
- my WLAN card (prism2-based), which works with hostap on Familiar, isn't recognized either. Incidentally, I noticed that kernel-module-hostap_cs is neither present in the images, nor in the simpad feed, although the hostap utilities are installed...
- "pccardctl ident" only works with the CF card adapter
- shouldn't there be a /proc/bus/pccard directory? (maybe not, but it's here on my linux 2.6.22 workstation)

has anybody got an ethernet or wifi card to work?

bugs.openembedded.org is down at the moment, so I cannot file any bug for these, sorry.

I can't wait for the day when I'll have a working Angstrom tablet with minimo running on it ;-)

Fred
Go to the top of the page
 
+Quote Post
Nokiast
post Jan 18 2008, 02:42 PM
Post #7





Group: Members
Posts: 2
Joined: 18-January 08
Member No.: 21,224



Same problem with the newest Angström-Image on my SIMpad.
Tried a manual installation of pcmcia*.ipk's. No success. As a newbie no chance for me. Confused.
The rest looks fine to me.
Tried to manually install the mini-browser package. As a newbie no success.
I'd better wait for the "professionals".
Seems to be promising.
Go to the top of the page
 
+Quote Post
noha
post Jan 23 2008, 02:55 PM
Post #8





Group: Members
Posts: 2
Joined: 11-April 05
Member No.: 6,851



Hi,

I'm also stuck without networking. I have a pimped orinoco silver (now gold). But the modules are missing. I think it is still the orinoco_cs driver. That's the one I used in the 0.8.4 image.

Is there any estimation when this will be "fixed"? Otherwise I have to build an image on my own (and I hope all the stuff is in the oe repo).

regards,

Norbert
Go to the top of the page
 
+Quote Post
mister_data
post Jan 24 2008, 02:29 AM
Post #9





Group: Members
Posts: 21
Joined: 1-March 06
From: Leipzig, Germany
Member No.: 9,257



QUOTE(noha @ Jan 23 2008, 11:55 PM) *
Hi,

I'm also stuck without networking. I have a pimped orinoco silver (now gold). But the modules are missing. I think it is still the orinoco_cs driver. That's the one I used in the 0.8.4 image.

Is there any estimation when this will be "fixed"? Otherwise I have to build an image on my own (and I hope all the stuff is in the oe repo).

regards,

Norbert


Hi,

there are only some options missing in current defconfig for SIMpad kernel 2.6.21 builds in oe.

This should change if the new defconfig is reviewed and checked in for SIMpad in oe.

orinoco_cs: Orinoco Gold (WEP) works great.

pcnet_cs: 16-bit ne2k-clones should work without any problems

But i had no success with "I-Gate" card (PRISM 1 based).
There is something wrong with init the card inside the pcmcia-subsystem.
-> pcmcia_socket0: time out after reset

And this has nothing to do with hostap_cs.

Short: new defconfig for SIMpad in oe -> autobuilder -> new image

Only for your information, kernel 2.6.24 could be the new default one in future.
Kernel 2.6.24-rc8 works great on my SIMpad. Opie ipc problems should be solved then.

Regards,

mrdata
Go to the top of the page
 
+Quote Post
Master One
post Jan 27 2008, 04:16 AM
Post #10





Group: Members
Posts: 28
Joined: 13-January 07
Member No.: 13,912



Oh boy, that's bad. This matter should be handled with priority, because without PRISM1 wlan support, this image is completely useless. I tried two different cards, one Siemens I-GATE, and one Typhoon Speednet Wireless, both are not even recognized:
CODE
$ pccardctl status
Socket 0:
  no card
$ dmesg | grep cs
<3>cs: pcmcia_socket0: time out after reset.

What the actual status?

Has that problem already been fixed in any of the images in unstable/autobuild/simpad?

I was so excited, when I read about Angstrom finally being the default for the Simpad, but without net, I can not do anything with it. So back to v0.8.4 for now, till this issue has been solved. sad.gif
Go to the top of the page
 
+Quote Post
Nokiast
post Jan 31 2008, 07:01 AM
Post #11





Group: Members
Posts: 2
Joined: 18-January 08
Member No.: 21,224



As of today there is a new unstable at the unstable images.

Anyone tried it?
Go to the top of the page
 
+Quote Post
fredyd
post Feb 4 2008, 07:06 AM
Post #12





Group: Members
Posts: 38
Joined: 4-April 05
Member No.: 6,787



QUOTE(Nokiast @ Jan 31 2008, 04:01 PM) *
As of today there is a new unstable at the unstable images.

Anyone tried it?


I just tried the 2007.12-r3 image, and we get the same stuff: only the CF adapter is recognized.
Go to the top of the page
 
+Quote Post
mister_data
post Feb 12 2008, 11:13 AM
Post #13





Group: Members
Posts: 21
Joined: 1-March 06
From: Leipzig, Germany
Member No.: 9,257



QUOTE(Nokiast @ Jan 31 2008, 04:01 PM) *
As of today there is a new unstable at the unstable images.

Anyone tried it?


Hi,

please test images again, with build date after 05.02.2008.

For opie-image there is a known error inside for missing wireless-tools.

Solution: install this ipk

Orinoco-based cards are ready for testing.

Prims 1 cards does not work (I-Gate and similar) because of error while card init from pcmcia-subsystem.

Timeframe to solve this problem is limited and help is welcome.

Regards
mrdata
Go to the top of the page
 
+Quote Post
fredyd
post Feb 15 2008, 02:12 AM
Post #14





Group: Members
Posts: 38
Joined: 4-April 05
Member No.: 6,787



Here's my report for the 2007-12.r3 images, dated feb. 6 2008:

Inserting a PCMCIA CF adaptor works,
CODE
pccard: PCMCIA card inserted into slot 0
pcmcia: registering new device pcmcia0.0
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 50MHz system bus speed for PIO modes; override with idebus=xx
hda: TOSHIBA THNCF256MMA, CFA DISK drive
ide0 at 0xc4800000-0xc4800007,0xc480000e on irq 1
ide-cs: hda: Vpp = 0.0
hda: max request size: 128KiB
hda: 500736 sectors (256 MB) w/2KiB Cache, CHS=978/16/32
hda: hda1
FAT: invalid media value (0x01)
VFS: Can't find a valid FAT filesystem on dev hda.

$ pccardctl ident
Socket 0:
product info: "TOSHIBA THNCF256MMA ", "", "", ""
manfid: 0x0098, 0x0000
function: 4 (fixed disk)


Inserting a Psion Dacom Gold Card Global 56K+Fax sometimes works. I get either
CODE
$ pccardctl ident
Socket 0:
product info: "RIPICAB", "RC288ACL", "021", "A"
manfid: 0x0013, 0x0000
function: 2 (serial)

or (I got the following only once, after a suspend/resume)
CODE
$pccardctl ident
Socket 0:
product info: "Psion Dacom", "Gold Card Global 56K+Fax", "56K+Fax", "V8.25"
manfid: 0x016c, 0x0005
function: 2 (serial)


Inserting a Prism2 card (SMC 2632W) gives the following in th console:
CODE
cs: pcmcia_socket0: time out after reset.
$ pccardctl ident
Socket 0:
no product info available
$ cs: pcmcia_socket0: time out after reset.


Inserting an ethernet card gives:
CODE
$ pccard: PCMCIA card inserted into slot 0
$ pccardctl status
Socket 0:
5.0V 16-bit PC Card
$ pccardctl ident
Socket 0:
no product info available


I don't have my Orinoco here, so I'll have to test it later.
Go to the top of the page
 
+Quote Post
mr_nice
post Feb 26 2008, 01:27 PM
Post #15





Group: Members
Posts: 156
Joined: 21-September 05
Member No.: 8,161



hi all,
mr data solved our general pcmca problem on simpad ... many thaks smile.gif
with a new hostap patch from here [1] I was able to use my siemens igate card on that pad with hostap!

here [2] is an _unofficial_ angstrom image. please test it!

it is based on linux 2.6.24 kernel. so you won't be able to get driver modules for it on the official angstrom feed.

besides we need YOUR help. please report a list of cards etc. if you want to have a kernel module in angstrom stable tree! we will enable every buildable kernel module in the kernel config, that you will have a comfortable way to install/upgrade them.
In a few days or maybe a week we will send the 2.6.24 to oe/angstrom. as far as I know the angstrom distribution plans an update image in the near future. we try to have everything done until this image will be released.

1 http://tv.latinsud.com/hostap/hostap-2.6.2...hared-irq.patch
2 http://opensimpad.org/images/2/2d/Angstrom....4_hostap.jffs2
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 04:26 PM