OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> sufin with USB zaurus and XP ... why no go?
suchs
post Feb 19 2004, 07:13 PM
Post #1





Group: Members
Posts: 29
Joined: 17-February 04
Member No.: 1,902



Well, I think I need a little help. :?:


What I want to do is surf through the zaurus using docking station connected to laptop. Read the howto many times. Tried just about every combination.

Here is my basic set up:


wifi Router IP: 192.168.1.1

wireless laptop: 192.168.1.225 mask 255.255.255.0
I have no problems surfing with Laptop alone.

zaurus IP: 192.168.0.100 255.255.255.0
connected via docking station to laptop...

zaurus SL series ver 3 (USB laptop): 192.168.0.1 mask 255.255.255.0
this is the zaurus/laptop interface on the laptop

dns set to internet provider's dns on all

I CAN ping back and forth from laptop to Zaurus, no prob. I CANNOT ping to router. sad.gif

I have set the wifi connection for ICS (tried it on and off) also tried the network wizard for bridging.

I just cannot ping the wireless adapter address (192.168.1.225) nor the router ... and obviously not google. megga frustrating!

this is route PRINT from the laptop


Interface List
0x1 ........................... MS TCP Loopback interface
0x1d0003 ...00 90 96 6e e3 65 ...... Atheros AR5001X+ Wireless Network Adapter - Packet Scheduler Miniport
0x1f0002 ...42 00 02 00 00 01 ...... MAC Bridge Miniport - Packet Scheduler Miniport
===========================================================================
===========================================================================
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.225 30
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.0.0 255.255.255.0 192.168.0.1 192.168.0.1 30
192.168.0.1 255.255.255.255 127.0.0.1 127.0.0.1 30
192.168.0.255 255.255.255.255 192.168.0.1 192.168.0.1 30
192.168.1.0 255.255.255.0 192.168.1.225 192.168.1.225 30
192.168.1.225 255.255.255.255 127.0.0.1 127.0.0.1 30
192.168.1.255 255.255.255.255 192.168.1.225 192.168.1.225 30
224.0.0.0 240.0.0.0 192.168.0.1 192.168.0.1 30
224.0.0.0 240.0.0.0 192.168.1.225 192.168.1.225 30
255.255.255.255 255.255.255.255 192.168.0.1 192.168.0.1 1
255.255.255.255 255.255.255.255 192.168.1.225 192.168.1.225 1
Default Gateway: 192.168.1.1
===========================================================================
Persistent Routes:
None




I think this is a routing problem. but i must be missing something, ehh?
Any suggestions on troubleshooting?

THanks!!!!!!!!!!!!!
Go to the top of the page
 
+Quote Post
Guest_tapjpa_*
post Feb 19 2004, 08:02 PM
Post #2





Guests






Try looking in the How to area if memory servers me right there is a doc outline the process to make this work.
Go to the top of the page
 
+Quote Post
suchs
post Feb 19 2004, 08:24 PM
Post #3





Group: Members
Posts: 29
Joined: 17-February 04
Member No.: 1,902



Read the howto many timesRead the howto many timesRead the howto many timesRead the howto many times
Go to the top of the page
 
+Quote Post
lardman
post Feb 20 2004, 05:47 AM
Post #4





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Is that 'Read' the past tense - 'I have read the howto many times', or an imperative - 'Read the howto many times!'?

;-)

Si
Go to the top of the page
 
+Quote Post
zbones
post Feb 20 2004, 10:38 AM
Post #5





Group: Members
Posts: 459
Joined: 9-December 03
From: Leeds, England
Member No.: 1,114



I use wifi to access the internet through my ap, which is directly connected to my cable modem. This means Ican browse the internet etc, without having to turn my pc on.

If you want to access the net through a pc, your have to set it up as a NAT (network address translation) router. I think this can be done through the ics(internet conection sharing) wizard. Basically you have to bridge your network connection.

I used to use this to connect my linux box to the net, but got really p***d off as the windows box kept dropping the link, needing a reboot to fix it. I also had to turn on two machines to access the net.

If you have a wifi ap, then do yourself a favor and buy a wifi cf card. Then you can lose the usb cradle and surf without having to boot your laptop.
Go to the top of the page
 
+Quote Post
suchs
post Feb 20 2004, 03:26 PM
Post #6





Group: Members
Posts: 29
Joined: 17-February 04
Member No.: 1,902



Ahhh, its just more of an exercise (in futility??) laugh.gif for me than anything else. I am just trying to see what this little thing can do. I am really psyched for the day when I can browse my network and play in hifi any song I want from my fileservers ... and yes ... I will need a wifi card for that. Any suggestions for a decent wifi cf card?

btw I have the "old" 250 processor in my 5600 ... does anybody know about the supposed bug fix kernel ... how bout oz ???

danks!
Go to the top of the page
 
+Quote Post
zbones
post Feb 20 2004, 03:39 PM
Post #7





Group: Members
Posts: 459
Joined: 9-December 03
From: Leeds, England
Member No.: 1,114



your zaurus looks good to go biggrin.gif

You just need to sort out the nat/ics on your pc.

Your PC will be getting your packets destined for the net, but does not know what to do with them.

Have you tried the ics wizard and selected "this machine connects to the internet, other machines connect through it" option.
Go to the top of the page
 
+Quote Post
suchs
post Feb 20 2004, 08:00 PM
Post #8





Group: Members
Posts: 29
Joined: 17-February 04
Member No.: 1,902



major breakthrough: got it working!
biggrin.gif
it seems there were 2 issues.

The routeadd.sh script apparently was not being executed from /etc/hotplug/
this problem is yet to be resolved.

The metrics on the laptop needed tweaking. it seems that windows gave equal metrics to both default routes. what i ended up doing was giving a metric of 35 instead of the automatic 30 to the zaurus interface adapter.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 04:53 AM