OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Linux Newbie: Can't Install U-boot
guscpu
post Mar 2 2008, 01:15 PM
Post #1





Group: Members
Posts: 69
Joined: 23-March 05
Member No.: 6,696



Trying to change ROM to PDAxrom r198 and it is driving me nuts, this is what i have done so far

Formatted SD card in WinXP and put u-boot archive i.e. the files: emergenc.img, u-boot.bin, updater.pro and updater.sh onto the card (a 2 GB SD card)
Followed the instructions here http://www.oesf.org/index.php?title=Maintenance_Menu
....but it seems to fail saying it cannot find SD card

I have also tried this...

uBoot is flashed by putting the FAT16-formatted SD with uBoot files in the Zaurus, removing all power, holding C and D, and inserting AC.

But whatever method i try the 1000 is rendered useless and I have to recover by doing a NAND restore using the Trisoft download for the SL-C1000.

How on earth can i install u-boot and do i need it to install PdaXrom? And if you are brave enough to reply to this Please remember I am a Linux newbie, thanks.

I seem to remember seeing somewhere on these forums that someone had more success using a smaller CF card, dose this apply to SD cards?


Cheers
Gus


SL-C1000
Go to the top of the page
 
+Quote Post
Capn_Fish
post Mar 2 2008, 01:50 PM
Post #2





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



You need an SD card <1GB or a CF card of any size (I have heard of no limits on CF cards).
Go to the top of the page
 
+Quote Post
guscpu
post Mar 2 2008, 02:13 PM
Post #3





Group: Members
Posts: 69
Joined: 23-March 05
Member No.: 6,696



QUOTE(Capn_Fish @ Mar 2 2008, 09:50 PM) *
You need an SD card <1GB or a CF card of any size (I have heard of no limits on CF cards).



Okay will give that a go... thanks
Go to the top of the page
 
+Quote Post
guscpu
post Mar 2 2008, 05:15 PM
Post #4





Group: Members
Posts: 69
Joined: 23-March 05
Member No.: 6,696



QUOTE(guscpu @ Mar 2 2008, 10:13 PM) *
QUOTE(Capn_Fish @ Mar 2 2008, 09:50 PM) *
You need an SD card <1GB or a CF card of any size (I have heard of no limits on CF cards).



Okay will give that a go... thanks



Okay got the U-boot installed using my 256mb SD card (knew it would come in handy one day), but boy did I have a bugger of a time getting pdaxrom installed. Tried all combinations of holding the OK key on the keyboard down and powering up just to see if the U-boot emergency system would boot up, did this without the SD. Generally no matter what combination I tried following the docs to the letter it rarely got the Z into life. Finally I got it going, what seemed to work which was contrary to the doc was to hold down the OK button before plugging in the AC, and i left the battery out altogether as i got fed up taking it in and out.


8. You'll be asked whether to proceed to install pdaXrom or the emergency system. Press "y" and then [ENTER]. YES THIS WENT FINE
9. Then you will be in a bash prompt (heading with a hash "#"). Switch to the location where the release files are: DIDN'T HAVE TO DO THIS
cd /mnt/card (or cd /mnt/cf ).
# Run the installation script by typing ./autoboot.sh DIDN'T HAVE TO DO THIS
(the last dot "." is necessary)
# Then you'll be asked once again whether to install pdaXrom or the emergency system. Again, press "y" and then [ENTER]. DIDN'T HAVE TO DO THIS
# Flashing will then begin. Just let it do its job. It may take minute or two.

okay here comes a silly newbie question.....

Only problem is I am now faced with a login screen which says.....

pdaXrom 1.1.0r198 "Kathrin"
zaurus login:

WHAT IS THE LOGIN and how do i get the gui up?

sad.gif
Go to the top of the page
 
+Quote Post
Capn_Fish
post Mar 2 2008, 05:19 PM
Post #5





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Login is "root" with no password. You can start the GUI by running

CODE
startx


EDIT: Before you do too much, you should probably also install the service pack:

http://www.oesf.org/forum/index.php?showto...24057&st=45

Post 51. I think there is a newer one, but I can't seem to find it (sp8)
Go to the top of the page
 
+Quote Post
guscpu
post Mar 2 2008, 05:24 PM
Post #6





Group: Members
Posts: 69
Joined: 23-March 05
Member No.: 6,696



QUOTE(Capn_Fish @ Mar 3 2008, 01:19 AM) *
Login is "root" with no password. You can start the GUI by running

CODE
startx



Sorry to have bothered you Capn Fish just found out what it is, and thanks for your super fast support. I will endeavour to avoid asking too many silly questions as i embark on this steep learning curve. My god it reminds me of the days when i was learning to use DOS...exciting!

Many thanks
Gus
Go to the top of the page
 
+Quote Post
Capn_Fish
post Mar 2 2008, 05:33 PM
Post #7





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Not a problem. In all fairness, there is a distinct lack of easy-to-find docs for pdaX (and docs, period).

Have fun.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd April 2014 - 11:08 PM