OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> C1000 And Openbsd, Together whether they like it or not
cal
post Sep 11 2006, 04:42 PM
Post #1





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



Edit: First post was rambling, here's what works so far


Prepareing the installation:

1.
fdisk cf card
Stops an error that sometimes happens when the card is not unmounted properly.

2.
copy the following files to /home/root/
bsd
bsd.rd
zboot
zbsdmod.o



Start BSD Installation
Run the following:

CODE
cd /home/root/
su
insmod zbsdmod.o
cp bsd.rd /proc/zboot



You are on your own from here. I cannot get a network adapter running, and my SD carder reader won't mount. Hope this helps. I'll post more when I figure it out.
Attached File(s)
Attached File  z.png ( 745.17K ) Number of downloads: 259
 
Go to the top of the page
 
+Quote Post
cal
post Sep 12 2006, 02:45 AM
Post #2





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



9/12
6:37A
New day...

Did a ctrl Z and paused the installation, and droped to a comandline. The mount showed there was no /dev/sda0 mounted.

mount -t /dev/sda0 /mnt2 errors with "device not configured"

I'm going to drop to linux and see if I can copy the 3.9 directory from the sd card to the CF card. Maybe I can skip labeling thing this time.

6:49A
No dice, cacko can't read bsd filesystems.
Go to the top of the page
 
+Quote Post
mathemajikian
post Sep 12 2006, 02:55 AM
Post #3





Group: Members
Posts: 304
Joined: 8-July 06
From: United Kingdom for now....
Member No.: 10,349



What partitions are you creating on the CF card? What device is the CF card reported as? Where are you installing zboot zbsdmod.o? They should be located in /bsd on /dev/mtdblock2. Why can't you use your USB wifi adapter with a powered usb hub to access an FTP server to aquire the bsd distribution sets? Does the C1000 have an emergeny boot linux you can access? (On the C3200 you can access sharps emergency boot linux by holding down D+B during a reboot) If so why are you doing this from within cacko? The first step is to get OpenBSD installed onto the CF card.

QUOTE(cal @ Sep 12 2006, 10:45 AM)
9/12
6:37A
New day...

Did a ctrl Z and paused the installation, and droped to a comandline.  The mount showed there was no /dev/sda0 mounted. 

mount -t /dev/sda0 /mnt2    errors with "device not configured"

I'm going to drop to linux and see if I can copy the 3.9 directory from the sd card to the CF card.  Maybe I can skip labeling thing this time.
*
Go to the top of the page
 
+Quote Post
cal
post Sep 12 2006, 03:39 AM
Post #4





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



[quote=mathemajikian,Sep 12 2006, 06:55 AM]
What partitions are you creating on the CF card? What device is the CF card reported as? Where are you installing zboot zbsdmod.o? They should be located in /bsd on /dev/mtdblock2. Why can't you use your USB wifi adapter with a powered usb hub to access an FTP server to aquire the bsd distribution sets? Does the C1000 have an emergeny boot linux you can access? (On the C3200 you can access sharps emergency boot linux by holding down D+B during a reboot) If so why are you doing this from within cacko? The first step is to get OpenBSD installed onto the CF card.


D+B doesn't bring up an emergency linux.

Wifi works on my laptop, but gives "can't write" errors. The drivers may have been added in 4.0 as it uses a relatively new chipset if I recall. Actually, I don't have the adapter here at the office but, it might be usb2. Duh, forgot to check.

In BSD the CF is reported as wd0 .

There is only one partition on the CF now, but I'm thinking of adding a 250m second partition to hold the installation sets.

The SD card in a usbreader is sd0

I have zboot and zbdsmod.o in /home/root/ .

in cacko / is readonly so "mkdir /bsd" give "Cannot create directory '/bsd': Read-only file system
Go to the top of the page
 
+Quote Post
mathemajikian
post Sep 12 2006, 04:29 AM
Post #5





Group: Members
Posts: 304
Joined: 8-July 06
From: United Kingdom for now....
Member No.: 10,349



Leaving zboot, and zbsdmod.o where they are located in your cacko install( /home/root ) you will need to rename and then copy this file to the directory stated below:

Attached File  rc.rofilesys.txt ( 4.72K ) Number of downloads: 38


(MAKE SURE YOU MAKE A BACKUP OF YOUR ORIGINAL FILE rc.rofilesys FIRST!) Rename the file rc.rofilesys.txt to rc.rofilesys and copy it to to /root/etc/rc.d/ . This has been edited to look for and load zboot and zbsdmod.o in /home/root. If you can install OpenBSD on the CF then you should be good to go using your current cacko installation.

You might also want to check out some of the other files found in this post: http://www.oesf.org/forums/index.php?showtopic=21249

QUOTE(cal @ Sep 12 2006, 11:39 AM)
D+B doesn't bring up an emergency linux. 

Wifi works on my laptop, but gives "can't write" errors.  The drivers may have been added in 4.0 as it uses a relatively new chipset if I recall.  Actually, I don't have the adapter here at the office but, it might be usb2.  Duh, forgot to check.

In  BSD the CF is reported as wd0 . 

There is only one partition on the CF now, but I'm thinking of adding a 250m second partition to hold the installation sets.

The SD card in a usbreader is sd0

I have zboot and zbdsmod.o in /home/root/ . 

in cacko / is readonly so "mkdir /bsd" give "Cannot create directory '/bsd': Read-only file system
*
Go to the top of the page
 
+Quote Post
cal
post Sep 12 2006, 04:45 AM
Post #6





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



Thanks, hope I get far enought to use it...
Unfortunately, the problem now is installing BSD to the CF... I cant mount the usb sd reader, so I can't install the installation sets. I'm going to try copying the files to a second partition on the cf card. that might work. Does the bsd labeling change when you have second partition on a disk?
Go to the top of the page
 
+Quote Post
mathemajikian
post Sep 12 2006, 05:09 AM
Post #7





Group: Members
Posts: 304
Joined: 8-July 06
From: United Kingdom for now....
Member No.: 10,349



Your best bet is to use a OpenBSD supported network adapter to download the distribution sets during the installation process. Also you should try and use the latest 4.0 snapshot. I thought you had managed to get the SD card mounted earlier during the OpenBSD install?

QUOTE(cal @ Sep 12 2006, 12:45 PM)
Thanks, hope I get far enought to use it... 
Unfortunately, the problem now is installing BSD to the CF...  I cant mount the usb sd reader, so I can't install the installation sets.  I'm going to try copying the files to a second partition on the cf card.  that might work.  Does the bsd  labeling change when you have second partition on a disk?
*
Go to the top of the page
 
+Quote Post
cal
post Sep 12 2006, 05:54 AM
Post #8





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



Nope the sd card is recognised, but will not mount. I'll try a network install after work.
Go to the top of the page
 
+Quote Post
iamasmith
post Oct 13 2006, 12:36 PM
Post #9





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



This isn't going to work. zboot only looks at CF.
Go to the top of the page
 
+Quote Post
cal
post Jan 28 2007, 06:20 PM
Post #10





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



Figured it out... Sort of. Did have a few problems though. FTP installs stalled everytime for every mirror. HTTP worked perfectly first time. I don't know why but it may have something to do with my usb ethernet adapter.
Go to the top of the page
 
+Quote Post
ZDevil
post Apr 23 2007, 12:26 PM
Post #11





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Found a japanese site with detailed guide on setting up OpenBSD on C1000:

http://www10.ocn.ne.jp/~a.koba/openbsd/zaurus.html

But it's all in Japanese, so no use to me for now. sad.gif
Go to the top of the page
 
+Quote Post
cal
post Apr 23 2007, 12:37 PM
Post #12





Group: Members
Posts: 112
Joined: 29-August 05
Member No.: 7,981



I actually got it to work fine... I guess I should have posted that. I'm not an OpenBSD expert yet so I was better off using linux, which of course we all knew from the beginning. I did however, get everything set up the way I liked it and was able to use OBSD for a week or so before I had some sort of crash. I had to shut down without running a halt, and I could never get my installation to boot again. About that time the announcement was made that SD actually working, so I looked into that for awhile and ultimately decided to wait until a official release was made. In the mean time I'm using pdaXrom
Go to the top of the page
 
+Quote Post
ZDevil
post Apr 23 2007, 01:04 PM
Post #13





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Oh that sounds scary enough.
May i ask what has actually happened?
But anyhow i will surely use my 3200 with OpenBSD on the microdrive once it arrives. smile.gif
Go to the top of the page
 
+Quote Post
mathemajikian
post Apr 24 2007, 03:16 AM
Post #14





Group: Members
Posts: 304
Joined: 8-July 06
From: United Kingdom for now....
Member No.: 10,349



QUOTE(ZDevil @ Apr 23 2007, 08:26 PM)
Found a japanese site with detailed guide on setting up OpenBSD on C1000:

http://www10.ocn.ne.jp/~a.koba/openbsd/zaurus.html

But it's all in Japanese, so no use to me for now.  sad.gif


Here's a translated version of the page: Translated Installing OpenBSD/Zaurus on the C1000

But look at the section near the end titled "Trying installing to SL-C1000." He seems to be stating what you would see during the OBSD installation process if you could get the OBSD kernel to boot on the C1000.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2014 - 04:27 AM