OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Gnumeric On Eabi, Importing xls solved by new packages from ZDevil !!
Chero
post Nov 11 2007, 10:55 AM
Post #1





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



Hi,

I've got a problem with gnumeric on eabi :
When importing an xls (95) I get the following message :
**(gnumeric:26547): CRITICAL **: workbook_iteration_tolerance: assertion 'tolerance >= 0' failed

(26547 is the process number - the real error are the iterations)
All the "number" cells have strange values. (e.g. 0:30 changes to 0:02) and all reals change really high numbers (E8 or E12).

Anyone has noticed this ?
Anyone has a clue ?

It seems to be an old problem rising again : http://mail.gnome.org/archives/gnumeric-li...y/msg00027.html

This doesn't happen on oabi (Titchy).

sad.gif
Chero.
Go to the top of the page
 
+Quote Post
jpmatrix
post Nov 11 2007, 02:14 PM
Post #2





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(Chero @ Nov 11 2007, 07:55 PM) *
Hi,

I've got a problem with gnumeric on eabi :
When importing an xls (95) I get the following message :
**(gnumeric:26547): CRITICAL **: workbook_iteration_tolerance: assertion 'tolerance >= 0' failed

(26547 is the process number - the real error are the iterations)
All the "number" cells have strange values. (e.g. 0:30 changes to 0:02) and all reals change really high numbers (E8 or E12).

Anyone has noticed this ?
Anyone has a clue ?

It seems to be an old problem rising again : http://mail.gnome.org/archives/gnumeric-li...y/msg00027.html

This doesn't happen on oabi (Titchy).

sad.gif
Chero.


i've tried to import an xls from excel and got the same problem
however i've tried an xls from openoffice and it seems good...
Go to the top of the page
 
+Quote Post
dlj0
post Nov 19 2007, 10:57 AM
Post #3





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



QUOTE(jpmatrix @ Nov 11 2007, 05:14 PM) *
QUOTE(Chero @ Nov 11 2007, 07:55 PM) *
Hi,

I've got a problem with gnumeric on eabi :
When importing an xls (95) I get the following message :
**(gnumeric:26547): CRITICAL **: workbook_iteration_tolerance: assertion 'tolerance >= 0' failed

(26547 is the process number - the real error are the iterations)
All the "number" cells have strange values. (e.g. 0:30 changes to 0:02) and all reals change really high numbers (E8 or E12).

Anyone has noticed this ?
Anyone has a clue ?

It seems to be an old problem rising again : http://mail.gnome.org/archives/gnumeric-li...y/msg00027.html

This doesn't happen on oabi (Titchy).

sad.gif
Chero.


i've tried to import an xls from excel and got the same problem
however i've tried an xls from openoffice and it seems good...


I finally got around to checking this. I have the same problem, and it also shows up on *.xls files made by gnumeric (at least those from a different machine, and maybe a year or so ago). It seems that random entries, those with formulas and maybe some pure data entries, get messed up.

*.gnumeric files, even older ones, seem to display just fine.
Go to the top of the page
 
+Quote Post
Chero
post Nov 20 2007, 12:44 PM
Post #4





Group: Members
Posts: 1,141
Joined: 22-April 04
From: Belgium
Member No.: 2,962



problem solved by new packages compiled by ZDevil !!!

Upload will probably follow soon.

I'm a happy guy now and ZDevil saved my Z from being reflashed with titchy !!! laugh.gif

Having fun,
Chero.
Go to the top of the page
 
+Quote Post
dlj0
post Nov 20 2007, 05:50 PM
Post #5





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



QUOTE(Chero @ Nov 20 2007, 03:44 PM) *
problem solved by new packages compiled by ZDevil !!!

Upload will probably follow soon.

I'm a happy guy now and ZDevil saved my Z from being reflashed with titchy !!! laugh.gif

Having fun,
Chero.


Where are these? BTW, as a workaround, if you have another machine with gnumeric, you can load your xls files in it, save them as gnumeric format, and they work properly on the Z. But a better solution would be nice.
Go to the top of the page
 
+Quote Post
ZDevil
post Nov 21 2007, 12:17 AM
Post #6





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



The packages will be up really soon. Now only waiting for smplayer to get packaged.
Go to the top of the page
 
+Quote Post
ZDevil
post Nov 21 2007, 02:48 PM
Post #7





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Uploaded. Please note that you also need the patched libgsf package to enable importing from Microsoft Excel.
Enjoy.
Go to the top of the page
 
+Quote Post
dlj0
post Nov 21 2007, 08:58 PM
Post #8





Group: Members
Posts: 219
Joined: 3-March 06
Member No.: 9,282



QUOTE(ZDevil @ Nov 21 2007, 05:48 PM) *
Uploaded. Please note that you also need the patched libgsf package to enable importing from Microsoft Excel.
Enjoy.


Thanks. It works perfectly. We should have you have a go with iceweasel and icedove.
Go to the top of the page
 
+Quote Post
ZDevil
post Nov 22 2007, 01:56 AM
Post #9





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



In fact I tried Iceweasel 2.0.0.9 some time ago. The build still suffered from the same mysterious seg fault without any further error message, even with the debugging package. Is there any pointer or patch to refer to? I will surely try again if there are workarounds. smile.gif
Go to the top of the page
 
+Quote Post
jpmatrix
post Nov 22 2007, 04:35 AM
Post #10





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(ZDevil @ Nov 22 2007, 10:56 AM) *
In fact I tried Iceweasel 2.0.0.9 some time ago. The build still suffered from the same mysterious seg fault without any further error message, even with the debugging package. Is there any pointer or patch to refer to? I will surely try again if there are workarounds. smile.gif


yes it is very curious because iceweasel was working just great under Debian OABI ..........
Go to the top of the page
 
+Quote Post
apink
post Mar 19 2008, 11:18 AM
Post #11





Group: Members
Posts: 105
Joined: 2-August 05
Member No.: 7,764



I am trying to get gnumeric working on debian. It is a must have for me, otherwise it is back to pdax.

I have tried several things: I successfully did apt-get gnumeric using the oregon state debian feed and manually installing an older version of gnumeric-common before installing gnumeric. But then it didn't work. The program would not recognize the "1" key blink.gif and did haywire other things.

I have tried installing ZDevil's packages, but cannot get past the libgoffice depends. apt-get reports that libgoffice-0-5 version 0.5.2 or above is required, but that version 0.5.1-2 is to be installed. I have searched the repositories for libgoffice-0-5 version 0.5.2 with no luck. I can find libgoffice-0-6 but that does not satisfy apt-get. I have tried to do apt-get install -f gnumeric but get nowhere there also.

I am sure that this is a newbie mistake as I am a tried and true newbie. Any help would be greatly appreciated.
Go to the top of the page
 
+Quote Post
ZDevil
post Mar 21 2008, 02:49 AM
Post #12





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



This seems to be a known bug in GNOME:
http://ubuntuforums.org/showthread.php?p=3777542#post3777542

I also run into a strange issue in epiphany and galeon when the num key "1" launches the help browser.

Tried the fix here: http://bugzilla.gnome.org/show_bug.cgi?id=500881 , but i can only see "1" echo as a screen output in the terminal (when gumeric is launched from the terminal) but does not actually insert "1" in gnumeric.

Any idea? :-?
Go to the top of the page
 
+Quote Post
ZDevil
post Mar 21 2008, 02:56 AM
Post #13





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Hey! This seems to work!

First install yelp (the gnome helper) if you didn't: apt-get install yelp

Second do this:
CODE
sudo mv /usr/bin/yelp /usr/bin/yelp1
sudo echo "xmodmap -e 'keysym 0x31 = 1'" > /usr/bin/yelp
sudo chmod 755 /usr/bin/yelp


Now the key "1" is recognized and is inserted as usual in gumeric.
Go to the top of the page
 
+Quote Post
ZDevil
post Mar 21 2008, 07:17 AM
Post #14





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Another update:

Don't use my packages. Now armel lenny has all the right packages in place.
So change your /etc/apt/sources.list to the official lenny feeds (see below), followed by a apt-get update
Next first apt-get remove libgoffice*
Then apt-get install gnumeric.
Apply the trick in post #13, if "1" is not recognized (but I got it working without the trick). That's it!

I've tested gnumeric 1.8.1 and it works great. wink.gif

Here is the feed I use. Quite stable and fast.
CODE
deb http://debian.ethz.ch/debian/ lenny main contrib non-free
Go to the top of the page
 
+Quote Post
apink
post Mar 22 2008, 02:02 PM
Post #15





Group: Members
Posts: 105
Joined: 2-August 05
Member No.: 7,764



QUOTE(ZDevil @ Mar 21 2008, 08:17 AM) *
Another update:

Don't use my packages. Now armel lenny has all the right packages in place.
So change your /etc/apt/sources.list to the official lenny feeds (see below), followed by a apt-get update
Next first apt-get remove libgoffice*
Then apt-get install gnumeric.
Apply the trick in post #13, if "1" is not recognized (but I got it working without the trick). That's it!

I've tested gnumeric 1.8.1 and it works great. wink.gif

Here is the feed I use. Quite stable and fast.
CODE
deb http://debian.ethz.ch/debian/ lenny main contrib non-free


Thanks for the fixes. Both work tongue.gif and I am using the debian.ethz.ch feed gnumeric.

Now some smaller gnumeric bugs that have popped up. When I enter a 4 for the first character in a cell the cell is filled with the previous value that I entered, wherever that may have been, as if I had entered the paste command. I can get around this by entering "4" as "04". Similarly when I enter a 9 for the first character in a cell nothing happens that I have detected. No 9 and no nothin else. "09" works here also, that is if the first character is not a 4 or a 9 then any succeeding characters can be a 4 or a 9. Interesting. dry.gif

I had noticed the bug with the 4 in previous gnumeric versions I was using on Lenny. I don't know if the 9 bug is new or was there also. This behavior is similar to the problem with the 1, so I would think that a kludge fix such as echo "xmodmap -e 'keysym 0x31 = 1'" > /usr/bin/yelp would do. Except yelp is not involved in this one. Any ideas are appreciated.

This is not a deal breaker for me but an annoyance I could live without.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st August 2014 - 06:05 AM