OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Tcp/ip Over Usb & Samba, Don't Work At Same Time, 3 settings need changing
Jon_J
post Oct 3 2006, 09:21 PM
Post #1





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I finally got TCP/IP over USB working by following this post:
http://www.oesf.org/forums/index.php?showtopic=18619
It uses Internet Connection Sharing in Windows.
I'm using a LAN card to connect to ADSL
To get this working, I need to do these 2 things which affect Samba.
1. Enable Internet Connection Sharing on my LAN connection.
2. Change the following settings in /etc/hotplug/usbdnet.conf

DHCPS=yes
DHCPC=no
to
DHCPS=no
DHCPC=yes

This allows me to surf over USB on my Zaurus, but "Blocks" Samba
To get Samba working again, I need to:
1. Disable Internet Connection Sharing on my LAN connection.
2. Change above settings in usbdnet.conf back to what they were originally.
3. Disable Windows firewall

This stops me from being able to go online on my Z.
I'll figure out the firewall later, but why do I need to change the other 2 settings
to get Samba working?

Also, I noticed, the IP that I usually used to connect Samba changed from
192.168.129.201
to
192.168.129.1

I have a desktop shortcut on windows that quit working because Samba's IP changes now.

Thanks for reading this,
Jon
Go to the top of the page
 
+Quote Post
Meanie
post Oct 5 2006, 05:08 AM
Post #2





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Jon_J @ Oct 4 2006, 03:21 PM)
I finally got TCP/IP over USB working by following this post:
http://www.oesf.org/forums/index.php?showtopic=18619
It uses Internet Connection Sharing in Windows.
I'm using a LAN card to connect to ADSL
To get this working, I need to do these 2 things which affect Samba.
1. Enable Internet Connection Sharing on my LAN connection.
2. Change the following settings in /etc/hotplug/usbdnet.conf

DHCPS=yes
DHCPC=no
to
DHCPS=no
DHCPC=yes

This allows me to surf over USB on my Zaurus, but "Blocks" Samba
To get Samba working again, I need to:
1. Disable Internet Connection Sharing on my LAN connection.
2. Change above settings in usbdnet.conf back to what they were originally.
3. Disable Windows firewall

This stops me from being able to go online on my Z.
I'll figure out the firewall later, but why do I need to change the other 2 settings
to get Samba working?

Also, I noticed, the IP that I usually used to connect Samba changed from
192.168.129.201
to
192.168.129.1

I have a desktop shortcut on windows that quit working because Samba's IP changes now.

Thanks for reading this,
Jon
*


just add multiple sub networks to smb.conf or don;t restrict by subnet at all and restart samba after you setup usbd and you will have both working.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th September 2014 - 07:36 AM