OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Kobo Deluxe With Sound, On an SL-5500, even!
Ikkakujyu
post Jul 15 2006, 03:43 PM
Post #1





Group: Members
Posts: 27
Joined: 20-October 04
From: San Diego, CA
Member No.: 5,122



Sooo, I'm having a ball with OZ 3.5.4 and its just-barely-usable native development chain.

Once you get it running, Kobo Deluxe compiles cleanly :D It even works with sound, at least on the Collie. The trick is not overloading the poor thing's limited memory. So far I've gotten it to work at the lowest sound quality (8khz) and al the lowest mixing quality, with reverb turned all the way off. Trying to enable the music made it segfault :( which is a real shame.

There is no noticeable slowdown when the sound is enabled, however :D

The important thing to note is that Kobo Deluxe creates its sound files at runtime, and that it uses a lot of floating-point operations for this... it's also caused trouble with the PlayStation2 port. So it takes a -really- long time to load the sounds, and the Zaurus stops responding while this is going.

Also note that the first time you run it, you have to use the -fullscreen and -nosound options, or else you won't be able to set everything up correctly.

I'd make an IPK for everyone but I have no idea how :/
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 11:55 AM