OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Mod Libdirectfb & Libts Packages, ... will fix apt-get dist-upgrade issues
ZDevil
post Apr 13 2008, 01:08 AM
Post #1





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Those who are using my rootfs tarball, which contains lots of goodies made by 2or0, may encounter errors while doing apt-get dist-upgrade because of some differences in the dependencies in 2or0's repackaged Angstrom .debs and the packages from the Debian repos, which causes conflicts and subsequently failure in the upgrading process.

I've repackaged the .debs from the Debian feeds, basically just changing the versions in the Depends line and the package versions.
Using these will prevent such error from showing up. Have tested in on two rootfs and the trick works. wink.gif

How?
Super easy. Just install these two packages BEFORE apt-get dist-upgrade:


Attached File(s)
Attached File  libdirectfb_1.0_0_1.0.1_7_armel.deb ( 1.06MB ) Number of downloads: 85
Attached File  libts_1.0_0_2.0_1_armel.deb ( 28.65K ) Number of downloads: 71
 
Go to the top of the page
 
+Quote Post
ArchiMark
post Apr 13 2008, 10:52 AM
Post #2





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(ZDevil @ Apr 13 2008, 02:08 AM) *
Those who are using my rootfs tarball, which contains lots of goodies made by 2or0, may encounter errors while doing apt-get dist-upgrade because of some differences in the dependencies in 2or0's repackaged Angstrom .debs and the packages from the Debian repos, which causes conflicts and subsequently failure in the upgrading process.

I've repackaged the .debs from the Debian feeds, basically just changing the versions in the Depends line and the package versions.
Using these will prevent such error from showing up. Have tested in on two rootfs and the trick works. wink.gif

How?
Super easy. Just install these two packages BEFORE apt-get dist-upgrade:



Thanks, ZDevil for this....

Just installed the 2 debs....

When I installed the second deb (libts_1.0_0_2.0_1_armel.deb) it asked me whether I wanted to keep the current 'ts.conf' file or use the one in the package.

I assumed that I should use the 'ts.conf' file in your new package, so replaced file with new one. Was that correct to do?

Started up XFCE4, it started up rotated for portrait not landscape now....

Also, does not respond to stylus taps....

Was I supposed to do anything else after installing these 2 packages?

Thanks.
Go to the top of the page
 
+Quote Post
ZDevil
post Apr 13 2008, 11:15 AM
Post #3





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



Yes, better use the ts.conf from the package.
Tell me what you have in ~/.profile. It should contain a line about your touchscreen setup. This is mine:
CODE
export TSLIB_TSDEVICE="/dev/input/ts0"

Also make sure that /usr/lib/ts and the files under it are present.
To rotate the screen is easy: xrandr -o right (= landscape); xrandr -o normal (= portrait). If that's not the case for you just play with the xrandr option (left, right, normal, inverted).
Go to the top of the page
 
+Quote Post
ArchiMark
post Apr 13 2008, 12:24 PM
Post #4





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(ZDevil @ Apr 13 2008, 12:15 PM) *
Yes, better use the ts.conf from the package.
Tell me what you have in ~/.profile. It should contain a line about your touchscreen setup. This is mine:
CODE
export TSLIB_TSDEVICE="/dev/input/ts0"


Ummm... I don't have a '.profile' file....I have the following in my ~ directory:
CODE
  
.ICEauthority
.Xauthority
.bash_history
.bash_logout
.bash_profile
.bashrc
[quote].cache
.dbus
.local
.xsession
.xsession-errors


I did check the .bash_profile and .bashrc, but don't see anything in those files about the touchscreen....



QUOTE
Also make sure that /usr/lib/ts and the files under it are present.


That directory is there and has the following files in it:

artic2.so
collie.so
corgi.so
dejitters.so
h8600.so
input.so
linear.so
linear_h2200.so
mk712.so
pthres.so
ucb1x00.so
variance.so


QUOTE
To rotate the screen is easy: xrandr -o right (= landscape); xrandr -o normal (= portrait). If that's not the case for you just play with the xrandr option (left, right, normal, inverted).


Yes, understand and have used 'xrandr -o right' somewhere, don't remember which file right now.... my point about this was that it was rotated correctly before, but now it's not....

Thanks.
Go to the top of the page
 
+Quote Post
ZDevil
post Apr 13 2008, 12:52 PM
Post #5





Group: Members
Posts: 2,003
Joined: 16-April 04
From: the Netherlands && /dev/null
Member No.: 2,882



QUOTE(ArchiMark @ Apr 13 2008, 10:24 PM) *
QUOTE(ZDevil @ Apr 13 2008, 12:15 PM) *
Yes, better use the ts.conf from the package.
Tell me what you have in ~/.profile. It should contain a line about your touchscreen setup. This is mine:
CODE
export TSLIB_TSDEVICE="/dev/input/ts0"

Ummm... I don't have a '.profile' file....

Then just create ~/.profile and put the line there.
Log out and log in again.
Run "ts_calibrate".
Start X again.
See if stylus works.
Go to the top of the page
 
+Quote Post
ArchiMark
post Apr 13 2008, 02:08 PM
Post #6





Group: Members
Posts: 1,010
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



QUOTE(ZDevil @ Apr 13 2008, 01:52 PM) *
QUOTE(ArchiMark @ Apr 13 2008, 10:24 PM) *
QUOTE(ZDevil @ Apr 13 2008, 12:15 PM) *
Yes, better use the ts.conf from the package.
Tell me what you have in ~/.profile. It should contain a line about your touchscreen setup. This is mine:
CODE
export TSLIB_TSDEVICE="/dev/input/ts0"

Ummm... I don't have a '.profile' file....

Then just create ~/.profile and put the line there.
Log out and log in again.
Run "ts_calibrate".
Start X again.
See if stylus works.


OK, I created '.profile' as you instructed, logged out and back in....

Tried to run 'ts_calibrate' and get the following:

CODE
#ts_calibrate
ts_calibrate: error while loading shared libraries:
libts-1.0.s0.0: can't open shared object file: No such file or directory


?????

Thanks.
Go to the top of the page
 
+Quote Post
rogalian
post Apr 14 2008, 05:16 AM
Post #7





Group: Members
Posts: 12
Joined: 30-January 08
Member No.: 21,303



Please tell me you'll be submitting the patches to Debian upstream? smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st April 2014 - 06:43 AM