OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Help With Compile Of Pine Email, command line email r/w'er
gtrinka
post Jul 31 2005, 03:17 AM
Post #1





Group: Members
Posts: 3
Joined: 31-July 05
Member No.: 7,745



Hi all, I have patched some great changes to the version 4.63 of pine. I can't get the
project to compile for arm-linux however. Don't know enough about the config and
make files. Will anyone take this mini-project on and compile this great command line
email reader (with static libs) for the C3000 Linux zaurus 2.4.20 ? Let's make this free software from washington.edu available for the greater Z. community! Code attached - may need ssh lib's.
NOTE: an older version of pine is available from http://www.killefiz.de/zaurus/showdetail.php?app=1053

Thanks, for any and ALL help
Attached File(s)
Attached File  pine4.63.tar.gz ( 4.03MB ) Number of downloads: 67
 
Go to the top of the page
 
+Quote Post
Mickeyl
post Aug 1 2005, 12:51 AM
Post #2





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



Phew. This thing for sure has an ugly buildsystem. I've added pine 4.63 to OE, see http://monotone.vanille.de/viewmtn/revisio...4387a817b24d046
Go to the top of the page
 
+Quote Post
gtrinka
post Aug 4 2005, 12:51 PM
Post #3





Group: Members
Posts: 3
Joined: 31-July 05
Member No.: 7,745



Hi Mickey, thanks for your efforts in cleaning up the build struc, how can a retrieve the linux exec for pine and pico from the link you included in your message?

GT

QUOTE(Mickeyl @ Aug 1 2005, 12:51 AM)
Phew. This thing for sure has an ugly buildsystem. I've added pine 4.63 to OE, see http://monotone.vanille.de/viewmtn/revisio...4387a817b24d046
*
Go to the top of the page
 
+Quote Post
Mickeyl
post Aug 5 2005, 03:46 AM
Post #4





Group: Members
Posts: 1,497
Joined: 12-November 03
From: Germany
Member No.: 907



Try http://www.vanille.de/temp/sharprom/
Go to the top of the page
 
+Quote Post
herbieach
post Aug 21 2005, 07:56 PM
Post #5





Group: Members
Posts: 4
Joined: 14-February 05
Member No.: 6,471



Hi Mickey & gtrinka,

I installed the pine/pico/opensll ipkgs on my 5500 running OZ 3.5.3. I'm assuming that because they were built via OE that this should work, but I'm getting the following error:

<program name unknown>: symbol lookup error: <main program>: undefined symbol: __modsi3

So I'm wondering now if my assumption is incorrect and this is a special build for the 3000 as requested or if I'm missing something.
Go to the top of the page
 
+Quote Post
lardman
post Aug 22 2005, 02:38 AM
Post #6





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Don't install the binaries from http://www.vanille.de/temp/sharprom/ as this is built for the Sharp ROM; either build it yourself using OE (as it's been added thanks to Mickeyl) or ask Hrw to add it to the upgrades feed (thread in OZ/Common).


Si
Go to the top of the page
 
+Quote Post
herbieach
post Aug 22 2005, 03:38 AM
Post #7





Group: Members
Posts: 4
Joined: 14-February 05
Member No.: 6,471



Ok thanks. I'll drop Hrw a note after I get back from vacation later this week . . . or maybe he'll see this and compile it if he has time.

Big thanks for Mickey for getting it into OE.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th November 2014 - 08:27 PM