OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Resolution/Rotation
jagrka
post Jun 25 2004, 05:59 AM
Post #1





Group: Members
Posts: 80
Joined: 23-February 04
From: Tokyo, Japan
Member No.: 2,006



I have some applications that open from the launcher on my SL-C760 into portrait mode at 360X240 resolution. They do not have checkboxes to change the resolution that are accessible by holding the stylus on the icon. Obviously, there were meant to work on an older model Zaurus, and not one of the new VGA models.

However, if I execute the same application from the console, they open in 720x360/landscape mode without any problem. Why is it that launching an application from an icon in Qtopia's launcher forces this change in resolution and rotation? Is there anyway to launch the application from within Qtopia without it switching? Is this issue in any way related to SDL?
Go to the top of the page
 
+Quote Post
bluedevils
post Jun 25 2004, 07:41 AM
Post #2





Group: Members
Posts: 1,284
Joined: 31-January 04
From: Vancouver, BC -> NYC, NY
Member No.: 1,633



you could modify the *.desktop file under /home/QtPalmtop/apps/Settings
Display=640x480/144dpi, 480x640/144dpi

There is also a way to force the app to give you the magnified option, but I am sleep deprived right now...
Go to the top of the page
 
+Quote Post
jagrka
post Jun 25 2004, 09:07 PM
Post #3





Group: Members
Posts: 80
Joined: 23-February 04
From: Tokyo, Japan
Member No.: 2,006



I had already tried adding the display line to the *.desktop file, but it doesn't work. If there is a way to force the app to give the magnified option, I would appreciate knowing how to to do this. Thanks!
Go to the top of the page
 
+Quote Post
Stubear
post Jun 26 2004, 05:42 AM
Post #4





Group: Members
Posts: 1,164
Joined: 17-December 03
From: Melbourne, AUSTRALIA
Member No.: 1,219



QUOTE(jagrka @ Jun 26 2004, 02:07 PM)
I had already tried adding the display line to the *.desktop file, but it doesn't work. If there is a way to force the app to give the magnified option, I would appreciate knowing how to to do this. Thanks!

Did you restart qtopia after adding the line?

Qtopia reads the desktop files at start up, changing them Display line wont take effect till it rereads them via a restart, or adding new apps or using the tab-manager. Changing themes might also work but not sure

Stu
Go to the top of the page
 
+Quote Post
Fromwithin
post Jun 26 2004, 09:11 AM
Post #5





Group: Members
Posts: 59
Joined: 17-February 04
From: Wirral, UK
Member No.: 1,907



You don't actually need to add new apps...I just open Tab Manager and then press okay.
Go to the top of the page
 
+Quote Post
jagrka
post Jun 26 2004, 04:27 PM
Post #6





Group: Members
Posts: 80
Joined: 23-February 04
From: Tokyo, Japan
Member No.: 2,006



Thanks! A restart made the difference.
Go to the top of the page
 
+Quote Post
jagrka
post Jul 18 2004, 05:02 AM
Post #7





Group: Members
Posts: 80
Joined: 23-February 04
From: Tokyo, Japan
Member No.: 2,006



I have been able to change the resolution/rotation of applications from the launcher by adding the above line to the .desktop files, but I'm now wondering how one can return to the unmagnified/portrait display? Removing this line from .desktop files does not result in the files launching in their original resolution/rotation. I tried editing the display line, but to no effect. Even if I uninstall, and then reinstall an application it is now locked into the unmagnifed/landscape display. How do I get a program to return to running in its original magnified display on my SL-C760?
Moreover, I recall that when I originally purchased by Zaurus in Japan, I was able to change the resolution/rotation using the display checkbox that appears when one taps-holds on an icon. Now, none of my applications even display this option any longer. Is there a line that can be inserted into the .desktop file that will force the display of this option? Why did this option disappear from all my applications?
I've tried finding the answers to these questions here and throughout the WWW, but was unsuccessful. I would appreciate any advise. Thank you.
Go to the top of the page
 
+Quote Post
g333
post Dec 26 2004, 03:46 PM
Post #8





Group: Members
Posts: 196
Joined: 8-December 04
Member No.: 5,853



How do I remove the line
OnlyWithDisplay=640x480/144dpi,480x640/144dpi


from the _7x009rotate.desktop file under /home/QtPalmtop/apps/Settings

ZEditor doesn't work
Go to the top of the page
 
+Quote Post
bethanyb
post Feb 21 2005, 10:55 PM
Post #9





Group: Members
Posts: 20
Joined: 3-February 05
From: Berkeley, CA
Member No.: 6,402



Is the magnified display option supposed to show up with every icon when you hold down on it? I have a c860 Z with Sharp ROM. I installed an application, and unchecked the magnified display option. When I uninstalled it, I had problems with the screen not rotating. I had to do a hard reset to fix it. I'd like to know why the screen rotations got screwed up and why I was unable to find the magnified display option afterwards. But since I'm new to Linux, maybe it's better not to know.
Go to the top of the page
 
+Quote Post
g333
post Feb 22 2005, 05:31 AM
Post #10





Group: Members
Posts: 196
Joined: 8-December 04
Member No.: 5,853



I think so but I have a SL-C3000.
Go to the top of the page
 
+Quote Post
Snappy
post Jan 29 2007, 09:01 AM
Post #11





Group: Members
Posts: 793
Joined: 28-November 04
From: NM, US, sometimes Asia
Member No.: 5,633



QUOTE(g333 @ Dec 27 2004, 07:46 AM)
How do I remove the line
OnlyWithDisplay=640x480/144dpi,480x640/144dpi


from the _7x009rotate.desktop file under /home/QtPalmtop/apps/Settings

ZEditor doesn't work
*


I chanced upon this thread while looking for rotation handling.

This is like utterly belated, but I think it's because zeditor does not have root rights. Press and hold the zeditor icon and allow it root access. smile.gif

For the magnification bit, if anymore help is still needed, buzz here.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th December 2014 - 04:28 AM