OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Zubuntu Rotation - Doesn't On Sl-c860
zmike
post Jan 14 2009, 06:05 PM
Post #1





Group: Members
Posts: 77
Joined: 15-January 04
Member No.: 1,206



Regarding rotation, I saw some references to x11-xserver-utils and xrandr to get rotation working.
I have both but changing the orientation of my SL-C860 doesn't do anything.

Is there something I'm missing?

Thanks!
Mike
Go to the top of the page
 
+Quote Post
Capn_Fish
post Jan 14 2009, 07:31 PM
Post #2





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



I suspect the /etc/zaurusd/... scripts aren't correct for the SL-Cxx0 models, and I don't know how to fix them (you could try taking them from Angstrom, I believe they work there).

Have you tried manually doing the rotation, eg:

CODE
xrander -o n


where 0 <= n <= 3?
Go to the top of the page
 
+Quote Post
zmike
post Jan 14 2009, 07:58 PM
Post #3





Group: Members
Posts: 77
Joined: 15-January 04
Member No.: 1,206



Thanks for the reply!
doing a manual rotate works but swinging the screen does nothing.
1 - portrait
0 - landscape

The events don't seem to trigger.

- Mike
Go to the top of the page
 
+Quote Post
cortez
post Jan 14 2009, 10:32 PM
Post #4





Group: Members
Posts: 376
Joined: 18-March 04
From: The Netherlands
Member No.: 2,380



You're right, the hinge detection is b0rked somehow. I will have a look to find out if this can easily be fixed.
The same applies by the way to the Spitz and Akita models, auto-rotation doesn't work on these either.
Go to the top of the page
 
+Quote Post
brontoZaurus
post Jul 23 2009, 02:33 AM
Post #5





Group: Members
Posts: 47
Joined: 18-February 09
Member No.: 31,414



something about landscape mode in console-only mode, it boots in portrait mode and this trick is only for X i think
Go to the top of the page
 
+Quote Post
YoG
post Jul 23 2009, 11:47 AM
Post #6





Group: Members
Posts: 56
Joined: 12-November 05
From: Israel
Member No.: 8,524



QUOTE(Capn_Fish @ Jan 15 2009, 06:31 AM) *
I suspect the /etc/zaurusd/... scripts aren't correct for the SL-Cxx0 models, and I don't know how to fix them (you could try taking them from Angstrom, I believe they work there).

Have you tried manually doing the rotation, eg:

CODE
xrander -o n


where 0 <= n <= 3?


I think the problem is with the X authorization. Run:

CODE
xhost +


this will enable free access to the X server.
Also, I don't remember, but I think the states were switched in /etc/zaurusd/scripts/zaurus-hinge.conf in my case state 0 is landscape and state 2 is portrait.

update:
After rebooting there was no problem with the authorization.

YoG.
Go to the top of the page
 
+Quote Post
brontoZaurus
post Jul 23 2009, 11:25 PM
Post #7





Group: Members
Posts: 47
Joined: 18-February 09
Member No.: 31,414



Ok, thanks man, i´ll give a try and post feedback!

Edited:

the main problem was that when is booting, THAT shell, boots in portrait mode, i have used only the RC1 filesystem and 2.6.31 rc3 Kernel and modules from cortez´s blog.
i need to use some patches or soż?
today i have 8.04 running from microdrive working flawesly but i would like to upgrade. ext4 support, performance...
Go to the top of the page
 
+Quote Post
YoG
post Jul 24 2009, 07:36 AM
Post #8





Group: Members
Posts: 56
Joined: 12-November 05
From: Israel
Member No.: 8,524



QUOTE(brontoZaurus @ Jul 24 2009, 10:25 AM) *
...boots in portrait mode...


Well, to solve this all I had to do was to remove
CODE
xrandr -o right

form ~/.xinitrc

YoG
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th October 2014 - 07:14 AM