OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3  
Reply to this topicStart new topic
> Compile Problem - Dev_img-1.5, Compiler Error Messages
qx773
post Aug 31 2005, 07:24 PM
Post #31





Group: Members
Posts: 219
Joined: 10-February 04
Member No.: 1,807



Here is a recap of what I did to get dev-img-1.5 working on my C760:

I initially failed to use the image_setup.sh script correctly and had to manually delete multiple incorrect lines from /etc/fstab. I ended up having to do the configuration manually.

I originally did not understand the reason for having a /mnt/dev mount point that is different from "/home/zaurus/develop" in the image_setup.sh script. Why not just mount the "dev_img-1.5" file directly to "/home/zaurus/develop"? The answer is at the end.

Here are the steps that I had to use to get the compiler working on my Sharp ROM on my Zaurus SL-C760's SD card:

Unzip the dev-img-1.5.zip file to /mnt/card

Execute the commands:
cd /home/zaurus
mkdir develop
su root

Add the following line to "/etc/fstab":
CODE
/usr/mnt.rom/card/dev_img-1.5   /home/zaurus/develop  cramfs  auto,loop  0 0


Execute:
mount develop (still as the root user, while your current directory is /home/zaurus)

Add the following line to ".bashrc":
CODE
export PATH="$PATH:/home/zaurus/develop/bin"


exit (to stop being the root user)
exit (to exit the terminal program and go back into Qtopia)

Go back in the terminal so that the new .bashrc can take effect.

Execute:
echo $PATH ("/home/zaurus/develop/bin" should appear in the path, otherwise edit .bashrc again)
su root
compiler_setup.sh
exit (to stop being the root user)

The compiler_setup.sh script is located in /home/zaurus/develop/bin once /home/zaurus/develop is mounted.

Try to compile a "Hello, World!" program.

I find that /home/zaurus/develop does not automatically mount on a reboot. I keep having to "su root; mount develop; exit".

I learned today that a program called autoconf is hard-coded to look in "/mnt/dev/bin" for a file that is in "/home/zaurus/develop/bin". That means that you have to execute commands like:

su root
cd /mnt
ln -s /home/zaurus/develop dev
exit


to link /mnt/dev to /home/zaurus/develop.
Go to the top of the page
 
+Quote Post

3 Pages V  < 1 2 3
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th November 2014 - 10:59 PM