OESF | ELSI (coming soon) | Community Links (coming soon) | LinuxPDA | Ibiblio


Welcome Guest ( Log In | Register )

Personal Photo
Personal Statement
ArchiMark doesn't have a personal statement currently.
Personal Info
Age Unknown
Gender Not Set
Silicon Valley
Birthday Unknown
No Information
Joined: 25-June 03
Profile Views: 26,053*
Last Seen: Today, 10:45 AM
Local Time: Jun 25 2017, 12:07 PM
1,362 posts (0 per day)
Contact Information
AIM No Information
Yahoo No Information
ICQ 250278680
MSN No Information
* Profile views updated each hour



My Content
7 Apr 2017

For fun I took a few family portrait photos of my current mini mobile computing devices (not including phones...).

Think I've pretty much covered all the bases, as we say, size-wise....from Zaurus up to 10" ideapad Flex 10 and everything inbetween.

Hope you can recognize the devices.....

Enjoy the pics!


17 Oct 2016
Now that I have Fluxbox setup and running OK, I've been trying to install some programs with mixed results.

Have installed some programs OK, but some give me error message after trying to install:

Could not fork a new process (cannot allocate memory)

Is this a result of Zaurus having limited RAM or ?

Anything I can do about it?

With some programs, when I open them, I get error message:

GLib-GObject-CRITICAL **:
assertion 'G_IS_OBJECT (object)' failed

Then some other error message that varies by program being opened.

Any ideas about this one?

Have tried running Firefox, but get error message:

XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
Cannot open shared object file:
No such file or directory
Could not load XPCOM

I searched on this error and it was common a few years ago with Firefox. Some people said removing FF and reinstalling worked for them. Tried that, but same error.

Some said to install xulrunner, ia32-libs, and ia32-libs.gtk

Tried installing xulrunner, got the memory error noted above.

When I run xulrunner, I get following error message:

$ xulrunner
XPCOMGlueLoad error for file /usr/lib/xulrunner-41.0.2/libxul.so:
libcui18n.so.57: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

Any input on any of these errors would be greatly appreciate.


28 Sep 2016

Hopefully, some will see this post.....

After quite a while that OESF went down, it has been resurrected!

Enjoy your Zaurii!

10 Nov 2015
Found what appears to be a nice little outliner app but having an issue getting it installed....

Maybe someone can advise....

App installation instructions can be found here:


When I do 'make' (from inside beeswax directory) I get:

# make
beeswax build options:
CFLAGS   = -Os -I, -I/usr/include -I/usr/include/libxml2 -DIVERSION="0.2.0"
LDFLAGS = -s -L/usr/lib -lxml2 -lz -ldl -lncurses -lreadline -luuid
CC          =  cc
CC main.c
In file included from main.c:22:0:
beeswax.h:20:28: fatal error:  ncurses/curses.h: No such file or directory
compilation terminated.
Makefile:21: recipe for target 'main.o' failed
make: *** [main.o] Error 1

Per comment in instructions for installing on Mac OSX, I changed the line in 'beeswax.h' file to say 'ncurses' instead of 'ncursesw' as there is no 'ncursesw' available for ALARM that I can find either via pacman or packer.

Also, I set the development flags to be like this (taken from planetofidiots.com):

export CPPFLAGS=""
export CFLAGS="-mcpu=xscale -mtune=xscale -O2"
export CXXFLAGS="-mcpu=xscale -mtune=xscale -O2"

The 'fatal error' refers to 'ncurses/curses.h' not being found. In the beeswax directory I do not see a 'curses.h' file, but I do see a 'curses.c' file.

Any suggestions?


Last Visitors

13 Apr 2017 - 11:10

30 Dec 2016 - 15:53

8 Nov 2016 - 20:31

2 Nov 2016 - 4:17

30 Sep 2016 - 13:09

Other users have left no comments for ArchiMark.


1248 posts
Active: 3rd November 2015 - 06:01 AM

60 posts
Active: 4th October 2008 - 02:32 PM

304 posts
Active: 5th April 2014 - 04:05 PM
View All Friends
RSS Lo-Fi Version Time is now: 25th June 2017 - 11:07 AM