OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

8 Pages V  « < 6 7 8  
Reply to this topicStart new topic
> [new] Kernel 2.6.24.4 With Cpufreq, Updated: Jul. 16 2008
xamindar
post Sep 6 2008, 10:52 PM
Post #106





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



Yep, it was the module package with the iptables modules. Switch back to the previous module pack that he has here: http://yonggun.tistory.com/72
and you will have working wifi again. Maybe he will get back to making a new iptables pack for us later on. Or you can maybe try just extracting the iptables modules only if you want to use them.

Either way, this kernel actually works better than the 2.6.24.3 kernel for me now.
Go to the top of the page
 
+Quote Post
speculatrix
post Sep 7 2008, 01:56 PM
Post #107





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(xamindar @ Sep 7 2008, 07:52 AM) *
Or you can maybe try just extracting the iptables modules only if you want to use them.


if the kernels are close versions and compiled with the same tools you can almost certainly get away with force-loading the modules you want into the kernel you know is stable!
Go to the top of the page
 
+Quote Post
bon_the_one
post Sep 9 2008, 06:31 AM
Post #108





Group: Members
Posts: 4
Joined: 21-August 08
From: Gibraltar
Member No.: 22,234



Hi,

I've flashed my SL-C3000 with the zImage from http://yonggun.tistory.com/72 and used the modules from that same page, release Aug 6th.

I've also unpacked a related root fs tar from a related thread.

However whenever I try to use networking (g_ether or dm9601) I get a kernel panic and the Z crashes.

Has anyone seen this before, and could you please suggest anything? Perhaps I am using the wrong root fs tarball, so if anyone could please point me at the correct one I 'should' be using that would be a great help.

Many Thanks,

Bon

Go to the top of the page
 
+Quote Post
xamindar
post Sep 10 2008, 12:30 AM
Post #109





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



QUOTE(bon_the_one @ Sep 9 2008, 07:31 AM) *
Hi,

I've flashed my SL-C3000 with the zImage from http://yonggun.tistory.com/72 and used the modules from that same page, release Aug 6th.

I've also unpacked a related root fs tar from a related thread.

However whenever I try to use networking (g_ether or dm9601) I get a kernel panic and the Z crashes.

Has anyone seen this before, and could you please suggest anything? Perhaps I am using the wrong root fs tarball, so if anyone could please point me at the correct one I 'should' be using that would be a great help.

Many Thanks,

Bon

bon_the_one, you have GOT to be kidding. Did you even bother to read the last four posts?
Go to the top of the page
 
+Quote Post
bon_the_one
post Sep 10 2008, 04:34 AM
Post #110





Group: Members
Posts: 4
Joined: 21-August 08
From: Gibraltar
Member No.: 22,234




Bon[/quote]
bon_the_one, you have GOT to be kidding. Did you even bother to read the last four posts?
[/quote]

Sorry, I assumed that was just related to wifi which I'm not using, I'll have another kick about with it and see what I get.

Cheers,

Bon
Go to the top of the page
 
+Quote Post
xamindar
post Sep 10 2008, 10:23 AM
Post #111





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368





I would recommend just unpacking the module pack from before august 6th (the old modules) from that same page into your modules directory, that should get them working and still leave the iptables ones there. I haven't tried the iptables modules so no idea if they even work.
Go to the top of the page
 
+Quote Post
bon_the_one
post Sep 10 2008, 01:07 PM
Post #112





Group: Members
Posts: 4
Joined: 21-August 08
From: Gibraltar
Member No.: 22,234



Hey Man,

Thanks for getting back to me! Having taken your (slightly hard) advice, I've gone back thru the posts and read more. I should have done before but sometimes I get lost on this board layout for some reason. Doh!

I'd kinda surfed and assumed that the posts recently related to Wifi mainly, and didn't really understand the stack discussed could hit all network hardware. I'm totally new to this having given up on Angstrom, and Titchy, while seeming sexy doesn't work for me yet (probably more reading issues!)

Now I've basically just cleared out the Z internal disk again and untarred the rootfs again and dropped in the previous version of the 'modules' build. Then Re-flashed (just to be sure) and it's alive! I'm only tinkering at the moment, but this is a lot more useful than GPE or OPIE on the Angstrom distros which is what caught my eye initially. My dm9601 works sweet, and all is good.

I did slighty bork it earlier, but maybe I'm just unlucky. I'm based in Spain and had real problems connecting to armel-debs.applieddata.net, so I tweaked the sources.list to use mirrors.eu.kernel.org. That seemed to work until I did a dist-upgrade, at which point I got major problems with libts arguing about 1.0-0 and 0.0-0. I'll have a look more on this one, but at the mo I'm just reinstalling the default, and will avoid dist-upgrade for now!

In the meantime, thanks for your advice, I appreciate it, and I'm glad I got it sorted before the LHC sucks us all into a Black Hole. That would have really pissed me off, the Zau still being useless and dying on the same day!! Also, Happy National Day from Gibraltar (The Country I work in) ((Sometimes!))

Bon




QUOTE(xamindar @ Sep 10 2008, 10:23 AM) *
I would recommend just unpacking the module pack from before august 6th (the old modules) from that same page into your modules directory, that should get them working and still leave the iptables ones there. I haven't tried the iptables modules so no idea if they even work.

Go to the top of the page
 
+Quote Post
gojira
post Dec 15 2008, 10:46 PM
Post #113





Group: Members
Posts: 124
Joined: 16-January 05
Member No.: 6,248



could you please add drivers/usb/serial/cp2101.ko to your modules build? thanks!

Go to the top of the page
 
+Quote Post
gojira
post Dec 19 2008, 04:55 AM
Post #114





Group: Members
Posts: 124
Joined: 16-January 05
Member No.: 6,248



QUOTE(ecc_hy @ Mar 28 2008, 03:28 PM) *
Sometimes I get message:
Unkwnon HZ value! (87) Assume 100.

Why?


upgrade procps
Go to the top of the page
 
+Quote Post
gojira
post Dec 19 2008, 05:03 AM
Post #115





Group: Members
Posts: 124
Joined: 16-January 05
Member No.: 6,248



does anyone know what build environment is used for these kernels? thanks!
Go to the top of the page
 
+Quote Post
gojira
post Jan 29 2009, 05:42 AM
Post #116





Group: Members
Posts: 124
Joined: 16-January 05
Member No.: 6,248



QUOTE(gojira @ Dec 16 2008, 05:46 PM) *
could you please add drivers/usb/serial/cp2101.ko to your modules build? thanks!


turns out it's quick and easy enough to build a single module natively on the z, so if you just need a module, download the kernel source and do it yourself in the usual way. for building the whole kernel however I'd still like to know what cross-compiling environment is used
Go to the top of the page
 
+Quote Post
radiochickenwax
post Jan 30 2009, 12:26 AM
Post #117





Group: Members
Posts: 158
Joined: 21-November 04
Member No.: 5,548



QUOTE(gojira @ Jan 29 2009, 01:42 PM) *
still like to know what cross-compiling environment is used


Codesourcery toolchain... try post #8 from the following link:

http://www.oesf.org/forum/index.php?showtopic=25922
Go to the top of the page
 
+Quote Post

8 Pages V  « < 6 7 8
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th December 2014 - 06:23 PM