OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Compiling Wmii On Pdaxii13, compiling wmii on pdaxii13
renick
post Aug 9 2007, 08:20 AM
Post #1





Group: Members
Posts: 11
Joined: 12-January 07
Member No.: 13,884



I'm trying to compile wmii on pdaxii13 (sl-c3200):

http://www.suckless.org/wiki/wmii

When I try make, I'm getting this error:

CODE
LD cmd/wmiir.o
/opt/native/arm/3.4.6-xscale-softvfp/lib/gcc/armv5tel-cakco-linux/3.4.6/../../../../armv5tel-cacko-linux/bin/ld: cannot find -lc
collect2: ld returned 1 exit status
make[1]: *** [wmiir.o] Error 1
make: *** [dall] Error 2


The source compiled fine on my Ubuntu machine. Any ideas? Have I failed to install some other package that I need?
Go to the top of the page
 
+Quote Post
Capn_Fish
post Aug 9 2007, 08:32 AM
Post #2





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Looks like it's looking for libc. I don't know if that is in the feed, or if you need to build it.
Go to the top of the page
 
+Quote Post
renick
post Aug 9 2007, 05:22 PM
Post #3





Group: Members
Posts: 11
Joined: 12-January 07
Member No.: 13,884



QUOTE(Capn_Fish @ Aug 10 2007, 01:32 AM)
Looks like it's looking for libc. I don't know if that is in the feed, or if you need to build it.
*


I have glibc 2.2.5 installed. Is it not the same thing? I'm using the squashfs from here:

http://www.tyrannozaurus.com/feed/pdaXii13/build/
Go to the top of the page
 
+Quote Post
Meanie
post Aug 10 2007, 07:37 PM
Post #4





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



just remove the -lc from the Makefile and run make again
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2014 - 01:22 PM