OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Install Bug In Cortez's Updater.sh
speculatrix
post Apr 10 2008, 09:51 AM
Post #1





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



so, I'm setting up dual booting, but didn't get it quite right, and needed to put the sharp kernel back. I used cortez's updater.sh, put the zImage.bin onto the memory card with it, and kicked it off*

it flashed the kernel no problem. when it said "format hard drive" I hit CTRL-C, no effect, so then I typed N and hit return, and it proceeded to format the hard drive. ARRRGHHH! ph34r.gif

sigh.
Go to the top of the page
 
+Quote Post
speculatrix
post Apr 10 2008, 09:53 AM
Post #2





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



damn, it didn't just format it, it repartitioned the hard drive too!
Go to the top of the page
 
+Quote Post
Capn_Fish
post Apr 10 2008, 12:12 PM
Post #3





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Ouch. I hope you have backups and/or nothing important on your hard drive.
Go to the top of the page
 
+Quote Post
speculatrix
post Apr 10 2008, 01:07 PM
Post #4





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(Capn_Fish @ Apr 10 2008, 09:12 PM) *
Ouch. I hope you have backups and/or nothing important on your hard drive.


fortunately, nothing too important as I'd flattened it when installing cortez's android.

it's kind of funny, really, as I'd installed cacko with katastrphos kernel + new modules + kat's WM sound driver and got it just right. then I'd partitioned the microdrive, formatted it, copied on all the debian files, added the new kernel, copied over kat's sharp kernel, put a few scripts in place, and then installed the yonggun kernel, and so was on the very last stage to have dual booting ready. booted the new yonggun kernel but it wouldn't mount the hard drive 'cos I'd forgotten to put journalling on, so I had to restore sharp kernel to boot cacko to turn on journalling. So, I was at the very very last step when I wiped out the entire debian install blink.gif
Go to the top of the page
 
+Quote Post
cortez
post Apr 10 2008, 11:07 PM
Post #5





Group: Members
Posts: 376
Joined: 18-March 04
From: The Netherlands
Member No.: 2,380



QUOTE(speculatrix @ Apr 10 2008, 11:07 PM) *
QUOTE(Capn_Fish @ Apr 10 2008, 09:12 PM) *
Ouch. I hope you have backups and/or nothing important on your hard drive.


fortunately, nothing too important as I'd flattened it when installing cortez's android.

it's kind of funny, really, as I'd installed cacko with katastrphos kernel + new modules + kat's WM sound driver and got it just right. then I'd partitioned the microdrive, formatted it, copied on all the debian files, added the new kernel, copied over kat's sharp kernel, put a few scripts in place, and then installed the yonggun kernel, and so was on the very last stage to have dual booting ready. booted the new yonggun kernel but it wouldn't mount the hard drive 'cos I'd forgotten to put journalling on, so I had to restore sharp kernel to boot cacko to turn on journalling. So, I was at the very very last step when I wiped out the entire debian install blink.gif


The installer asks whether or not you would like to format the internal drive. Only 'y', 'n' and the Enter key are accepted as input. The Enter key accepts the default, in the case of disk formatting this is (unfortunately for you) 'y'. I guess pressing Ctrl+C contains the Enter-keycode? Or did you press Enter after the Ctrl+C? Anyhow, you haven't convince me that this is a bug dry.gif . I could of course set the default to 'n', just to prevent any more harm.
Go to the top of the page
 
+Quote Post
speculatrix
post Apr 11 2008, 02:38 AM
Post #6





Group: Admin
Posts: 3,281
Joined: 29-July 04
From: Cambridge, England
Member No.: 4,149



QUOTE(cortez @ Apr 11 2008, 08:07 AM) *
The installer asks whether or not you would like to format the internal drive. Only 'y', 'n' and the Enter key are accepted as input. The Enter key accepts the default, in the case of disk formatting this is (unfortunately for you) 'y'. I guess pressing Ctrl+C contains the Enter-keycode? Or did you press Enter after the Ctrl+C? Anyhow, you haven't convince me that this is a bug dry.gif . I could of course set the default to 'n', just to prevent any more harm.


er, I think any program feature which will let a user completely destroy the contents of the computer as the default action is a bug, not a feature.

I would change it so that you have to type, literally, YES to get it to wipe the microdrive. It's not as if someone can't reboot and re-run the tool if they later decide they did want to wipe everything!

anyway, that's only my humble opinion. laugh.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2014 - 05:38 PM