OESF Portal | OESF Forum | OESF Wiki | LinuxPDA | ELSI (coming soon) | Ibiblio


Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Unable To Write Hhd3 On Cacko 1.23, How can I check / fix hhd3, read only
post Jun 24 2006, 09:30 PM
Post #1

Group: Members
Posts: 21
Joined: 5-August 05
From: Houston TX - most of the time!
Member No.: 7,791


I need help, with a write problem with hhd3 on Cacko 1.23.
Note: I now enough to be dangerous, I am a noob.
SL-C3200, Cacko 1.23, 2 weeks olnly, 128 mb swap on hd3, 1 Gbyte SD card.
Installed so far -> VNC viewer, PDF viewer, ZBEDIc, KA/Pi, OM/Pi, KO/Pi, KP/Pi (not tried), KT/Pi, PWM/Pi.
.- Using actively KA/Pi, KO/Pi, both set for Fast load.
Configured the kde to store data in /documents/kdepim/

.- Problem:
While using KA/Pi and saving a new address entry I have the indication that system unable to write.
Close KA/Pi, and reopened, then receive the indication that data file does not exist.
Used the build in file manager and could not find the kdepim directory.

.- Trouble shooting:
Turn off fast load.
Turn off swap file.
Rebooted the system.
Restarted KA/Pi, file was found but read only.
Open build in file manager kdepim folder is present, but oppening it reveals to subdirectories with the same name "apps".
Tried do delete one of them and have message"Could not delete the file".
Open Midnight Commander "Execute with root privilege" select directory and select to delete and receve:
Cannot delete file"/home/zaurus....
Reead only file system (30)

Before this incident I was able to use either the build in file manager or Midnight C. to create, copy delete files and directories.

Any help will be appreciated.

Go to the top of the page
+Quote Post
post Jun 27 2006, 12:33 AM
Post #2

Group: Members
Posts: 1,002
Joined: 28-April 05
From: Germany
Member No.: 7,027

I had a similar problem a while ago.

The file system was corrupt, so that everytime KA/PI (or was is KO/PI?) wanted to save its file, the hdd3 fs got remounted read-only automatically.
I could remount it rw again manually, but each time this particular file was accessed, the file system switched back to ro.

1. Make a full backup of all important files on hdd3!

2. Try the following in order to narrow down the reason for the problem:

in console:

sudo mount -o remount,rw /hdd3

Check with "mount" if it's really rw now.

Then try different things which access files on hdd3 and always check after that if hdd3 is read-only again.

So you can find out which application / file access causes the problem.

If you found the file, you have these options:

Temporary fix: copy the corrupt file into another file (using the cp command), reanem the original file to "garbage" or so and rename the new file to the name of the original file.
Thus you have a file which may be corrupt in its structure but at least is coherent with the FAT. Try to use that new file with the application now. hdd3 should not be remounted ro now anymore.

Deleting the old file is not possible, so you will want to do the second option anyway some tim ein the future. So conside doing it right now:

reformat hdd3.

This will write new FATs and delete the corrupt file(s).
Restoring from the backup will bring back the uspicious file of course, but most probably the file itself is OK, only the FAT entry is broken, and the FAT entry is created anew when restoring from backup.

Good luck
Go to the top of the page
+Quote Post
post Jun 27 2006, 04:12 AM
Post #3

Group: Members
Posts: 193
Joined: 19-March 04
Member No.: 2,402

You may want to try this alternative as it should be a lot quicker.

Mount the Zaurus on your Windows PC as storage

Open Windows Explorer, right click on the Zaurus entry & select Properties

Select the Tools Tab

Select the Check now in error checking section

Check 'Automatically Fix File system errors'.

It does take some time as the checking process has a total of 5 phases.

Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 16th October 2017 - 03:42 PM