OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Dillo 2.0 Compatable With Latest Angstrom/libs?, I don't want to pull down older libs
Jon_J
post Dec 10 2008, 09:54 AM
Post #1





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I want to install Dillo 2.0 on my angstrom C3100 with Angstrom version: "Angstrom-x11-image-glibc-ipk-2007.12-r13-spitz-installkit"
I cannot find it in the default official feeds for my Angstrom version, but I found it in this OZ feed:
openzaurus.org/download/3.5.4.1/feed/x11/
The problem is that the libraries listed for depends are older versions and I don't want to "mix" old libs with the default newer ones.
Can Dillo 2.0 just be installed with the "current" libs for my Angstrom version?
CODE
Dillo-from-Packages OZ Index of download-3.5.4.1-feed-x11
http://www.openzaurus.org/download/3.5.4.1/feed/x11/

Package: dillo2
Version: 0.6.6-r0
Depends: gdk-pixbuf-loader-xpm, gtk+ (>= 2.6.10), libatk-1.0-0 (>= 1.9.0), libc6 (>= 2.3.5+cvs20050627), pango (>= 1.8.1), libglib-2.0-0 (>= 2.6.4), libjpeg62 (>= 6b), libpng12-0 (>= 1.2.8), libz1 (>= 1.2.3), libgcc1 (>= 3.4.4)
Section: x11/network
Architecture: arm
Maintainer: Chris Lord <cwiiis@handhelds.org>
MD5Sum: bad6b6eb869e6c55ce60721ec2e351e5
Size: 124960
Filename: dillo2_0.6.6-r0_arm.ipk
Description: Lightweight gtk+2 browser.

While on this subject,
Can one install older OZ application packages onto the current Angstrom version?
Go to the top of the page
 
+Quote Post
Capn_Fish
post Dec 10 2008, 12:15 PM
Post #2





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



I don't know why that feed lists it as Dillo 2, as it's really not (just look at the version number).

I don't know if OE has a build file for Dillo 2, but if it does, I could build you a package (I'm already setting it up, so I might as well) and post it along with the deps.
Go to the top of the page
 
+Quote Post
Jon_J
post Dec 10 2008, 12:45 PM
Post #3





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



QUOTE(Capn_Fish @ Dec 10 2008, 02:15 PM) *
I don't know why that feed lists it as Dillo 2, as it's really not (just look at the version number).

I don't know if OE has a build file for Dillo 2, but if it does, I could build you a package (I'm already setting it up, so I might as well) and post it along with the deps.

You are right, I just looked and I have a dillo2 pkg in my two year old pdaxrom/pdaxii3 archive.
The new version should read "dillo_2.0", shouldn't it?

That would be cool, I bet I'm not the only one who would like Dillo 2.0 for Angstrom. smile.gif
Dillo is especially good for reading offline archived web sites. smile.gif
I looked into compiling and all the related stuff last Winter, but it overwhelmed me and I just got confused, so I gave it up for awhile.
Go to the top of the page
 
+Quote Post
Capn_Fish
post Dec 10 2008, 05:31 PM
Post #4





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



With Bitbake, it SHOULD just be "bitbake dillo," but there's a blocking but ATM that won't let my environment get set up. I'll get to trying it as soon as my environment can be set up.
Go to the top of the page
 
+Quote Post
ofels
post Dec 11 2008, 10:51 AM
Post #5





Group: Members
Posts: 142
Joined: 4-December 06
From: Lake Constance, Germany
Member No.: 13,087



QUOTE(Jon_J @ Dec 10 2008, 06:54 PM) *
Can one install older OZ application packages onto the current Angstrom version?


Almost certainly not unless there is a compatibility package available which I am not aware of.

Oliver
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2014 - 08:33 PM