OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Recent zgcc (C compiler)?
vinc17
post Sep 22 2004, 01:54 AM
Post #1





Group: Members
Posts: 38
Joined: 27-July 04
From: Lyon, France
Member No.: 4,122



I currently have zgcc 2.02, but it corresponds to an old and buggy (for the unsigned division) gcc version (2.95). Where can I find a recent version (gcc 3.x)?

Note: I want gcc on my Zaurus, not a cross-compiler.
Go to the top of the page
 
+Quote Post
stupkid
post Sep 22 2004, 09:19 PM
Post #2





Group: Members
Posts: 578
Joined: 2-January 04
From: Texas USA
Member No.: 1,324



All the Sharp based ROMs are compiled with gcc 2.95. There is a binary incompatiblity with newer GCC. If you are trying to compile for Sharp ROMs stick with the old GCC.
Go to the top of the page
 
+Quote Post
vinc17
post Sep 22 2004, 10:47 PM
Post #3





Group: Members
Posts: 38
Joined: 27-July 04
From: Lyon, France
Member No.: 4,122



There could be incompatibilities for C++ programs, but I don't see why there would be one for C programs (as long as the libc isn't changed, but I just want a more recent gcc).
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th November 2014 - 11:34 PM