OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Install Trouble With Some Ipks, solved: was meanie's zgcc env related :)
jpmatrix
post Feb 16 2007, 03:14 PM
Post #1





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



hi
sometimes i ve troubles installing some ipks for example latest clamav-0.9.0 from z.drun.net... i got errors like this :

tar: ./usr/include/clamav.h: Cannot open: Read-only file system
tar: ./usr/include: Cannot change mode to rwxr-xr-x: Read-only file system
tar: Error exit delayed from previous errors

would someone help please?
Go to the top of the page
 
+Quote Post
radiochickenwax
post Feb 16 2007, 03:35 PM
Post #2





Group: Members
Posts: 158
Joined: 21-November 04
Member No.: 5,548



QUOTE(jpmatrix @ Feb 16 2007, 11:14 PM)
hi
sometimes i ve troubles installing some ipks for example latest clamav-0.9.0 from z.drun.net... i got errors like this :

tar: ./usr/include/clamav.h: Cannot open: Read-only file system
tar: ./usr/include: Cannot change mode to rwxr-xr-x: Read-only file system
tar: Error exit delayed from previous errors

would someone help please?
*



Just to get the obvious out of the way, you're not trying to install to a FAT formatted filesystem on SD or CF are you? Or maybe into some location that has no memory left? Those have been the two reasons this has happened to me so far.
Go to the top of the page
 
+Quote Post
jpmatrix
post Feb 17 2007, 01:18 AM
Post #3





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(radiochickenwax @ Feb 17 2007, 01:35 AM)
QUOTE(jpmatrix @ Feb 16 2007, 11:14 PM)
hi
sometimes i ve troubles installing some ipks for example latest clamav-0.9.0 from z.drun.net... i got errors like this :

tar: ./usr/include/clamav.h: Cannot open: Read-only file system
tar: ./usr/include: Cannot change mode to rwxr-xr-x: Read-only file system
tar: Error exit delayed from previous errors

would someone help please?
*



Just to get the obvious out of the way, you're not trying to install to a FAT formatted filesystem on SD or CF are you? Or maybe into some location that has no memory left? Those have been the two reasons this has happened to me so far.
*




well
i'm always installing FROM a fat formatted sdcard yes but TO my c3000 harddrive...
most packages works; there're only some which gave me these messages....
Go to the top of the page
 
+Quote Post
kkazakov13
post Feb 17 2007, 03:32 AM
Post #4





Group: Members
Posts: 409
Joined: 3-December 06
Member No.: 13,063



It's not the problem from this package ... i've used it lot of times.


Ok, is this always happening with bigger packages or the size doesn't matter? Because as you noticed, clamav is 9mb archived ....
Go to the top of the page
 
+Quote Post
jpmatrix
post Feb 17 2007, 09:07 AM
Post #5





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(kkazakov13 @ Feb 17 2007, 01:32 PM)
It's not the problem from this package ... i've used it lot of times.


Ok, is this always happening with bigger packages or the size doesn't matter? Because as you noticed, clamav is 9mb archived ....
*


no it is not size related:i got lots of error messages with this package too:

http://z.drun.net/packages/evolution-data-....2_armv5tel.ipk

andi it is only 200ko...
Go to the top of the page
 
+Quote Post
kkazakov13
post Feb 17 2007, 09:17 AM
Post #6





Group: Members
Posts: 409
Joined: 3-December 06
Member No.: 13,063



is it always /usr/include/ related? and why you install -devel package ? it's only when developing ...
Go to the top of the page
 
+Quote Post
jpmatrix
post Feb 17 2007, 09:40 AM
Post #7





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(kkazakov13 @ Feb 17 2007, 07:17 PM)
is it always /usr/include/ related? and why you install -devel package ? it's only when developing ...
*


i remember compiling i-don-t-know-which-package asked me about it...well it was just a try smile.gif

here are the error i get :

yeah, it seems to bet /usr/include related
Attached File(s)
Attached File  err.txt ( 28.59K ) Number of downloads: 14
 
Go to the top of the page
 
+Quote Post
kkazakov13
post Feb 17 2007, 09:49 AM
Post #8





Group: Members
Posts: 409
Joined: 3-December 06
Member No.: 13,063



can you make

CODE
ls -al /usr/ | grep include


and paste the output ( permissions ) here ?
Go to the top of the page
 
+Quote Post
jpmatrix
post Feb 17 2007, 09:58 AM
Post #9





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



QUOTE(kkazakov13 @ Feb 17 2007, 07:49 PM)
can you make

CODE
ls -al /usr/ | grep include


and paste the output ( permissions ) here ?
*


ho yes you find it!!!
in fact as i've installed meanie's compiling tool zgcc-3.4.6.squashfs, now /usr/include is linked to /opt/native/xxxxx which is readonly, as it is a squashfs mount........
well how do i get rid of that???
am i alone in this situation???
Go to the top of the page
 
+Quote Post
kkazakov13
post Feb 17 2007, 10:30 AM
Post #10





Group: Members
Posts: 409
Joined: 3-December 06
Member No.: 13,063



Usually I make gcc environment by myself. /usr/include should NOT be linked to /opt/native/arm/...

my quickfix for this - if you have enough space, unpack squashfs somewhere and link it to /opt/native/arm - this way you will have RW env.

another quickfix - I would remove link /usr/include , when building this should be checked in includedir too by default.

But better do the first one - you will encounter situations when you don't want the include files or libs in the squashfs , in this case I just rename them smile.gif As my GCC is directly in the filesystem.
Go to the top of the page
 
+Quote Post
jpmatrix
post Feb 17 2007, 10:38 AM
Post #11





Group: Members
Posts: 1,019
Joined: 15-February 05
From: France
Member No.: 6,477



ok i'll try that

for now unmounting the zgcc environnement did the trick

thanks for your help!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 2nd September 2015 - 10:51 PM