OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Poodle + Upgrade, Wifi Card not recognized
cstrand1
post Apr 10 2006, 12:27 PM
Post #1





Group: Members
Posts: 41
Joined: 30-April 04
Member No.: 3,066



Hello all,

I am running 3.5.4 on my poodle.

I just ran ipkg update ; ipkg upgrade and it upgraded quite a few packages.

I rebooted it and it told me that I was running the wrong kernel. That I need to be running one that ended in 3.5.4.1-alpha. Well, it booted into opie fine, except my Ambicom WL1100 Wifi card is not recognized.

A side note: I dual boot (altboot) and run gpe off of my SD card. Same problem with that as well.

What have I done?

Chuck
Go to the top of the page
 
+Quote Post
Hrw
post Apr 10 2006, 01:02 PM
Post #2





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



hmm.. looks that I need to check initscripts in upgrades and fix them.

card not working is other thing... can you paste cardctl ident output? Ill do update to get it working back.
Go to the top of the page
 
+Quote Post
cstrand1
post Apr 10 2006, 03:31 PM
Post #3





Group: Members
Posts: 41
Joined: 30-April 04
Member No.: 3,066



QUOTE(Hrw @ Apr 10 2006, 04:02 PM)
hmm.. looks that I need to check initscripts in upgrades and fix them.

card not working is other thing... can you paste cardctl ident output? Ill do update to get it working back.
*


Here is the output.

Socket 0:
product info: "AmbiCom", "WL1100C 802.11b CF-Card", "2.2"
manfid: 0xd601, 0x0002
function: 6 (network)
Socket 1:
no product info available

In Opie, when selecting the card applet, the popup states "unsupported card" and when selecting configure, it tells me that it is not bound to a driver.

Prior to the upgrade the card worked without any problems, both in opie and gpe.

Thank you,
Chuck
Go to the top of the page
 
+Quote Post
Hrw
post Apr 10 2006, 11:16 PM
Post #4





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



http://ewi546.ewi.utwente.nl/tmp/hrw/3.5.4..._1.0-r1_all.ipk

Install that package and tell me does it help - it should wink.gif
Go to the top of the page
 
+Quote Post
cstrand1
post Apr 11 2006, 06:09 AM
Post #5





Group: Members
Posts: 41
Joined: 30-April 04
Member No.: 3,066



QUOTE(Hrw @ Apr 11 2006, 02:16 AM)
http://ewi546.ewi.utwente.nl/tmp/hrw/3.5.4..._1.0-r1_all.ipk

Install that package and tell me does it help - it should wink.gif
*


I installed the into the Opie install and that worked great!

It did not work, however, in my Gpe install. I assigned the orinoco driver, but to no avail.
Go to the top of the page
 
+Quote Post
Hrw
post Apr 11 2006, 06:38 AM
Post #6





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



can you be more verbose?

you booted opie installation, added hostap-conf r1 and card was working

then you booted gpe installation, not used hostap-conf r1 and complain that card is not working?
Go to the top of the page
 
+Quote Post
cstrand1
post Apr 11 2006, 07:22 AM
Post #7





Group: Members
Posts: 41
Joined: 30-April 04
Member No.: 3,066



QUOTE(Hrw @ Apr 11 2006, 09:38 AM)
can you be more verbose?

you booted opie installation, added hostap-conf r1 and card was working

then you booted gpe installation, not used hostap-conf r1 and complain that card is not working?
*


I am sorry that I was not more clear.

You are correct regarding the Opie installation. Everything works well.

As for GPE, I booted into it and installed the hostap package, just I did in the Opie. It did not work with the package you said to try. Under settings, I used the PC card app and tried assigning the orinoco_cs driver to it and it reports that socket 0 has the Ambicom card and the driver assigned. It still does not work.

Do the hostap and hostap_cs modules need to be loaded in gpe as they are in opie? They are not loaded in my installation of gpe. I may go back and reinstall gpe, see what's configured prior to doing an update.

Chuck
Go to the top of the page
 
+Quote Post
grog
post Apr 11 2006, 09:03 AM
Post #8





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



QUOTE(cstrand1 @ Apr 11 2006, 09:22 AM)
Do the hostap and hostap_cs modules need to be loaded in gpe as they are in opie?  They are not loaded in my installation of gpe.  I may go back and reinstall gpe, see what's configured prior to doing an update.
*

I actually never thought to check before, but the modules are not loaded in the default rom (I haven't upgraded yet since the new modules came out).

CODE
grog@grond[pts/1][~]$ lsmod
Module                  Size  Used by    Tainted: P
pxa_bi                 20028   0 (unused)
net_fd                 25012   1
usbdcore               30424   0 [pxa_bi net_fd]
sharp_mmcsd_m          26200   4
rfcomm                 33488   0
l2cap                  17028   2 [rfcomm]
bluez                  32616   1 [rfcomm l2cap]
grog@grond[pts/1][~]$ ipkg list_installed | grep hostap
hostap-modules-2.4.18-rmk7-pxa3-embedix - 0.3.9-r7 -
hostap-modules-cs-2.4.18-rmk7-pxa3-embedix - 0.3.9-r7 -
hostap-utils - 0.4.0-r1 -


Maybe that's part of my (unreported, undiagnosed) problem connecting with WEP @ home. I hadn't had the time to fifgure that one out.
Go to the top of the page
 
+Quote Post
Hrw
post Apr 12 2006, 06:01 AM
Post #9





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



http://openzaurus.org/wordpress/2006/04/12...with-wifi-card/
Go to the top of the page
 
+Quote Post
grog
post Apr 12 2006, 07:17 AM
Post #10





Group: Members
Posts: 692
Joined: 27-January 04
From: Canada
Member No.: 1,564



QUOTE(Hrw @ Apr 12 2006, 08:01 AM)

I posted what seems to be a fix for me & details.
Go to the top of the page
 
+Quote Post
cstrand1
post Apr 12 2006, 10:07 AM
Post #11





Group: Members
Posts: 41
Joined: 30-April 04
Member No.: 3,066



QUOTE(grog @ Apr 12 2006, 10:17 AM)
QUOTE(Hrw @ Apr 12 2006, 08:01 AM)

I posted what seems to be a fix for me & details.
*



I actually just got it to work as well. What I did was start the PC/CF card application and assign the hostap_cs driver to my card. Now, that driver is not listed in the dropdown, so I typed it in manually. After that it worked like it should.

Now, looking at the /etc/pcmcia/hostap_cs.conf, it shows my Ambicom WL1100C card bound to hostap_cs. I noticed that under /etc/pcmcia, the file "config" had a modified date of today. In looking at that file, I see my Ambicom WL1100 card bound to hostap_cs. I rebooted and it worked as I would expect.
Go to the top of the page
 
+Quote Post
Hrw
post Apr 12 2006, 10:57 PM
Post #12





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



can you share that part? I want to add it into hostap-conf
Go to the top of the page
 
+Quote Post
cstrand1
post Apr 13 2006, 05:57 AM
Post #13





Group: Members
Posts: 41
Joined: 30-April 04
Member No.: 3,066



QUOTE(Hrw @ Apr 13 2006, 01:57 AM)
can you share that part? I want to add it into hostap-conf
*


I am going to assume what was added to /etc/pcmcia/config.

It actually is the same format as hostap_cs.conf. I am including the lines prior to it as well.

# Include configuration files for add-on drivers

source ./*.conf

# Include local configuration settings

source ./config.opts

card "AmbiCom WL1100C 802.11b CF-Card"
manfid 0xd601, 0x0002
bind "hostap_cs"

If there is something else you needed, let me know.

Chuck
Go to the top of the page
 
+Quote Post
ozric100
post Jul 31 2006, 06:17 PM
Post #14





Group: Members
Posts: 9
Joined: 30-October 04
Member No.: 5,278



I am having the same problem... on a collie with altroot direct install on a SD card. I did an upgrade.. now I cant get my Ambicom wifi working. so what is the fix ? also... I get an odd segfault using iwconf from the cli.

I have mounted -o bind /var /dev and /proc then I can chroot to my sd card .. and use my programs .. but altboot to the card does not work with my card.

Oz
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th August 2014 - 04:43 AM