OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Does Planex Gw-cf11x Card Work On Zubuntu?
lineager
post Jan 7 2009, 08:01 AM
Post #1





Group: Members
Posts: 7
Joined: 30-November 07
Member No.: 21,007



Hi,

I have spent a lot of time to make my Planex GW-CF11X card works on Zubuntu. I did try all the methods mentioned here and the comments on Omegamoon blog, but still fail...

Methods I tried:
1. Install Wicd Network Manger => I can run it on x window, but the card cannot be detected
2. Install Hostap Utils
3. blacklist onrinoco
blacklist onrinoco_cs

Does anyone use the same card and get connected WIFI with Zubuntu ? Please share the steps. Thanks. rolleyes.gif


Go to the top of the page
 
+Quote Post
jeana
post Jan 7 2009, 10:46 AM
Post #2





Group: Members
Posts: 34
Joined: 6-September 05
Member No.: 8,047



Yes, it works !

Find my configuration below :

- Install the Hostap utills
- Copy pm010102.hex and rf010804.hex into /lib/firmware
- Add the following in your /etc/network/interfaces :
QUOTE
allow-hotplug wlan0
iface wlan0 inet dhcp
pre-up modprobe hostap
pre-up prism2_srec -gs wlan0 /lib/firmware/pm010102.hex
pre-up prism2_srec -gp wlan0 /lib/firmware/pm010102.hex
pre-up iwpriv wlan0 reset 1
pre-up prism2_srec -rp wlan0 /lib/firmware/rf010804.hex
pre-up wpa_supplicant -B -Dwext -iwlan0 -c/etc/wpa_supplicant.conf

- Configure your /etc/wpa_supplicant.conf . An example follows for a WPA2 with Pre-shared key connection :
QUOTE
network={
ssid="YOURWIFISID"
key_mgmt=WPA-PSK
proto=WPA2
group=CCMP
pairwise=CCMP
psk=your-hexadecimal-password
}


To start the wifi connection :
QUOTE
ifup wlan0


To stop the wifi connection :
QUOTE
ifdown wlan0
killall wpa_supplicant


I hope I forget nothing.
Go to the top of the page
 
+Quote Post
lineager
post Jan 13 2009, 07:31 AM
Post #3





Group: Members
Posts: 7
Joined: 30-November 07
Member No.: 21,007



Thanks Jeana,

I follow your setting, but I got error when executing "ifup wlan0" :

/bin/sh: /usr/sbin/prism2_srec: No such file or directory

I have installed hostap-utils_0.4.7-1_arm.deb. What can I do next to make it works?
Go to the top of the page
 
+Quote Post
jeana
post Jan 13 2009, 10:22 AM
Post #4





Group: Members
Posts: 34
Joined: 6-September 05
Member No.: 8,047




It's very bizarre that the package hostap-utils_0.4.7-1_arm.deb didn't contains /usr/sbin/prism2_srec !

I use the following hostap-utils package :
Attached File(s)
Attached File  hostap_utils_0.4.0_1_arm.deb ( 49.18K ) Number of downloads: 60
 
Go to the top of the page
 
+Quote Post
lineager
post Jan 14 2009, 07:27 AM
Post #5





Group: Members
Posts: 7
Joined: 30-November 07
Member No.: 21,007



QUOTE(jeana @ Jan 13 2009, 10:22 AM) *
It's very bizarre that the package hostap-utils_0.4.7-1_arm.deb didn't contains /usr/sbin/prism2_srec !

I use the following hostap-utils package :


WOW~! It works~! Thanks Jeana. laugh.gif
Go to the top of the page
 
+Quote Post
Kirin
post Feb 21 2009, 03:11 PM
Post #6





Group: Members
Posts: 40
Joined: 20-July 05
Member No.: 7,641



I'm using the Planex GW-CF11H card, I think mine is a prism3 chip card instead of prism2.

I've installed hostap, put in the same .hex files as mention in this thread and add the same wlan0 information under /etc/network/interfaces

when I manually bring up wlan0 on command line and set the ESSID, my card change from blinking light to solid light, so I assume it is connected to the router, but then I still couldn't get on the internet. Currently there is no encryption setting on my router, and i heart dhcp is not working under zubuntu yet.

May I know what I need to put for static ip address? or these drivers won't work with my card?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st October 2014 - 06:24 PM