OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Usb Networking On Rc10 With C1k
Quickfry
post Jul 5 2005, 08:03 PM
Post #1





Group: Members
Posts: 46
Joined: 15-June 05
From: NB.CA
Member No.: 7,359



I was having problems with this, but the answer isn't hard.
Open a root console, and modprobe acm hid and pxa27x_bi
The host machine should now pick up the Z (you can check using lsusb)
Check on the Z, using ifconfig -a, you should see a usbd0 device.
Now you can ifconfig usbd0 192.168.129.201 and add your gw, route add default gw 192.168.129.1 or what have you. /etc/resolv.conf also needs to be edited with your dns servers.
Go to the top of the page
 
+Quote Post
zeno
post Jul 19 2005, 01:46 PM
Post #2





Group: Members
Posts: 3
Joined: 12-May 05
Member No.: 7,122



QUOTE(Quickfry @ Jul 5 2005, 08:03 PM)
I was having problems with this, but the answer isn't hard.
Open a root console, and modprobe acm hid and pxa27x_bi
The host machine should now pick up the Z (you can check using lsusb)
Check on the Z, using ifconfig -a, you should see a usbd0 device.
Now you can ifconfig usbd0 192.168.129.201 and add your gw, route add default gw 192.168.129.1 or what have you. /etc/resolv.conf also needs to be edited with your dns servers.
*


Thanks Quickfry for your mini-how-to. Now i can see the Z from the Pc and vice versa. Now i have another problem because i modified the file resolv.conf with my dns server but dillo and wget or others appz don't resolve any address!
Now is late for me and tomorrow is going to be a day of hard work so i'll try the internet connection in nesxt days. I'll let you know.
Bye,
zeno
Go to the top of the page
 
+Quote Post
Quickfry
post Jul 20 2005, 01:05 PM
Post #3





Group: Members
Posts: 46
Joined: 15-June 05
From: NB.CA
Member No.: 7,359



First, make sure you can ping the machine your Z is connected to.
If you can't, do an ifconfig on each machine to make sure both interfaces are up, and using the correct ip addresses.
Second, make sure you can ping your dns servers.
If you can't, you may need to set up iptables on the host machine. Make sure your kernel and distrobution have support for iptables enabled. Check this thread for instructions on what to do after that.
If you can ping your dns servers, make sure your /etc/resolv.conf looks like this:
CODE
namserver 198.164.30.2
Go to the top of the page
 
+Quote Post
zeno
post Jul 20 2005, 01:21 PM
Post #4





Group: Members
Posts: 3
Joined: 12-May 05
Member No.: 7,122



Strange day...
yesterday i connected the Z to the host PC and the output of dmesg on PC was allright... now i start the PC and the Z and dmesg output is:

CODE
usb 3-2: new full speed USB device using uhci_hcd and address 6
usb 3-2: device descriptor read/64, error -71
usb 3-2: device descriptor read/64, error -71


It's a shame, i don't have time to setup the connection because i have a lot of work to do. I hope to solve my problems during the next week-end when i will have more free time. Thanks a lot Quickfry for your interests on my problems!
Bye,
zeno
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th December 2014 - 07:08 PM