OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Missing Links?, Im kinda lost on this one now.
daeos
post Jul 7 2008, 03:54 PM
Post #1





Group: Members
Posts: 29
Joined: 29-June 08
From: San Antonio, Tx
Member No.: 21,989



After using some new feeds i found to install that pango/cairo file I was missing. I added some new packages to my zaurus and now I can not exit x11, I can not run the blank screen app for x, I can not even pull up the sound icon anymore. When i try to run the sound app or any new apps or even some previously working apps I am now getting an error referring to the same pango file AGAIN! here is my exact error:

#mb-applet-volume
mb-applet-volume: relocation error: /usr/lib/libpangoxft-1.0.so.0: undefined symbol: g_once_init_enter_impl

I get this exact same issue when running any new app or running this speaker app. What would cause this error and how can I fix it? I would hate to start all over again with reinstalling pdaXrom but if I have to, which version should I install for my Zaurus? (model in my sig)
Go to the top of the page
 
+Quote Post
Capn_Fish
post Jul 7 2008, 07:06 PM
Post #2





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



You installed it from kkazakov13's feed, right? If you haven't, you should update all of your libs to the versions in his feed. They're interdependent.

I believe it's also possible that the libs in his feed use optimizations that don't work on the 6000. The 6000 has a PXA255 CPU, while the one he's using has a PXA270. I'm not sure if this could be the issue.
Go to the top of the page
 
+Quote Post
utx
post Jul 8 2008, 12:32 AM
Post #3





Group: Members
Posts: 135
Joined: 27-June 05
From: Prague, Czech Republic, Europe
Member No.: 7,468



QUOTE(daeos @ Jul 8 2008, 01:54 AM) *
mb-applet-volume: relocation error: /usr/lib/libpangoxft-1.0.so.0: undefined symbol: g_once_init_enter_impl


Reinstall newer (lib)glib(2) package. You need to update libglib-2.0.so.0 library. But I cannot guarantee, that it will need more updates. Hopefully, glib2 is backward compatible for both API and ABI, so you should not break anything.
Go to the top of the page
 
+Quote Post
daeos
post Jul 8 2008, 09:39 AM
Post #4





Group: Members
Posts: 29
Joined: 29-June 08
From: San Antonio, Tx
Member No.: 21,989



QUOTE(utx @ Jul 8 2008, 03:32 AM) *
QUOTE(daeos @ Jul 8 2008, 01:54 AM) *
mb-applet-volume: relocation error: /usr/lib/libpangoxft-1.0.so.0: undefined symbol: g_once_init_enter_impl


Reinstall newer (lib)glib(2) package. You need to update libglib-2.0.so.0 library. But I cannot guarantee, that it will need more updates. Hopefully, glib2 is backward compatible for both API and ABI, so you should not break anything.


Yes sir! that fixed it! Gratz to you! +karma .... if there was any.

Edit: After doing this update for libglib-2.0.so.0 library.... all of the x windows boxes are no longer titled with the app name... it just says "untitled window [#]"
Go to the top of the page
 
+Quote Post
daeos
post Jul 8 2008, 01:31 PM
Post #5





Group: Members
Posts: 29
Joined: 29-June 08
From: San Antonio, Tx
Member No.: 21,989



Now, after doing this upgrade to the lib you told me to upgrade... I am now missing fonts in X. does this mean I have to reinstall X also? I am missing the iso font and i get an error that it can not convert from utf to iso I'll post the exact error in a second.
Go to the top of the page
 
+Quote Post
daeos
post Jul 8 2008, 04:05 PM
Post #6





Group: Members
Posts: 29
Joined: 29-June 08
From: San Antonio, Tx
Member No.: 21,989



Here we go... but before you read the rest here is a question... would this error mean i need to reinstall GTK also?


(mb-applet-volume:3514): Gdk-WARNING **: Error converting from UTF-8 to STRING: Could not open converter from 'UTF-8' to 'ISO-8859-1'

am i correct? I need to remove Gdk and reinstall? or what else would I do?
Go to the top of the page
 
+Quote Post
Capn_Fish
post Jul 8 2008, 05:20 PM
Post #7





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



I'm not entirely sure. I'd wait until kkazakov13 can answer, or PM him directly.
Go to the top of the page
 
+Quote Post
daeos
post Jul 8 2008, 05:59 PM
Post #8





Group: Members
Posts: 29
Joined: 29-June 08
From: San Antonio, Tx
Member No.: 21,989



QUOTE(Capn_Fish @ Jul 8 2008, 08:20 PM) *
I'm not entirely sure. I'd wait until kkazakov13 can answer, or PM him directly.


Also, im beginning to notice something VERY wierd..... keyboard, key pad and touch screen operation suddenly stops working after a few mins or so of inactivity, I even left it plugged in, wifi off, running only top ... Top kept running along and would update, and the clock in x would keep going all the while no response when I press anything on the pda.
Go to the top of the page
 
+Quote Post
utx
post Jul 9 2008, 01:47 AM
Post #9





Group: Members
Posts: 135
Joined: 27-June 05
From: Prague, Czech Republic, Europe
Member No.: 7,468



QUOTE(daeos @ Jul 9 2008, 02:05 AM) *
(mb-applet-volume:3514): Gdk-WARNING **: Error converting from UTF-8 to STRING: Could not open converter from 'UTF-8' to 'ISO-8859-1'


Missing iconv module in glibc. You need a package, which contains file /usr/lib/gconv/ISO8859-1.so and /usr/lib/gconv/gconv-modules and /usr/lib/gconv/gconv-modules.cache.

In worse case it may be incompatibility between libc (different status of iconv support). In this case, ther is no simpe solution.
Go to the top of the page
 
+Quote Post
daeos
post Jul 9 2008, 09:39 AM
Post #10





Group: Members
Posts: 29
Joined: 29-June 08
From: San Antonio, Tx
Member No.: 21,989



Any possible hope of avoiding a new install again? If not, which version should I install for my SL-6000L ? beta 3 again?
Go to the top of the page
 
+Quote Post
utx
post Jul 9 2008, 03:37 PM
Post #11





Group: Members
Posts: 135
Joined: 27-June 05
From: Prague, Czech Republic, Europe
Member No.: 7,468



QUOTE(daeos @ Jul 9 2008, 07:39 PM) *
Any possible hope of avoiding a new install again? If not, which version should I install for my SL-6000L ? beta 3 again?


Try to find upper mentioned files. In Angstrom distribution, the package has name glibc-gconv-iso8859-1.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st September 2014 - 10:42 PM