OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Time Discrepancy, 1 hr earlier on desktop
wpchan
post Oct 22 2005, 12:25 AM
Post #1





Group: Members
Posts: 17
Joined: 19-February 05
Member No.: 6,504



I have a strange problem with my C3K. It has Sharp ROM 1.11 and Tetsu v18a kernel. The time is set to PDT (US/Pacific, Seattle) and I sync it with ntpdate. Here is my locale.conf

[Language]
Language = ja
[Location]
Timezone = America/Seattle

And the date command returns "DDD MMM dd hh:mm:ss PDT 2005".

My desktop XP is also set to same time zone and sync to the same time server. So the clock on the XP is the same as shown on the Z. When I connect the Z with USB to XP (PC link setting: storage), explorer shows the time stamp of the files on the Z 1 hr earlier e.g., foo on Z will show Oct 21 19:04 but XP explorer will show the same file with time stamp Oct 21 18:04. I tried that on 2 XP and 1 gentoo linux and get the same result. It looks like it is the daylight time difference. Have I set something wrong on the Z?

Any clues will be much appreciated!

--pang
Go to the top of the page
 
+Quote Post
wpchan
post Nov 1 2005, 09:53 PM
Post #2





Group: Members
Posts: 17
Joined: 19-February 05
Member No.: 6,504



The problem was definitely related to daylight saving time. After switching to standard time this week, there is no more time discrepency. Now, I just have to figure out if it is the settings on my desktop or that on the Z.

--pang
Go to the top of the page
 
+Quote Post
Tomoe
post Nov 2 2005, 03:55 AM
Post #3





Group: Members
Posts: 51
Joined: 23-January 05
Member No.: 6,293



QUOTE(wpchan @ Nov 1 2005, 09:53 PM)
The problem was definitely related to daylight saving time.  After switching to standard time this week, there is no more time discrepency.  Now, I just have to figure out if it is the settings on my desktop or that on the Z.

--pang
*

Japan doesn't have daylight saving time. That's why. =)
Go to the top of the page
 
+Quote Post
sitongia
post Apr 21 2006, 08:25 PM
Post #4





Group: Members
Posts: 2
Joined: 15-January 05
Member No.: 6,237



I see this, too, here in MST. Did you figure out how to fix it? I don't see how to toggle MST in Opie/OpenZaurus. As in your case, my clocks are set to the same time.

==Leonard
Go to the top of the page
 
+Quote Post
wpchan
post May 3 2006, 01:47 PM
Post #5





Group: Members
Posts: 17
Joined: 19-February 05
Member No.: 6,504



I do not know a solution but this may be due to the setting of the hardware clock. I think Windoze always set the HW clock to localtime while most UNIX machines prefer UTC. I can't test this because all the unix machines that I have access to dual boot with windoze and the HW clocks are all set to localtime.

Somehow, the usb driver does not know how to account for that. In addition, I should also mention that I have /usr/share/zoneinfo/US/Pacific linked to /etc/localtime. If not, ssh sessions into Z will come up with TZ set to UTC instead of PDT.

I noticed this problem when I first started using ko/pi. When I sync the Z to my XP desktop, the timestamp of the ics file would be off by one hr but the timestamp of the calender events were correct. As long as it does not mess up my calender, I can live with that.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 29th August 2014 - 12:03 AM