OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Newbie With Zaurus Roms, Need help with pdaXrom software
ironmantis7x
post Apr 4 2008, 10:08 AM
Post #1





Group: Members
Posts: 14
Joined: 4-April 08
Member No.: 21,592



Hi all!

I am sure that this question has been asked before and please forgive me such redundancy ...

I am a newbie with Linux and Zaurus. I flashed my first Zaurus that I just purchased -- a SL-C750 with pdaXrom.
It works and feels great! I discovered that there are some applications that I would like that are missing. Examples are Abi Sheet, to do list, calander and firefox or opera.

Can some one please give me step by step details of how to get this onto my Zaurus?

Thanks

Ironmantis7x
Go to the top of the page
 
+Quote Post
ArchiMark
post Apr 4 2008, 11:05 AM
Post #2





Group: Members
Posts: 1,027
Joined: 25-June 03
From: Silicon Valley
Member No.: 208



Welcome to the Z Club, ironmantis7x!

Think you will find this an excellent group....

However, please take the time to do some homework to help you get up to speed...
after you check things out feel free to ask questions for things you don't understand and I'm sure you'll get some help....

In the meantime, check out the OESF Wiki, lots of great info there along with these forums....

For the wiki, check out this page on feeds....

OESF Wiki - Feeds


Have Fun!

Mark


Go to the top of the page
 
+Quote Post
Jon_J
post Apr 4 2008, 01:57 PM
Post #3





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I don't know much about the 760/860 Zauri. Are you running pdaxrom beta 1?
If so, here is the feed for pdaxrom beta1 for 7x0/860. This should cover your needs for your 760
http://distro.ibiblio.org/pub/linux/distri...s-7x0-860/feed/
Abiword is there. I don't know about Abi sheet. Firefox is available, but it is very slow to load.
Opera is only available for Sharp/Cacko ROMs. Opera will not work in pdaxrom. Someone got it working in an older version of Open Zaurus (Opie), a long time ago

You are better off when using a feed to use the package manager and fetch your packages with your Zaurus online.
This will make sure any dependencies are also downloaded when you fetch a package.

Also, just do some browsing in the pdaxrom subforum, and search that forum for things you're interested in.
Also check out the pinned thread called" "New Packages announcements"
Go to the top of the page
 
+Quote Post
Capn_Fish
post Apr 4 2008, 04:51 PM
Post #4





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



"Abisheet" would likely be "Gnumeric"
Go to the top of the page
 
+Quote Post
ironmantis7x
post Apr 7 2008, 11:07 AM
Post #5





Group: Members
Posts: 14
Joined: 4-April 08
Member No.: 21,592



QUOTE(Jon_J @ Apr 4 2008, 01:57 PM) *
I don't know much about the 760/860 Zauri. Are you running pdaxrom beta 1?
If so, here is the feed for pdaxrom beta1 for 7x0/860. This should cover your needs for your 760
http://distro.ibiblio.org/pub/linux/distri...s-7x0-860/feed/
Abiword is there. I don't know about Abi sheet. Firefox is available, but it is very slow to load.
Opera is only available for Sharp/Cacko ROMs. Opera will not work in pdaxrom. Someone got it working in an older version of Open Zaurus (Opie), a long time ago

You are better off when using a feed to use the package manager and fetch your packages with your Zaurus online.
This will make sure any dependencies are also downloaded when you fetch a package.

Also, just do some browsing in the pdaxrom subforum, and search that forum for things you're interested in.
Also check out the pinned thread called" "New Packages announcements"



I was able to load pdaXrom on the 750. It is pretty good.
However -- I tried to update it using feeds and I keep getting errors. One error that I am getting is that I am running out of space. SO I bout a 1GB SD card for it. I tried to install firefox and planner from one of teh feeds but it keeps giving me an error (something about might have to run ipkg update).

Can some one help me??
I am running pdaXrom kathrin-1.1.0beta1-corgi.
Go to the top of the page
 
+Quote Post
Capn_Fish
post Apr 7 2008, 12:15 PM
Post #6





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Do you have a feed configured that has Firefox and planner?
Go to the top of the page
 
+Quote Post
ironmantis7x
post Apr 7 2008, 12:29 PM
Post #7





Group: Members
Posts: 14
Joined: 4-April 08
Member No.: 21,592



QUOTE(Capn_Fish @ Apr 7 2008, 12:15 PM) *
Do you have a feed configured that has Firefox and planner?



Yes I do ....
Go to the top of the page
 
+Quote Post
Capn_Fish
post Apr 7 2008, 01:04 PM
Post #8





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Maybe posting the exact error would help.
Go to the top of the page
 
+Quote Post
ironmantis7x
post Apr 7 2008, 04:31 PM
Post #9





Group: Members
Posts: 14
Joined: 4-April 08
Member No.: 21,592



QUOTE(Capn_Fish @ Apr 7 2008, 01:04 PM) *
Maybe posting the exact error would help.


My Zaurus has a slashing yellow light and will not boot up. This happened today after I tried to do a rest of it. Is it dead??
Go to the top of the page
 
+Quote Post
ironmantis7x
post Apr 7 2008, 04:57 PM
Post #10





Group: Members
Posts: 14
Joined: 4-April 08
Member No.: 21,592



QUOTE(ironmantis7x @ Apr 7 2008, 04:31 PM) *
QUOTE(Capn_Fish @ Apr 7 2008, 01:04 PM) *
Maybe posting the exact error would help.


My Zaurus has a slashing yellow light and will not boot up. This happened today after I tried to do a rest of it. Is it dead??



I changed batteries and the Zaurus is back to life!!

Now on the feed issue: here is the error::
ERROR: failed to retrieve http://mirror/pdaxrom.org/rc8/feed/Packages

what do I do now?? I need to install firefox and calender. I am trying to install to my SD card.

ironmantis7x

Go to the top of the page
 
+Quote Post
apink
post Apr 7 2008, 08:26 PM
Post #11





Group: Members
Posts: 106
Joined: 2-August 05
Member No.: 7,764



QUOTE(ironmantis7x @ Apr 7 2008, 05:57 PM) *
Now on the feed issue: here is the error::
ERROR: failed to retrieve http://mirror/pdaxrom.org/rc8/feed/Packages

ironmantis7x


Are you sure that your internet connection is up?
You might also try another feed source. I just tried to connect to the url listed above and got an "unable to connect" error. The error might be with the feed being down, not with your setup.
Go to the top of the page
 
+Quote Post
ironmantis7x
post Apr 7 2008, 10:06 PM
Post #12





Group: Members
Posts: 14
Joined: 4-April 08
Member No.: 21,592



QUOTE(apink @ Apr 7 2008, 09:26 PM) *
QUOTE(ironmantis7x @ Apr 7 2008, 05:57 PM) *
Now on the feed issue: here is the error::
ERROR: failed to retrieve http://mirror/pdaxrom.org/rc8/feed/Packages

ironmantis7x


Are you sure that your internet connection is up?
You might also try another feed source. I just tried to connect to the url listed above and got an "unable to connect" error. The error might be with the feed being down, not with your setup.



My internet connection is up ... I can surf the web ....
Do you have any other suggestions for which feeds I should try? My Zaurus is running 2.4.18-rmk7-pxa3-embedix.

Thanks!!

ironmantis7x
Go to the top of the page
 
+Quote Post
Capn_Fish
post Apr 8 2008, 03:41 AM
Post #13





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



I also cannot connect to that feed. Try the one at

http://distro.ibiblio.org/pub/linux/distri...axrom/download/

I've also had issues with feeds not being found. If you KNOW the URL is correct, try pinging the server before doing the "ipkg install."
Go to the top of the page
 
+Quote Post
ironmantis7x
post Apr 8 2008, 06:55 AM
Post #14





Group: Members
Posts: 14
Joined: 4-April 08
Member No.: 21,592



QUOTE(Capn_Fish @ Apr 8 2008, 03:41 AM) *
I also cannot connect to that feed. Try the one at

http://distro.ibiblio.org/pub/linux/distri...axrom/download/

I've also had issues with feeds not being found. If you KNOW the URL is correct, try pinging the server before doing the "ipkg install."



I tried that link and I am still getting erros with the downloads. I run the ipkg update and the packages still will not install.
The error that I get says something about cacko-unstable.

Is there a way to do a manual install of these packages that I am looking for (todo list, calander, firefox). If so can some one give me step-by-step instructions (I am new to linux and tha zaurus world)?

ironmantis7x
Go to the top of the page
 
+Quote Post
Capn_Fish
post Apr 8 2008, 08:15 AM
Post #15





Group: Members
Posts: 2,350
Joined: 30-July 06
Member No.: 10,575



Here's a manual way to install an ipk:

CODE
(on an ext2/ext3/jffs2 fs)
tar -xf some_ipk_arm.ipk
tar -xf data.tar.gz
cp -r (new directories that are made) /


The first line extracts the stuff from the ipk, the second extracts the data, and the third copies the data into your filesystem.
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 04:49 AM