OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Java On The C3000
totsubo
post Feb 22 2005, 03:12 AM
Post #1





Group: Members
Posts: 60
Joined: 12-February 05
Member No.: 6,461



How can I install Java on my SL-C3000?

Specifically I downloaded an application (J-Flash) that is a kanji flashcard program in a .jar file. It seems that java is not installedby default on the C3000 and I can find an ipk for java.

Jc
Go to the top of the page
 
+Quote Post
iamasmith
post Feb 22 2005, 03:29 AM
Post #2





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



QUOTE(totsubo @ Feb 22 2005, 11:12 AM)
How can I install Java on my SL-C3000?

Specifically I downloaded an application (J-Flash) that is a kanji flashcard program in a .jar file. It seems that java is not installedby default on the C3000 and I can find an ipk for java.

Jc
*


The JVMs that the Zaurus previously supported (Jeode on earlier models and Sun PersonalProfile for clamshells up to SL-C860) have been discontinued by Sharp from the SL-C3000 onwards.

I believe IBM have commercial offering for a JVM for the Zaurus, alternatively you could see if Kaffe or one of the other compatible runtimes lets you run it.

I'm not sure if anyone has built Kaffe for Qtopia yet though.

- Andy
Go to the top of the page
 
+Quote Post
totsubo
post Feb 22 2005, 04:10 AM
Post #3





Group: Members
Posts: 60
Joined: 12-February 05
Member No.: 6,461



Damn, does that mean that there is no way to run annd/or compile java applications for the C3000?

I bought the Zaurus b/c I thought that I could write my own application for it in Java. I didn't realize that the C3000 was the end of the line ....

If anyone knows how to get a JVM for the C3000 please let me know.
Go to the top of the page
 
+Quote Post
Kerensa
post Feb 22 2005, 04:42 AM
Post #4





Group: Members
Posts: 27
Joined: 30-November 04
From: Okinawa, Japan
Member No.: 5,675



I followed these instructions for my C3000 http://augustin.vidovic.org/pages/java_on_...3000/index.html

I also installed the jeode package from the feed www.cacko.biz/cacko/feed

I'm still learning, but these seemed for work for different java apps on the C3000.

Regards,
Kerensa

QUOTE(totsubo @ Feb 22 2005, 12:10 PM)
Damn, does that mean that there is no way to run annd/or compile java applications for the C3000?

I bought the Zaurus b/c I thought that I could write my own application for it in Java. I didn't realize that the C3000 was the end of the line ....

If anyone knows how to get a JVM for the C3000 please let me know.
*
Go to the top of the page
 
+Quote Post
iamasmith
post Feb 22 2005, 05:57 AM
Post #5





Group: Members
Posts: 1,248
Joined: 6-July 04
Member No.: 3,928



Not sure I like the idea of using Jeode. This version was licensed for the SL-5500 and I believe the SL-5600 but not for the SL-C series (up to 860) that was Sun PersonalProfile.

Basically your purchase of the product (a type of Zaurus accompanied with a downstream licensing deal) contributes to the licensing scheme of the sofware house that produced the runtime (as agreed between Sharp and the software house on a model by model basis) so it's important to have the right version licensed for your model to remain legit.

That doesn't change the fact that Sharp didn't license a JVM for the SL-C3000, I would suggest picking something free like Kaffe or using the IBM WebSphere environment (haven't tried it but its only $5.99 for a single device license)...

http://www.handango.com/PlatformProductDet...roductId=118025

- Andy
Go to the top of the page
 
+Quote Post
neutralidea
post Mar 23 2005, 09:00 AM
Post #6





Group: Members
Posts: 3
Joined: 23-March 05
Member No.: 6,698



Have someone tried to install the same Java Personal Profile on C860 to C3000? I should work, but I didn't try yet...

Let us know when someone did it...
Go to the top of the page
 
+Quote Post
rickh
post Mar 24 2005, 11:21 AM
Post #7





Group: Members
Posts: 143
Joined: 19-August 04
Member No.: 4,336



QUOTE(neutralidea @ Mar 23 2005, 05:00 PM)
Have someone tried to install the same Java Personal Profile on C860 to C3000? I should work, but I didn't try yet...

Let us know when someone did it...
*

I installed it on a C3000 without problems. It runs the one application I've tried (Project Pro), albeit poorly. That may have more to do with Project Pro being written specifically against Jeode, though.

I haven't tried any other java apps, but I'm sure that some will work, others won't.

R.
==
Go to the top of the page
 
+Quote Post
Omicron
post Mar 24 2005, 12:40 PM
Post #8





Group: Members
Posts: 608
Joined: 14-April 04
Member No.: 2,853



QUOTE(totsubo @ Feb 22 2005, 06:12 AM)
How can I install Java on my SL-C3000?

Specifically I downloaded an application (J-Flash) that is a kanji flashcard program in a .jar file. It seems that java is not installedby default on the C3000 and I can find an ipk for java.

Jc
*



Is the C-1000 in the same boat?
Go to the top of the page
 
+Quote Post
reinci
post Oct 11 2005, 09:20 AM
Post #9





Group: Members
Posts: 13
Joined: 6-October 05
From: Murcia
Member No.: 8,261



Hello everybody!!

I could install a JVM from the Sun Web page in a Z-SLC3000, a JEODE PersonaJava, but it is similar to version 1.3 of JVM. I need version 1.4 as mininum, and I can't find such version anywhere.

Someone knows somethinh about this?

Thank yoy very much
Go to the top of the page
 
+Quote Post
smuelas
post Nov 9 2005, 11:49 AM
Post #10





Group: Members
Posts: 110
Joined: 15-October 04
Member No.: 5,026



I have Java working perfectly on my SL-6000. I have jdk-1.1.8 but also Jeode and apart from that, a package with Swing.
I have installed everything without any use of ipk packages. Just downloading the JVM for Debian (I use Debian under Xqt). For Jeode, I don't care at all about licenses and other similar stories. I received my first 5500 with Jeode so I payed for everything, hardware and software. As I don't obtain any profit for my programs I don't feel any need to do any other way.
Coming back to Java, it should work exactly the same on the C-3000. In fact, my son has a 860 and the JDK and Swing work perfectly. I don't remember about Jeode.
Don't forget that Jeode is only useful if you use Qtopia. If you change to pdaXrom, it is of no use.
Finally, if someone wnat to see some nice snapshots of Java-programs running on Zaurus, I have put some on the page http://w3.mecanica.upm.es/~smuelas/debianxqt.html

If some one continue to be interested in having Java installed and working on his Zaurus, please contact me at smuelas@mecanica.upm.es and I will help as much as possible.

smuelas
Go to the top of the page
 
+Quote Post
Meanie
post Nov 9 2005, 03:13 PM
Post #11





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



I have built a cramfs image that contains the full blackdown 1.3.1 jre plus jikes and kopi compilers.
The new version I am working on also include the classpath tools and maybe will also include components from jamvm as well which has some of the 1.4 features implemented, but there is no complete 1.4 jre/jvm for the Zaurus afaik.

The cramfs image can be downloaded from http://www.thegrinder.ws/Meanies_XQT/java.cramfs.zip
Of course you will need to install XQT if you want swing or awt which is also available from there.

for more information, read http://users.on.net/~hluc/myZaurus/jumbo/xqtjumbo.html

and

http://www.users.on.net/~hluc/myZaurus/custom.html#java
Go to the top of the page
 
+Quote Post
smuelas
post Nov 11 2005, 05:17 PM
Post #12





Group: Members
Posts: 110
Joined: 15-October 04
Member No.: 5,026



Hi Meanie,
I've seen your impressive pages on Zaurus. You have done a lot of things!!
You seem to be the first one to have run java1.3.1 on Z. I've tried a lot of times but always finished with the problem of NOT finding this "famous" libstdc++-libc6.2-2.so.3 that java1.3 asks for. I have seen on your pages that you offer an ipq package with this library, but when I've tried to download it... no way: a negative answer about a broken link or something similar.
Would it be possible for you to put somewhere this library to let us download it?
Thanks a lot for all your excellent work.
smuelas




QUOTE(Meanie @ Nov 9 2005, 11:13 PM)
I have built a cramfs image that contains the full blackdown 1.3.1 jre plus jikes and kopi compilers.
The new version I am working on also include the classpath tools and maybe will also include components from jamvm as well which has some of the 1.4 features implemented, but there is no complete 1.4 jre/jvm for the Zaurus afaik.

The cramfs image can be downloaded from http://www.thegrinder.ws/Meanies_XQT/java.cramfs.zip
Of course you will need to install XQT if you want swing or awt which is also available from there.

for more information, read http://users.on.net/~hluc/myZaurus/jumbo/xqtjumbo.html

and

http://www.users.on.net/~hluc/myZaurus/custom.html#java
*
Go to the top of the page
 
+Quote Post
Meanie
post Nov 11 2005, 08:52 PM
Post #13





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(smuelas @ Nov 12 2005, 11:17 AM)
Hi Meanie,
I've seen your impressive pages on Zaurus. You have done a lot of things!!
You seem to be the first one to have run java1.3.1 on Z. I've tried a lot of times but always finished with the problem of NOT finding this "famous"  libstdc++-libc6.2-2.so.3 that java1.3 asks for. I have seen on your pages that you offer an ipq package with this library, but when I've tried to download it... no way: a negative answer about a broken link or something similar.
Would it be possible for you to put somewhere this library to let us download it?
Thanks a lot for all your excellent work.
smuelas




QUOTE(Meanie @ Nov 9 2005, 11:13 PM)
I have built a cramfs image that contains the full blackdown 1.3.1 jre plus jikes and kopi compilers.
The new version I am working on also include the classpath tools and maybe will also include components from jamvm as well which has some of the 1.4 features implemented, but there is no complete 1.4 jre/jvm for the Zaurus afaik.

The cramfs image can be downloaded from http://www.thegrinder.ws/Meanies_XQT/java.cramfs.zip
Of course you will need to install XQT if you want swing or awt which is also available from there.

for more information, read http://users.on.net/~hluc/myZaurus/jumbo/xqtjumbo.html

and

http://www.users.on.net/~hluc/myZaurus/custom.html#java
*

*




Thank you for your kind words. I did yet another typo in the links on my page. The correct link is http://www.users.on.net/~hluc/myZaurus/stu...6_1.2.2_arm.zip
Go to the top of the page
 
+Quote Post
smuelas
post Nov 12 2005, 11:25 AM
Post #14





Group: Members
Posts: 110
Joined: 15-October 04
Member No.: 5,026



Thanks a lot, Meanie. It works!. In a few days I will comment about the first tries. Thanks
smuelas
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st October 2014 - 07:45 AM