OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> How To Make Zeditor Default Text Editor?, How to associate txt files to zEditor?
znpp
post Dec 1 2005, 12:23 AM
Post #1





Group: Members
Posts: 8
Joined: 27-November 05
Member No.: 8,622



I installed ZEditor 3.2.2. English and find it much better than TextEditor 1.23 lite.

Tapping on text files used to automatically open TextEditor, but now that I've deleted TextEditor, I get the following message when I try to open text files:

"No application is defined for this document. Type is text/plain."

How do I create an association that will cause ZEditor to open as the default text editor when I tap on text files?

Thanks,

znpp
Go to the top of the page
 
+Quote Post
bam
post Dec 1 2005, 12:57 AM
Post #2





Group: Members
Posts: 1,213
Joined: 9-June 05
From: Gobi Desert, Mongolia
Member No.: 7,306



go Here
Go to the top of the page
 
+Quote Post
znpp
post Dec 1 2005, 01:21 AM
Post #3





Group: Members
Posts: 8
Joined: 27-November 05
Member No.: 8,622



Thanks for the background info on associations.

But I'm still in the dark about how to get text files to associate with ZEditor.

I guess something has to be typed into the console? What that something is, I have no idea....

znpp

"The file association information is derived from two places. The file /home/QtPalmtop/etc/mime.types stores the mime types that is used to derive the association information which is then combined with the desktop files stored under /home/QtPalmtop/apps

The information inside mime.types specifies what file extensions are associated with each file type."



QUOTE(bam @ Dec 1 2005, 03:57 AM)
go Here
*
Go to the top of the page
 
+Quote Post
znpp
post Dec 1 2005, 01:26 AM
Post #4





Group: Members
Posts: 8
Joined: 27-November 05
Member No.: 8,622



As long as I'm asking about how to make file associations - how would I associate MS-Word docs with TextMaker instead of Hancomword?

Thx,

znpp
Go to the top of the page
 
+Quote Post
znpp
post Dec 2 2005, 03:33 AM
Post #5





Group: Members
Posts: 8
Joined: 27-November 05
Member No.: 8,622



I'm still trying to associate text files with ZEditor.

As far as I can figure out, I go to the directory

/home/QtPalmtop/apps/Applications

and open "zeditor.desktop" with my text editor (in this case ZEditor)

Under "CanFastload=1" I then add:

MimeType=text/plain
MimeTypeIcons=zeditor

I do all that, but when I try to save the changed zeditor.desktop I get a write error message that prevents me from saving the changes.

How do I get the Zaurus to accept the changes to the file?

znpp
Go to the top of the page
 
+Quote Post
craigtyson
post Dec 2 2005, 04:25 AM
Post #6





Group: Members
Posts: 464
Joined: 15-June 04
Member No.: 3,698



also if you'r using the VGA file manager package you will need to make a symlink from textedit to zeditor to use the "View as Text" option.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th December 2014 - 02:09 AM