OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Why Does My Kernel Not Work?
Jinidog
post May 21 2005, 08:11 AM
Post #1





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



Hello,

after a hell of trying to get a crosscompiler running, I finally was able to compile my own kernel based on the openzaurus-poodle kernel just with devfs compiled in.
Anyway, after flashing it on the zaurus, the zaurus is dead and nothing works anymore.

I used this commands to get the kernelsource:
bitbake -b /openembedded/openembedded/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.bb -c fetch
bitbake -b /openembedded/openembedded/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.bb -c unpack
bitbake -b /openembedded/openembedded/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.bb -c patch

Patch failed in this case and I patched the source manually with this patches:
diff-2.4.18-rmk7-pxa3
patch-2.4.18-rmk7

I used the defconfig_poodle config file and put in a font and devfs.
You know the result when I flashed it on the zaurus.

This is the .config:
QUOTE
#
# Automatically generated by make menuconfig: don't edit
#
CONFIG_ARM=y
# CONFIG_EISA is not set
# CONFIG_SBUS is not set
# CONFIG_MCA is not set
CONFIG_UID16=y
CONFIG_RWSEM_GENERIC_SPINLOCK=y
# CONFIG_RWSEM_XCHGADD_ALGORITHM is not set
# CONFIG_GENERIC_BUST_SPINLOCK is not set
# CONFIG_GENERIC_ISA_DMA is not set

#
# Code maturity level options
#
CONFIG_EXPERIMENTAL=y
# CONFIG_OBSOLETE is not set

#
# Loadable module support
#
CONFIG_MODULES=y
# CONFIG_MODVERSIONS is not set
CONFIG_KMOD=y

#
# System Type
#
# CONFIG_ARCH_ANAKIN is not set
# CONFIG_ARCH_ARCA5K is not set
# CONFIG_ARCH_CLPS7500 is not set
# CONFIG_ARCH_CLPS711X is not set
# CONFIG_ARCH_CO285 is not set
CONFIG_ARCH_PXA=y
# CONFIG_ARCH_EBSA110 is not set
# CONFIG_ARCH_CAMELOT is not set
# CONFIG_ARCH_FOOTBRIDGE is not set
# CONFIG_ARCH_INTEGRATOR is not set
# CONFIG_ARCH_L7200 is not set
# CONFIG_ARCH_MX1ADS is not set
# CONFIG_ARCH_RPC is not set
# CONFIG_ARCH_SA1100 is not set
# CONFIG_ARCH_SHARK is not set

#
# Archimedes/A5000 Implementations
#
# CONFIG_ARCH_ARC is not set
# CONFIG_ARCH_A5K is not set

#
# Footbridge Implementations
#
# CONFIG_ARCH_CATS is not set
# CONFIG_ARCH_PERSONAL_SERVER is not set
# CONFIG_ARCH_EBSA285_ADDIN is not set
# CONFIG_ARCH_EBSA285_HOST is not set
# CONFIG_ARCH_NETWINDER is not set

#
# SA11x0 Implementations
#
# CONFIG_SA1100_ASSABET is not set
# CONFIG_ASSABET_NEPONSET is not set
# CONFIG_SA1100_ADSBITSY is not set
# CONFIG_SA1100_BRUTUS is not set
# CONFIG_SA1100_CEP is not set
# CONFIG_SA1100_CERF is not set
# CONFIG_SA1100_H3100 is not set
# CONFIG_SA1100_H3600 is not set
# CONFIG_SA1100_H3800 is not set
# CONFIG_SA1100_H3XXX is not set
# CONFIG_SA1100_EXTENEX1 is not set
# CONFIG_SA1100_FLEXANET is not set
# CONFIG_SA1100_FREEBIRD is not set
# CONFIG_SA1100_FRODO is not set
# CONFIG_SA1100_GRAPHICSCLIENT is not set
# CONFIG_SA1100_GRAPHICSMASTER is not set
# CONFIG_SA1100_BADGE4 is not set
# CONFIG_SA1100_JORNADA720 is not set
# CONFIG_SA1100_HUW_WEBPANEL is not set
# CONFIG_SA1100_ITSY is not set
# CONFIG_SA1100_LART is not set
# CONFIG_SA1100_NANOENGINE is not set
# CONFIG_SA1100_OMNIMETER is not set
# CONFIG_SA1100_PANGOLIN is not set
# CONFIG_SA1100_PLEB is not set
# CONFIG_SA1100_PT_SYSTEM3 is not set
# CONFIG_SA1100_SHANNON is not set
# CONFIG_SA1100_SHERMAN is not set
# CONFIG_SA1100_SIMPAD is not set
# CONFIG_SA1100_PFS168 is not set
# CONFIG_SA1100_VICTOR is not set
# CONFIG_SA1100_XP860 is not set
# CONFIG_SA1100_YOPY is not set
# CONFIG_SA1100_USB is not set
# CONFIG_SA1100_USB_NETLINK is not set
# CONFIG_SA1100_USB_CHAR is not set
# CONFIG_H3600_SLEEVE is not set

#
# Intel PXA250/210 Implementations
#
# CONFIG_ARCH_LUBBOCK is not set
# CONFIG_ARCH_PXA_IDP is not set
# CONFIG_ARCH_PXA_CERF is not set
# CONFIG_PXA_USB is not set
# CONFIG_PXA_USB_NETLINK is not set
# CONFIG_PXA_USB_CHAR is not set

#
# CLPS711X/EP721X Implementations
#
# CONFIG_ARCH_AUTCPU12 is not set
# CONFIG_ARCH_CDB89712 is not set
# CONFIG_ARCH_CLEP7312 is not set
# CONFIG_ARCH_EDB7211 is not set
# CONFIG_ARCH_P720T is not set
# CONFIG_ARCH_FORTUNET is not set
# CONFIG_ARCH_EP7211 is not set
# CONFIG_ARCH_EP7212 is not set
# CONFIG_ARCH_ACORN is not set
# CONFIG_FOOTBRIDGE is not set
# CONFIG_FOOTBRIDGE_HOST is not set
# CONFIG_FOOTBRIDGE_ADDIN is not set
CONFIG_CPU_32=y
# CONFIG_CPU_26 is not set
# CONFIG_CPU_32v3 is not set
# CONFIG_CPU_32v4 is not set
# CONFIG_CPU_ARM610 is not set
# CONFIG_CPU_ARM710 is not set
# CONFIG_CPU_ARM720T is not set
# CONFIG_CPU_ARM920T is not set
# CONFIG_CPU_ARM922T is not set
# CONFIG_PLD is not set
# CONFIG_CPU_ARM926T is not set
# CONFIG_CPU_ARM1020 is not set
# CONFIG_CPU_SA110 is not set
# CONFIG_CPU_SA1100 is not set
CONFIG_CPU_32v5=y
CONFIG_CPU_XSCALE=y
CONFIG_XSCALE_CACHE_ERRATA=y
CONFIG_ARM_THUMB=y
# CONFIG_DISCONTIGMEM is not set

#
# General setup
#
# CONFIG_PCI is not set
# CONFIG_ISA is not set
# CONFIG_ISA_DMA is not set
# CONFIG_ZBOOT_ROM is not set
CONFIG_ZBOOT_ROM_TEXT=0
CONFIG_ZBOOT_ROM_BSS=0
CONFIG_HOTPLUG=y

#
# PCMCIA/CardBus support
#
CONFIG_PCMCIA=y
# CONFIG_I82092 is not set
# CONFIG_I82365 is not set
# CONFIG_TCIC is not set
# CONFIG_PCMCIA_CLPS6700 is not set
# CONFIG_PCMCIA_SA1100 is not set
CONFIG_PCMCIA_PXA=y
CONFIG_NET=y
CONFIG_SYSVIPC=y
# CONFIG_BSD_PROCESS_ACCT is not set
CONFIG_SYSCTL=y
CONFIG_FPE_NWFPE=y
CONFIG_FPE_FASTFPE=y
CONFIG_KCORE_ELF=y
# CONFIG_KCORE_AOUT is not set
CONFIG_BINFMT_AOUT=y
CONFIG_BINFMT_ELF=y
# CONFIG_BINFMT_MISC is not set
CONFIG_PM=y
# CONFIG_ARTHUR is not set
CONFIG_CMDLINE="<see .oe file>"
CONFIG_ALIGNMENT_TRAP=y

#
# Parallel port support
#
# CONFIG_PARPORT is not set

#
# Memory Technology Devices (MTD)
#
CONFIG_MTD=y
# CONFIG_MTD_DEBUG is not set
CONFIG_MTD_PARTITIONS=y
# CONFIG_MTD_CONCAT is not set
# CONFIG_MTD_REDBOOT_PARTS is not set
CONFIG_MTD_CMDLINE_PARTS=y
# CONFIG_MTD_AFS_PARTS is not set
CONFIG_MTD_CHAR=y
CONFIG_MTD_BLOCK=y
# CONFIG_FTL is not set
# CONFIG_NFTL is not set

#
# RAM/ROM/Flash chip drivers
#
# CONFIG_MTD_CFI is not set
# CONFIG_MTD_JEDECPROBE is not set
# CONFIG_MTD_GEN_PROBE is not set
# CONFIG_MTD_CFI_INTELEXT is not set
# CONFIG_MTD_CFI_AMDSTD is not set
# CONFIG_MTD_RAM is not set
CONFIG_MTD_ROM=y
# CONFIG_MTD_ABSENT is not set
# CONFIG_MTD_OBSOLETE_CHIPS is not set
# CONFIG_MTD_AMDSTD is not set
# CONFIG_MTD_SHARP is not set
# CONFIG_MTD_JEDEC is not set

#
# Mapping drivers for chip access
#
# CONFIG_MTD_PHYSMAP is not set
# CONFIG_MTD_LUBBOCK is not set
# CONFIG_MTD_NORA is not set
# CONFIG_MTD_ARM_INTEGRATOR is not set
# CONFIG_MTD_CDB89712 is not set
# CONFIG_MTD_SA1100 is not set
# CONFIG_MTD_DC21285 is not set
# CONFIG_MTD_IQ80310 is not set
# CONFIG_MTD_FORTUNET is not set
# CONFIG_MTD_PXA_CERF is not set
# CONFIG_MTD_EPXA10DB is not set
# CONFIG_MTD_AUTCPU12 is not set
# CONFIG_MTD_EDB7312 is not set
# CONFIG_MTD_IMPA7 is not set
# CONFIG_MTD_PCI is not set

#
# Self-contained MTD device drivers
#
# CONFIG_MTD_PMC551 is not set
# CONFIG_MTD_SLRAM is not set
# CONFIG_MTD_MTDRAM is not set
# CONFIG_MTD_BLKMTD is not set
# CONFIG_MTD_DOC1000 is not set
# CONFIG_MTD_DOC2000 is not set
# CONFIG_MTD_DOC2001 is not set
# CONFIG_MTD_DOCPROBE is not set

#
# NAND Flash Device Drivers
#
CONFIG_MTD_NAND=y
CONFIG_MTD_NAND_ECC=y
CONFIG_MTD_NAND_VERIFY_WRITE=y
# CONFIG_MTD_NAND_ECC_JFFS2 is not set

#
# Plug and Play configuration
#
# CONFIG_PNP is not set
# CONFIG_ISAPNP is not set

#
# Block devices
#
# CONFIG_BLK_DEV_FD is not set
# CONFIG_BLK_DEV_XD is not set
# CONFIG_PARIDE is not set
# CONFIG_BLK_CPQ_DA is not set
# CONFIG_BLK_CPQ_CISS_DA is not set
# CONFIG_BLK_DEV_DAC960 is not set
CONFIG_BLK_DEV_LOOP=y
# CONFIG_BLK_DEV_NBD is not set
CONFIG_BLK_DEV_RAM=y
CONFIG_BLK_DEV_RAM_SIZE=8192
CONFIG_BLK_DEV_INITRD=y

#
# Multi-device support (RAID and LVM)
#
# CONFIG_MD is not set
# CONFIG_BLK_DEV_MD is not set
# CONFIG_MD_LINEAR is not set
# CONFIG_MD_RAID0 is not set
# CONFIG_MD_RAID1 is not set
# CONFIG_MD_RAID5 is not set
# CONFIG_MD_MULTIPATH is not set
# CONFIG_BLK_DEV_LVM is not set

#
# Networking options
#
CONFIG_PACKET=y
CONFIG_PACKET_MMAP=y
CONFIG_NETLINK_DEV=y
CONFIG_NETFILTER=y
# CONFIG_NETFILTER_DEBUG is not set
CONFIG_FILTER=y
CONFIG_UNIX=y
CONFIG_INET=y
# CONFIG_IP_MULTICAST is not set
# CONFIG_IP_ADVANCED_ROUTER is not set
# CONFIG_IP_PNP is not set
CONFIG_NET_IPIP=m
CONFIG_NET_IPGRE=m
# CONFIG_ARPD is not set
# CONFIG_INET_ECN is not set
# CONFIG_SYN_COOKIES is not set

#
#  IP: Netfilter Configuration
#
# CONFIG_IP_NF_CONNTRACK is not set
# CONFIG_IP_NF_QUEUE is not set
# CONFIG_IP_NF_IPTABLES is not set
# CONFIG_IP_NF_COMPAT_IPCHAINS is not set
# CONFIG_IP_NF_COMPAT_IPFWADM is not set
# CONFIG_IPV6 is not set
# CONFIG_KHTTPD is not set
# CONFIG_ATM is not set
# CONFIG_VLAN_8021Q is not set
# CONFIG_IPX is not set
# CONFIG_ATALK is not set
# CONFIG_DECNET is not set
# CONFIG_BRIDGE is not set
# CONFIG_X25 is not set
# CONFIG_LAPB is not set
# CONFIG_LLC is not set
# CONFIG_NET_DIVERT is not set
# CONFIG_ECONET is not set
# CONFIG_WAN_ROUTER is not set
# CONFIG_NET_FASTROUTE is not set
# CONFIG_NET_HW_FLOWCONTROL is not set

#
# QoS and/or fair queueing
#
# CONFIG_NET_SCHED is not set

#
# Network device support
#
CONFIG_NETDEVICES=y

#
# ARCnet devices
#
# CONFIG_ARCNET is not set
# CONFIG_DUMMY is not set
# CONFIG_BONDING is not set
# CONFIG_EQUALIZER is not set
# CONFIG_TUN is not set
# CONFIG_ETHERTAP is not set

#
# Ethernet (10 or 100Mbit)
#
CONFIG_NET_ETHERNET=y
# CONFIG_ARM_AM79C961A is not set
# CONFIG_SUNLANCE is not set
# CONFIG_SUNBMAC is not set
# CONFIG_SUNQE is not set
# CONFIG_SUNGEM is not set
# CONFIG_NET_VENDOR_3COM is not set
# CONFIG_LANCE is not set
# CONFIG_NET_VENDOR_SMC is not set
# CONFIG_NET_VENDOR_RACAL is not set
# CONFIG_NET_ISA is not set
# CONFIG_NET_PCI is not set
# CONFIG_NET_POCKET is not set

#
# Ethernet (1000 Mbit)
#
# CONFIG_ACENIC is not set
# CONFIG_DL2K is not set
# CONFIG_MYRI_SBUS is not set
# CONFIG_NS83820 is not set
# CONFIG_HAMACHI is not set
# CONFIG_YELLOWFIN is not set
# CONFIG_SK98LIN is not set
# CONFIG_FDDI is not set
# CONFIG_HIPPI is not set
# CONFIG_PLIP is not set
CONFIG_PPP=y
# CONFIG_PPP_MULTILINK is not set
# CONFIG_PPP_FILTER is not set
CONFIG_PPP_ASYNC=y
# CONFIG_PPP_SYNC_TTY is not set
# CONFIG_PPP_DEFLATE is not set
CONFIG_PPP_BSDCOMP=y
# CONFIG_PPPOE is not set
# CONFIG_SLIP is not set

#
# Wireless LAN (non-hamradio)
#
CONFIG_NET_RADIO=y
# CONFIG_STRIP is not set
# CONFIG_WAVELAN is not set
# CONFIG_ARLAN is not set
# CONFIG_AIRONET4500 is not set
# CONFIG_AIRONET4500_NONCS is not set
# CONFIG_AIRONET4500_PROC is not set
# CONFIG_HERMES is not set
# CONFIG_PCMCIA_HERMES is not set
# CONFIG_AIRO_CS is not set
CONFIG_NET_WIRELESS=y

#
# Token Ring devices
#
# CONFIG_TR is not set
# CONFIG_NET_FC is not set
# CONFIG_RCPCI is not set
# CONFIG_SHAPER is not set

#
# Wan interfaces
#
# CONFIG_WAN is not set

#
# PCMCIA network device support
#
CONFIG_NET_PCMCIA=y
# CONFIG_PCMCIA_3C589 is not set
# CONFIG_PCMCIA_3C574 is not set
# CONFIG_PCMCIA_FMVJ18X is not set
CONFIG_PCMCIA_PCNET=y
# CONFIG_PCMCIA_AXNET is not set
# CONFIG_PCMCIA_NMCLAN is not set
# CONFIG_PCMCIA_SMC91C92 is not set
# CONFIG_PCMCIA_XIRC2PS is not set
# CONFIG_ARCNET_COM20020_CS is not set
# CONFIG_PCMCIA_IBMTR is not set
# CONFIG_NET_PCMCIA_RADIO is not set

#
# Amateur Radio support
#
# CONFIG_HAMRADIO is not set

#
# IrDA (infrared) support
#
CONFIG_IRDA=y
# CONFIG_IRLAN is not set
CONFIG_IRNET=m
CONFIG_IRCOMM=y
# CONFIG_IRDA_ULTRA is not set
# CONFIG_IRDA_CACHE_LAST_LSAP is not set
CONFIG_IRDA_FAST_RR=y
# CONFIG_IRDA_DEBUG is not set

#
# Infrared-port device drivers
#
CONFIG_IRTTY_SIR=y
# CONFIG_IRPORT_SIR is not set
# CONFIG_DONGLE is not set
# CONFIG_USB_IRDA is not set
# CONFIG_NSC_FIR is not set
# CONFIG_WINBOND_FIR is not set
# CONFIG_TOSHIBA_FIR is not set
# CONFIG_SMC_IRCC_FIR is not set
# CONFIG_ALI_FIR is not set
# CONFIG_VLSI_FIR is not set

#
# ATA/IDE/MFM/RLL support
#
CONFIG_IDE=y

#
# IDE, ATA and ATAPI Block devices
#
CONFIG_BLK_DEV_IDE=y
# CONFIG_BLK_DEV_HD_IDE is not set
# CONFIG_BLK_DEV_HD is not set
CONFIG_BLK_DEV_IDEDISK=y
# CONFIG_IDEDISK_MULTI_MODE is not set
# CONFIG_BLK_DEV_IDEDISK_VENDOR is not set
# CONFIG_BLK_DEV_IDEDISK_FUJITSU is not set
# CONFIG_BLK_DEV_IDEDISK_IBM is not set
# CONFIG_BLK_DEV_IDEDISK_MAXTOR is not set
# CONFIG_BLK_DEV_IDEDISK_QUANTUM is not set
# CONFIG_BLK_DEV_IDEDISK_SEAGATE is not set
# CONFIG_BLK_DEV_IDEDISK_WD is not set
# CONFIG_BLK_DEV_COMMERIAL is not set
# CONFIG_BLK_DEV_TIVO is not set
CONFIG_BLK_DEV_IDECS=y
# CONFIG_BLK_DEV_IDECD is not set
# CONFIG_BLK_DEV_IDETAPE is not set
# CONFIG_BLK_DEV_IDEFLOPPY is not set
# CONFIG_BLK_DEV_IDESCSI is not set
# CONFIG_BLK_DEV_CMD640 is not set
# CONFIG_BLK_DEV_CMD640_ENHANCED is not set
# CONFIG_BLK_DEV_ISAPNP is not set
# CONFIG_IDE_CHIPSETS is not set
# CONFIG_IDEDMA_AUTO is not set
# CONFIG_DMA_NONPCI is not set
# CONFIG_BLK_DEV_IDE_MODES is not set
# CONFIG_BLK_DEV_ATARAID is not set
# CONFIG_BLK_DEV_ATARAID_PDC is not set
# CONFIG_BLK_DEV_ATARAID_HPT is not set

#
# SCSI support
#
# CONFIG_SCSI is not set

#
# I2O device support
#
# CONFIG_I2O is not set
# CONFIG_I2O_BLOCK is not set
# CONFIG_I2O_LAN is not set
# CONFIG_I2O_SCSI is not set
# CONFIG_I2O_PROC is not set

#
# ISDN subsystem
#
# CONFIG_ISDN is not set

#
# Input core support
#
# CONFIG_INPUT is not set
# CONFIG_INPUT_KEYBDEV is not set
# CONFIG_INPUT_MOUSEDEV is not set
# CONFIG_INPUT_JOYDEV is not set
# CONFIG_INPUT_EVDEV is not set

#
# Character devices
#
CONFIG_VT=y
CONFIG_VT_CONSOLE=y
CONFIG_SERIAL=y
# CONFIG_SERIAL_CONSOLE is not set
# CONFIG_SERIAL_EXTENDED is not set
# CONFIG_SERIAL_NONSTANDARD is not set

#
# Serial drivers
#
# CONFIG_SERIAL_ANAKIN is not set
# CONFIG_SERIAL_ANAKIN_CONSOLE is not set
# CONFIG_SERIAL_AMBA is not set
# CONFIG_SERIAL_AMBA_CONSOLE is not set
# CONFIG_SERIAL_CLPS711X is not set
# CONFIG_SERIAL_CLPS711X_CONSOLE is not set
# CONFIG_SERIAL_21285 is not set
# CONFIG_SERIAL_21285_OLD is not set
# CONFIG_SERIAL_21285_CONSOLE is not set
# CONFIG_SERIAL_UART00 is not set
# CONFIG_SERIAL_UART00_CONSOLE is not set
# CONFIG_SERIAL_SA1100 is not set
# CONFIG_SERIAL_SA1100_CONSOLE is not set
# CONFIG_SERIAL_8250 is not set
# CONFIG_SERIAL_8250_CONSOLE is not set
# CONFIG_SERIAL_8250_EXTENDED is not set
# CONFIG_SERIAL_8250_MANY_PORTS is not set
# CONFIG_SERIAL_8250_SHARE_IRQ is not set
# CONFIG_SERIAL_8250_DETECT_IRQ is not set
# CONFIG_SERIAL_8250_MULTIPORT is not set
# CONFIG_SERIAL_8250_HUB6 is not set
CONFIG_UNIX98_PTYS=y
CONFIG_UNIX98_PTY_COUNT=256

#
# I2C support
#
# CONFIG_I2C is not set

#
# L3 serial bus support
#
# CONFIG_L3 is not set
# CONFIG_L3_ALGOBIT is not set
# CONFIG_L3_BIT_SA1100_GPIO is not set
# CONFIG_L3_SA1111 is not set
# CONFIG_BIT_SA1100_GPIO is not set

#
# Mice
#
# CONFIG_BUSMOUSE is not set
# CONFIG_MOUSE is not set

#
# Joysticks
#
# CONFIG_INPUT_GAMEPORT is not set
# CONFIG_QIC02_TAPE is not set

#
# Watchdog Cards
#
# CONFIG_WATCHDOG is not set
# CONFIG_INTEL_RNG is not set
# CONFIG_NVRAM is not set
# CONFIG_RTC is not set
# CONFIG_DTLK is not set
# CONFIG_R3964 is not set
# CONFIG_APPLICOM is not set

#
# Ftape, the floppy tape device driver
#
# CONFIG_FTAPE is not set
# CONFIG_AGP is not set
# CONFIG_DRM is not set

#
# PCMCIA character devices
#
CONFIG_PCMCIA_SERIAL_CS=y
CONFIG_PCMCIA_CHRDEV=y

#
# Multimedia devices
#
# CONFIG_VIDEO_DEV is not set

#
# File systems
#
# CONFIG_QUOTA is not set
# CONFIG_AUTOFS_FS is not set
# CONFIG_AUTOFS4_FS is not set
# CONFIG_REISERFS_FS is not set
# CONFIG_REISERFS_CHECK is not set
# CONFIG_REISERFS_PROC_INFO is not set
# CONFIG_ADFS_FS is not set
# CONFIG_ADFS_FS_RW is not set
# CONFIG_AFFS_FS is not set
# CONFIG_HFS_FS is not set
# CONFIG_BFS_FS is not set
# CONFIG_EXT3_FS is not set
# CONFIG_JBD is not set
# CONFIG_JBD_DEBUG is not set
CONFIG_FAT_FS=y
# CONFIG_MSDOS_FS is not set
# CONFIG_UMSDOS_FS is not set
CONFIG_VFAT_FS=y
# CONFIG_EFS_FS is not set
# CONFIG_JFFS_FS is not set
CONFIG_JFFS2_FS=y
CONFIG_JFFS2_FS_DEBUG=0
CONFIG_CRAMFS=y
CONFIG_TMPFS=y
CONFIG_RAMFS=y
# CONFIG_ISO9660_FS is not set
# CONFIG_JOLIET is not set
# CONFIG_ZISOFS is not set
CONFIG_MINIX_FS=y
# CONFIG_VXFS_FS is not set
# CONFIG_NTFS_FS is not set
# CONFIG_NTFS_RW is not set
# CONFIG_HPFS_FS is not set
CONFIG_PROC_FS=y
CONFIG_DEVFS_FS=y
CONFIG_DEVFS_MOUNT=y
# CONFIG_DEVFS_DEBUG is not set
CONFIG_DEVPTS_FS=y
# CONFIG_QNX4FS_FS is not set
# CONFIG_QNX4FS_RW is not set
# CONFIG_ROMFS_FS is not set
CONFIG_EXT2_FS=y
# CONFIG_SYSV_FS is not set
# CONFIG_UDF_FS is not set
# CONFIG_UDF_RW is not set
# CONFIG_UFS_FS is not set
# CONFIG_UFS_FS_WRITE is not set

#
# Network File Systems
#
# CONFIG_CODA_FS is not set
# CONFIG_INTERMEZZO_FS is not set
CONFIG_NFS_FS=y
CONFIG_NFS_V3=y
# CONFIG_ROOT_NFS is not set
# CONFIG_NFSD is not set
# CONFIG_NFSD_V3 is not set
CONFIG_SUNRPC=y
CONFIG_LOCKD=y
CONFIG_LOCKD_V4=y
CONFIG_SMB_FS=m
# CONFIG_SMB_NLS_DEFAULT is not set
# CONFIG_NCP_FS is not set
# CONFIG_NCPFS_PACKET_SIGNING is not set
# CONFIG_NCPFS_IOCTL_LOCKING is not set
# CONFIG_NCPFS_STRONG is not set
# CONFIG_NCPFS_NFS_NS is not set
# CONFIG_NCPFS_OS2_NS is not set
# CONFIG_NCPFS_SMALLDOS is not set
# CONFIG_NCPFS_NLS is not set
# CONFIG_NCPFS_EXTRAS is not set
# CONFIG_ZISOFS_FS is not set
CONFIG_ZLIB_FS_INFLATE=y

#
# Partition Types
#
CONFIG_PARTITION_ADVANCED=y
# CONFIG_ACORN_PARTITION is not set
# CONFIG_OSF_PARTITION is not set
# CONFIG_AMIGA_PARTITION is not set
# CONFIG_ATARI_PARTITION is not set
# CONFIG_MAC_PARTITION is not set
CONFIG_MSDOS_PARTITION=y
# CONFIG_BSD_DISKLABEL is not set
# CONFIG_MINIX_SUBPARTITION is not set
# CONFIG_SOLARIS_X86_PARTITION is not set
# CONFIG_UNIXWARE_DISKLABEL is not set
# CONFIG_LDM_PARTITION is not set
# CONFIG_SGI_PARTITION is not set
# CONFIG_ULTRIX_PARTITION is not set
# CONFIG_SUN_PARTITION is not set
CONFIG_SMB_NLS=y
CONFIG_NLS=y

#
# Native Language Support
#
CONFIG_NLS_DEFAULT="iso8859-1"
CONFIG_NLS_CODEPAGE_437=y
# CONFIG_NLS_CODEPAGE_737 is not set
# CONFIG_NLS_CODEPAGE_775 is not set
CONFIG_NLS_CODEPAGE_850=y
# CONFIG_NLS_CODEPAGE_852 is not set
# CONFIG_NLS_CODEPAGE_855 is not set
# CONFIG_NLS_CODEPAGE_857 is not set
# CONFIG_NLS_CODEPAGE_860 is not set
# CONFIG_NLS_CODEPAGE_861 is not set
# CONFIG_NLS_CODEPAGE_862 is not set
# CONFIG_NLS_CODEPAGE_863 is not set
# CONFIG_NLS_CODEPAGE_864 is not set
# CONFIG_NLS_CODEPAGE_865 is not set
# CONFIG_NLS_CODEPAGE_866 is not set
# CONFIG_NLS_CODEPAGE_869 is not set
# CONFIG_NLS_CODEPAGE_936 is not set
# CONFIG_NLS_CODEPAGE_950 is not set
CONFIG_NLS_CODEPAGE_932=y
# CONFIG_NLS_CODEPAGE_949 is not set
# CONFIG_NLS_CODEPAGE_874 is not set
# CONFIG_NLS_ISO8859_8 is not set
# CONFIG_NLS_CODEPAGE_1250 is not set
# CONFIG_NLS_CODEPAGE_1251 is not set
CONFIG_NLS_ISO8859_1=y
# CONFIG_NLS_ISO8859_2 is not set
# CONFIG_NLS_ISO8859_3 is not set
# CONFIG_NLS_ISO8859_4 is not set
# CONFIG_NLS_ISO8859_5 is not set
# CONFIG_NLS_ISO8859_6 is not set
# CONFIG_NLS_ISO8859_7 is not set
# CONFIG_NLS_ISO8859_9 is not set
# CONFIG_NLS_ISO8859_13 is not set
# CONFIG_NLS_ISO8859_14 is not set
# CONFIG_NLS_ISO8859_15 is not set
# CONFIG_NLS_KOI8_R is not set
# CONFIG_NLS_KOI8_U is not set
CONFIG_NLS_UTF8=y

#
# Console drivers
#
CONFIG_PC_KEYMAP=y
# CONFIG_VGA_CONSOLE is not set

#
# Frame-buffer support
#
CONFIG_FB=y
CONFIG_DUMMY_CONSOLE=y
# CONFIG_FB_ACORN is not set
# CONFIG_FB_ANAKIN is not set
# CONFIG_FB_CLPS711X is not set
# CONFIG_FB_SA1100 is not set
# CONFIG_FB_PXA is not set
# CONFIG_FB_CYBER2000 is not set
# CONFIG_FB_VIRTUAL is not set
CONFIG_FBCON_ADVANCED=y
# CONFIG_FBCON_MFB is not set
# CONFIG_FBCON_CFB2 is not set
# CONFIG_FBCON_CFB4 is not set
# CONFIG_FBCON_CFB8 is not set
CONFIG_FBCON_CFB16=y
# CONFIG_FBCON_CFB24 is not set
# CONFIG_FBCON_CFB32 is not set
# CONFIG_FBCON_AFB is not set
# CONFIG_FBCON_ILBM is not set
# CONFIG_FBCON_IPLAN2P2 is not set
# CONFIG_FBCON_IPLAN2P4 is not set
# CONFIG_FBCON_IPLAN2P8 is not set
# CONFIG_FBCON_MAC is not set
# CONFIG_FBCON_VGA_PLANES is not set
# CONFIG_FBCON_VGA is not set
# CONFIG_FBCON_HGA is not set
# CONFIG_FBCON_FONTWIDTH8_ONLY is not set
CONFIG_FBCON_FONTS=y
# CONFIG_FONT_8x8 is not set
# CONFIG_FONT_8x16 is not set
# CONFIG_FONT_SUN8x16 is not set
# CONFIG_FONT_SUN12x22 is not set
# CONFIG_FONT_6x11 is not set
# CONFIG_FONT_PEARL_8x8 is not set
CONFIG_FONT_ACORN_8x8=y

#
# Sound
#
CONFIG_SOUND=y
# CONFIG_SOUND_BT878 is not set
# CONFIG_SOUND_CMPCI is not set
# CONFIG_SOUND_EMU10K1 is not set
# CONFIG_MIDI_EMU10K1 is not set
# CONFIG_SOUND_FUSION is not set
# CONFIG_SOUND_CS4281 is not set
# CONFIG_SOUND_ES1370 is not set
# CONFIG_SOUND_ES1371 is not set
# CONFIG_SOUND_ESSSOLO1 is not set
# CONFIG_SOUND_MAESTRO is not set
# CONFIG_SOUND_MAESTRO3 is not set
# CONFIG_SOUND_ICH is not set
# CONFIG_SOUND_RME96XX is not set
# CONFIG_SOUND_SONICVIBES is not set
# CONFIG_SOUND_TRIDENT is not set
# CONFIG_SOUND_MSNDCLAS is not set
# CONFIG_SOUND_MSNDPIN is not set
# CONFIG_SOUND_VIA82CXXX is not set
# CONFIG_MIDI_VIA82CXXX is not set
# CONFIG_SOUND_OSS is not set
# CONFIG_SOUND_WAVEARTIST is not set
# CONFIG_SOUND_PXA_AC97 is not set
# CONFIG_SOUND_TVMIXER is not set

#
# Multimedia Capabilities Port drivers
#
# CONFIG_MCP is not set
# CONFIG_MCP_SA1100 is not set
# CONFIG_MCP_UCB1200 is not set
# CONFIG_MCP_UCB1200_AUDIO is not set
# CONFIG_MCP_UCB1200_TS is not set
# CONFIG_MCP_UCB1400_TS is not set

#
# USB support
#
# CONFIG_USB is not set
# CONFIG_USB_UHCI is not set
# CONFIG_USB_UHCI_ALT is not set
# CONFIG_USB_OHCI is not set
# CONFIG_USB_OHCI_SA1111 is not set
# CONFIG_USB_AUDIO is not set
# CONFIG_USB_BLUETOOTH is not set
# CONFIG_USB_STORAGE is not set
# CONFIG_USB_STORAGE_DEBUG is not set
# CONFIG_USB_STORAGE_DATAFAB is not set
# CONFIG_USB_STORAGE_FREECOM is not set
# CONFIG_USB_STORAGE_ISD200 is not set
# CONFIG_USB_STORAGE_DPCM is not set
# CONFIG_USB_STORAGE_HP8200e is not set
# CONFIG_USB_STORAGE_SDDR09 is not set
# CONFIG_USB_STORAGE_JUMPSHOT is not set
# CONFIG_USB_ACM is not set
# CONFIG_USB_PRINTER is not set
# CONFIG_USB_DC2XX is not set
# CONFIG_USB_MDC800 is not set
# CONFIG_USB_SCANNER is not set
# CONFIG_USB_MICROTEK is not set
# CONFIG_USB_HPUSBSCSI is not set
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_KAWETH is not set
# CONFIG_USB_CATC is not set
# CONFIG_USB_CDCETHER is not set
# CONFIG_USB_USBNET is not set
# CONFIG_USB_USS720 is not set

#
# USB Serial Converter support
#
# CONFIG_USB_SERIAL is not set
# CONFIG_USB_SERIAL_GENERIC is not set
# CONFIG_USB_SERIAL_BELKIN is not set
# CONFIG_USB_SERIAL_WHITEHEAT is not set
# CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
# CONFIG_USB_SERIAL_EMPEG is not set
# CONFIG_USB_SERIAL_FTDI_SIO is not set
# CONFIG_USB_SERIAL_VISOR is not set
# CONFIG_USB_SERIAL_IPAQ is not set
# CONFIG_USB_SERIAL_IR is not set
# CONFIG_USB_SERIAL_EDGEPORT is not set
# CONFIG_USB_SERIAL_KEYSPAN_PDA is not set
# CONFIG_USB_SERIAL_KEYSPAN is not set
# CONFIG_USB_SERIAL_KEYSPAN_USA28 is not set
# CONFIG_USB_SERIAL_KEYSPAN_USA28X is not set
# CONFIG_USB_SERIAL_KEYSPAN_USA28XA is not set
# CONFIG_USB_SERIAL_KEYSPAN_USA28XB is not set
# CONFIG_USB_SERIAL_KEYSPAN_USA19 is not set
# CONFIG_USB_SERIAL_KEYSPAN_USA18X is not set
# CONFIG_USB_SERIAL_KEYSPAN_USA19W is not set
# CONFIG_USB_SERIAL_KEYSPAN_USA49W is not set
# CONFIG_USB_SERIAL_MCT_U232 is not set
# CONFIG_USB_SERIAL_KLSI is not set
# CONFIG_USB_SERIAL_PL2303 is not set
# CONFIG_USB_SERIAL_CYBERJACK is not set
# CONFIG_USB_SERIAL_XIRCOM is not set
# CONFIG_USB_SERIAL_OMNINET is not set
# CONFIG_USB_RIO500 is not set

#
# Bluetooth support
#
CONFIG_BLUEZ=m
CONFIG_BLUEZ_L2CAP=m

#
# Bluetooth device drivers
#
# CONFIG_BLUEZ_HCIUSB is not set
CONFIG_BLUEZ_HCIUART=m
CONFIG_BLUEZ_HCIVHCI=m

#
# Kernel hacking
#
CONFIG_FRAME_POINTER=y
# CONFIG_DEBUG_USER is not set
# CONFIG_DEBUG_INFO is not set
# CONFIG_NO_PGT_CACHE is not set
# CONFIG_DEBUG_KERNEL is not set
# CONFIG_DEBUG_SLAB is not set
# CONFIG_MAGIC_SYSRQ is not set
# CONFIG_DEBUG_SPINLOCK is not set
# CONFIG_DEBUG_WAITQ is not set
# CONFIG_DEBUG_BUGVERBOSE is not set
# CONFIG_DEBUG_ERRORS is not set
# CONFIG_DEBUG_LL is not set
# CONFIG_DEBUG_DC21285_PORT is not set
# CONFIG_DEBUG_CLPS711X_UART2 is not set


So, can you help me?
Go to the top of the page
 
+Quote Post
koen
post May 21 2005, 08:31 AM
Post #2





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(Jinidog @ May 21 2005, 04:11 PM)
Hello,

after a hell of trying to get a crosscompiler running, I finally was able to compile my own kernel based on the openzaurus-poodle kernel just with devfs compiled in.
Anyway, after flashing it on the zaurus, the zaurus is dead and nothing works anymore.

I used this commands to get the kernelsource:
bitbake -b /openembedded/openembedded/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.bb -c fetch
bitbake -b /openembedded/openembedded/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.bb -c unpack
bitbake -b /openembedded/openembedded/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.bb -c patch

Patch failed in this case and I patched the source manually with this patches:
*


Please include what error you are seeing, we aren't telepathic.
Go to the top of the page
 
+Quote Post
Jinidog
post May 21 2005, 08:34 AM
Post #3





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



I did not believe that that is important.
QUOTE
root@AMD2800 openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38 # bitbake -b /openembedded/openembedded/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.bb -c patch
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix: started
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_fetch: started
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_fetch: completed
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_unpack: started
NOTE: Unpacking /usr/portage/distfiles/linux-2.4.18.tar.bz2 to /openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/patch-2.4.18-rmk7.gz to /openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/diff-2.4.18-rmk7-pxa3.gz to /openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/linux-2.4.18-rmk7-pxa3-embedix-slc860-20031107-rom1_10.bz2 to /openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/openswan-2.2.0-kernel-2.4-klips.patch.gz to /openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/cifs-1.20c-2.4.tar.gz to /openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /openembedded/openembedded/packages/linux/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix20031107/defconfig-poodle to /openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_unpack: completed
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_patch: started
ERROR: function do_patchcleancmd failed
ERROR: log data follows (/openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/temp/log.do_patchcleancmd.7368)
| /openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/temp/run.do_patchcleancmd.7368: line 442: syntax error near unexpected token `'INHIBIT_PACKAGE_STRIP','
NOTE: Task failed:
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_patch: failed
ERROR: TaskFailed event exception, aborting
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix: failed
Build statistics:
  Attempted builds: 1
  Failed builds: 1
Go to the top of the page
 
+Quote Post
Jinidog
post May 21 2005, 10:49 AM
Post #4





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



It's quite mysterious why the defconfig_poodle does not select a font to compile in the kernel.
More mysterious is, that my kernel is around 870 kb big, although it only adds devfs to the openzaurus features.
The openzaurus kernel is 100kb bigger without devfs.

So, what is going wrong here?
Go to the top of the page
 
+Quote Post
lardman
post May 21 2005, 12:28 PM
Post #5





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



What are you compiling on?

It would be more useful to see the log file itself, rather than the output of bitbake.


Si

This post has been edited by lardman: May 21 2005, 12:28 PM
Go to the top of the page
 
+Quote Post
Jinidog
post May 21 2005, 12:31 PM
Post #6





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



I compile in a chroot of an old gentoo 1.2 on which I installed a crosscompiler 2.95.3 that works.

What logfile do you want?
Go to the top of the page
 
+Quote Post
lardman
post May 21 2005, 01:18 PM
Post #7





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



QUOTE
ERROR: log data follows (/openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/temp/log.do_patchcleancmd.7368)


Depending on the error, it usually has more info than is printed out by bitbake.

Also look at the .run file which it's talking about and see if you can spot the reason for the failure:

QUOTE
ine 442: syntax error near unexpected token `'INHIBIT_PACKAGE_STRIP','


I must admit that I don't enable INHIBIT_PACKAGE_STRIP.


Si
Go to the top of the page
 
+Quote Post
koen
post May 21 2005, 02:10 PM
Post #8





Group: Members
Posts: 1,014
Joined: 4-January 05
From: Enschede, The Netherlands
Member No.: 6,107



QUOTE(lardman @ May 21 2005, 09:18 PM)
QUOTE
ERROR: log data follows (/openembedded/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/temp/log.do_patchcleancmd.7368)


Depending on the error, it usually has more info than is printed out by bitbake.

Also look at the .run file which it's talking about and see if you can spot the reason for the failure:

QUOTE
ine 442: syntax error near unexpected token `'INHIBIT_PACKAGE_STRIP','


I must admit that I don't enable INHIBIT_PACKAGE_STRIP.


Si
*



I think the INHIBIT_PACKAGE_STRIP is being caused by not defining a package format. Set a correct DISTRO and MACHINE, and it'll patch ok (openzaurus-3.5.4 would be a good choice).
Go to the top of the page
 
+Quote Post
Jinidog
post May 22 2005, 04:22 AM
Post #9





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



I set the DISTRO, but it doesn't help.
But I think the error changed:

QUOTE
root@AMD2800 tmp # bitbake -b /openembedded/openembedded/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.bb -c unpack
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix: started
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_fetch: started
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_fetch: completed
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_unpack: started
NOTE: Unpacking /usr/portage/distfiles/linux-2.4.18.tar.bz2 to /reallyold/var/tmp/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/patch-2.4.18-rmk7.gz to /reallyold/var/tmp/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/diff-2.4.18-rmk7-pxa3.gz to /reallyold/var/tmp/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/linux-2.4.18-rmk7-pxa3-embedix-slc860-20031107-rom1_10.bz2 to /reallyold/var/tmp/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/openswan-2.2.0-kernel-2.4-klips.patch.gz to /reallyold/var/tmp/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /usr/portage/distfiles/cifs-1.20c-2.4.tar.gz to /reallyold/var/tmp/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: Unpacking /openembedded/openembedded/packages/linux/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix20031107/defconfig-poodle to /reallyold/var/tmp/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_unpack: completed
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix: completed
Build statistics:
  Attempted builds: 1
root@AMD2800 tmp # bitbake -b /openembedded/openembedded/packages/linux/openzaurus-pxa_2.4.18-rmk7-pxa3-embedix20031107.bb -c patch
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix: started
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_fetch: started
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_fetch: completed
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_patch: started
NOTE: Applying patch 'patch-2.4.18-rmk7'
ERROR: function do_patchcmd failed
ERROR: log data follows (/reallyold/var/tmp/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/temp/log.do_patchcmd.9091)
NOTE: Task failed:
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38: task do_patch: failed
ERROR: TaskFailed event exception, aborting
NOTE: package openzaurus-pxa-2.4.18-rmk7-pxa3-embedix: failed
Build statistics:
  Attempted builds: 1
  Failed builds: 1


The log.do_patchcmd.9091 is empty after the failed patching, log.do_patchcleancmd.9091contains this:
/reallyold/var/tmp/tmp/work/openzaurus-pxa-2.4.18-rmk7-pxa3-embedix-r38/temp/run.do_patchcleancmd.9091: line 1: quilt: command not found
Go to the top of the page
 
+Quote Post
Jinidog
post May 22 2005, 05:35 AM
Post #10





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



Okay, I needed to merge quilt for corectly patching the kernel.
Should be added to the gettingStarted OE Howto.
Go to the top of the page
 
+Quote Post
lardman
post May 22 2005, 05:43 AM
Post #11





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



http://openembedded.org/cgi-bin/moin.cgi/RequiredSoftware

Which is linked from the GettingStarted page.

Si
Go to the top of the page
 
+Quote Post
Hrw
post May 22 2005, 05:44 AM
Post #12





Group: Members
Posts: 1,376
Joined: 11-January 04
From: Poznań, Poland
Member No.: 1,413



normally quilt is built during build - you are using bitbake to build just one package so you have to install it by yourself.

BTW - patcher can be used instead of quilt
Go to the top of the page
 
+Quote Post
Jinidog
post May 22 2005, 07:04 AM
Post #13





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



Is it possible, that devfs is incompatible with the zaurus?
I always get an kernel panic, because it is unable to mount the root-fs.
I only added devfs to the kernel-config.
Go to the top of the page
 
+Quote Post
Jinidog
post May 22 2005, 07:15 AM
Post #14





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



No, it's the same without devfs.
But I simply use the poodle-config ohmy.gif
Go to the top of the page
 
+Quote Post
Jinidog
post May 22 2005, 07:29 AM
Post #15





Group: Members
Posts: 76
Joined: 25-April 05
From: Berlin, Germany
Member No.: 6,985



I built the gcc without the option '--with-newlib' because that broke the build.
Could that be the cause?
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th November 2014 - 04:24 AM