OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3 >  
Reply to this topicStart new topic
> Internet sharing Mac osx
keef
post May 12 2004, 11:43 AM
Post #16





Group: Members
Posts: 124
Joined: 31-January 04
Member No.: 1,634



Try adding the command:
route add -host 192.168.129.1 usbd0
this should direct the connection through usb.

keef
Go to the top of the page
 
+Quote Post
freizugheit
post May 12 2004, 07:12 PM
Post #17





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



asfrank16,

Please check whether you have activated Internet shaing uisng Sharing under System Preferences.

You need to modify your /etc/resolv.conf to include nameserver and IP there.
Go to the top of the page
 
+Quote Post
asfrank16
post May 13 2004, 04:43 AM
Post #18





Group: Members
Posts: 25
Joined: 29-April 04
Member No.: 3,071



How do I put the IP in the resolv.conf? I do have internet sharing on.
Go to the top of the page
 
+Quote Post
asfrank16
post May 13 2004, 04:44 AM
Post #19





Group: Members
Posts: 25
Joined: 29-April 04
Member No.: 3,071



What I meant to ask was not how (i know how to edit the file) but what syntax do I use in the file to specify the IP address
Go to the top of the page
 
+Quote Post
freizugheit
post May 14 2004, 06:37 PM
Post #20





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



Maybe you can post the content of /etc/resolv.con of Zaurus here.
Go to the top of the page
 
+Quote Post
asfrank16
post May 20 2004, 11:23 AM
Post #21





Group: Members
Posts: 25
Joined: 29-April 04
Member No.: 3,071



Sorry for the delay in responding.

the contents are as follows (I did not opy the warning about having to point to an actual nameserver):

nameserver 199.45.32.43
nameserver 199.45.32.38
Go to the top of the page
 
+Quote Post
freizugheit
post May 20 2004, 04:44 PM
Post #22





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



asfrank16,

By reading your ifconfig output posted on 29/4, it looks like your Mac was not connected to Internet directly.
Maybe let us know how you connect to the Interne, are you using another computer as a gateway.
Go to the top of the page
 
+Quote Post
asfrank16
post May 21 2004, 06:51 AM
Post #23





Group: Members
Posts: 25
Joined: 29-April 04
Member No.: 3,071



I am connected through the network (dsl router). The DSL router is part of the network router. The info entered as the nameserver is what my computer uses to connect to the network, not what the router uses to connect to the internet (if that makes sense).

-Adam
Go to the top of the page
 
+Quote Post
freizugheit
post May 21 2004, 08:17 AM
Post #24





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



asfrank16,

On the Mac's System Preferences, click Sharing and press Internet tab.
Select Buitl-In Ethernet follow by pressing the Start button.

I hope this will help share your built-in ethernet interface en1.
Go to the top of the page
 
+Quote Post
ericwerk
post May 26 2004, 12:28 AM
Post #25





Group: Members
Posts: 11
Joined: 9-May 04
From: mexico city
Member No.: 3,215



It cost me some sweat as well, but i have it working. You can find a nat how-to on the following address:
http://www.mac-im-netz.de/MacOSX-NAT.html
The first part is in german, but it basically says that in /etc/hostconfig you need to change the IPFORWARDING=-NO- line
to IPFORWARDING=-YES-

than just do what the rest of the how-to says, putting the three files in the /System/Library/StartupItems/NAT folder (make the folder if it doesn't exist) . And freizugheit's tip about checking if you have sharing allowed in the system's pref network panel is very important as well (I wish I would have read that before stumbling upon it)

Then on the zaurus type

route add -host 192.168.129.1 dev usbd0
route add -host 192.168.129.201 dev usbd0
route add default gw 192.168.129.1 dev usbd0

(not my idea these, also googled them from somewhere)
Go to the top of the page
 
+Quote Post
asfrank16
post Jun 3 2004, 09:29 AM
Post #26





Group: Members
Posts: 25
Joined: 29-April 04
Member No.: 3,071



Thank you all who helped. I now have access via my mac to email and the web. Thank you.

-Adam Frank
Go to the top of the page
 
+Quote Post
freizugheit
post Jun 4 2004, 02:46 AM
Post #27





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



asfrank16,

Can You share the steps or configurations you have done with us?
Go to the top of the page
 
+Quote Post
asfrank16
post Jun 4 2004, 05:09 AM
Post #28





Group: Members
Posts: 25
Joined: 29-April 04
Member No.: 3,071



I used the steps outlines by ericwork above exactly (I had to create the directory and three files myself). Then I was able to connect. I also think part of my problem was that I had the power saving features on, which terminated the connection whenever the mac went into power save mode (although this IS NOT what stopped me from connecting originally). Hope this helps.

-Adam
Go to the top of the page
 
+Quote Post
Ovi
post Jun 8 2004, 11:45 PM
Post #29





Group: Members
Posts: 27
Joined: 18-March 04
Member No.: 2,381



Hi
I tried also to acces my mail from my SLA-300 using the shared MAC ethernet but it does not work. I have sharing enabled on my Mac, the correct gw on my zaurus, the correct DNS server on my zaurus and the NAT modifications on my Mac. I can even ping the DNS server but when trying to get the mail it always complains about "unknown host". Bellow I attached the output of "ifconfig" on my Mac:

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet6 ::1 prefixlen 128
inet6 fe80::1 prefixlen 64 scopeid 0x1
inet 127.0.0.1 netmask 0xff000000
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::20a:95ff:fecf:6bea prefixlen 64 scopeid 0x4
inet 141.xx.xxx.x netmask 0xffffffc0 broadcast 141.xx.xxx.xx
ether 00:0a:95:cf:6b:ea
media: autoselect (100baseTX <full-duplex>) status: active
supported media: none autoselect 10baseT/UTP <half-duplex> 10baseT/UTP <
full-duplex> 10baseT/UTP <full-duplex,hw-loopback> 100baseTX <half-duplex> 100ba
seTX <full-duplex> 100baseTX <full-duplex,hw-loopback> 1000baseTX <full-duplex>
1000baseTX <full-duplex,hw-loopback> 1000baseTX <full-duplex,flow-control> 1000b
aseTX <full-duplex,flow-control,hw-loopback>
fw0: flags=8822<BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 2030
lladdr 00:0a:95:ff:fe:cf:6b:ea
media: autoselect <full-duplex> status: inactive
supported media: autoselect <full-duplex>
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet 192.168.129.1 netmask 0xffffff00 broadcast 192.168.129.255
ether 34:30:30:30:30:00
Go to the top of the page
 
+Quote Post
Ovi
post Jun 9 2004, 10:24 PM
Post #30





Group: Members
Posts: 27
Joined: 18-March 04
Member No.: 2,381



Hi
On my home setup where I share between my mac and my zaurus the modem line (dynamic IP) I can easily acces the internet from my zaurus even without the NAT files installed (just sharing from System Preferences and add the mac as a default gateway on my zaurus).

On my work setup I have a static IP for my computer and it uses a gateway somewhere on a central server of the lab to acces the net.[/i]
Go to the top of the page
 
+Quote Post

3 Pages V  < 1 2 3 >
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 31st October 2014 - 01:11 AM