OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Ruby 1.8.3 Compiled.., Tested with ruby on rails...
willgan
post Oct 1 2005, 11:00 AM
Post #1





Group: Members
Posts: 84
Joined: 9-December 04
From: KL, Malaysia
Member No.: 5,869



I've finish compiling ruby 1.8.3...

Some minor problem during compilation...
socket extension is missing... but i compile the file manually... luckly it works..
Without the socket extension ruby on rails.. won't work...

So if you like ruby.. download this package... download ruby on rails..
unzip ruby on rails to CF or SD card..
Run

ruby script/server # in the ruby on rails directory

Point your browser to http://<zaurus ip>:3000

There you have it... ruby on rails on Z.. hope you like it

Dependencies...

0x00000001 (NEEDED) Shared library: [libdl.so.2]
0x00000001 (NEEDED) Shared library: [libcrypt.so.1]
0x00000001 (NEEDED) Shared library: [libm.so.6]
0x00000001 (NEEDED) Shared library: [libc.so.6]

Attached File  ruby_1.8.3_armv5tel_iwmmxt.ipk ( 1.6MB ) Number of downloads: 112

Attached File  ruby_1.8.3_armv5tel.ipk ( 1.57MB ) Number of downloads: 80
Go to the top of the page
 
+Quote Post
henrysviper
post Oct 1 2005, 12:03 PM
Post #2





Group: Members
Posts: 76
Joined: 4-May 04
From: Athens, Greece
Member No.: 3,136



I would be interested. Please do try to compile ruby :-)

And if you could make a package for gem or rails ... that would be even better!
Go to the top of the page
 
+Quote Post
spank
post Oct 3 2005, 12:00 AM
Post #3





Group: Members
Posts: 2
Joined: 2-October 05
Member No.: 8,239



is anyone able to compile the ruby extension for sqlite?
http://rubyforge.org/projects/sqlite-ruby/

thanks,

bio.
Go to the top of the page
 
+Quote Post
sds
post Oct 3 2005, 09:58 AM
Post #4





Group: Members
Posts: 81
Joined: 15-March 05
Member No.: 6,635



willgan, would you kindly set a feed/download for the many interesting packages you are compiling?
Or negotiate to download to some set-up feed already mentioned in the current forum?
Go to the top of the page
 
+Quote Post
willgan
post Oct 3 2005, 05:07 PM
Post #5





Group: Members
Posts: 84
Joined: 9-December 04
From: KL, Malaysia
Member No.: 5,869



QUOTE(sds @ Oct 3 2005, 05:58 PM)
willgan, would you kindly set a feed/download for the many interesting packages you are compiling?
Or negotiate to download to some set-up feed already mentioned in the current forum?
*


The problem is... i don't have a server space to place the build yet...
Working on it...
Go to the top of the page
 
+Quote Post
ScottYelich
post Oct 6 2005, 05:52 AM
Post #6





Group: Members
Posts: 992
Joined: 9-October 03
From: NYC
Member No.: 609



I will host any legal zaurus content that you need hosted.

Scott
Go to the top of the page
 
+Quote Post
ltrm
post Oct 19 2005, 02:12 PM
Post #7





Group: Members
Posts: 86
Joined: 21-January 04
Member No.: 793



Any news on how the new version of Ruby is comming along?

I'm really interested in using Rails on the move.
Go to the top of the page
 
+Quote Post
willgan
post Oct 20 2005, 02:50 AM
Post #8





Group: Members
Posts: 84
Joined: 9-December 04
From: KL, Malaysia
Member No.: 5,869



updated ruby .... please read first message
Go to the top of the page
 
+Quote Post
ltrm
post Oct 20 2005, 04:35 AM
Post #9





Group: Members
Posts: 86
Joined: 21-January 04
Member No.: 793



Excellent!

I'll have a go installing this afternoon.

Many thanks,

ltrm
Go to the top of the page
 
+Quote Post
spank
post Oct 20 2005, 07:54 AM
Post #10





Group: Members
Posts: 2
Joined: 2-October 05
Member No.: 8,239



thank you for compiling ruby,
it's a shocking programming language smile.gif

bio.
Go to the top of the page
 
+Quote Post
ltrm
post Oct 20 2005, 12:16 PM
Post #11





Group: Members
Posts: 86
Joined: 21-January 04
Member No.: 793



Hmmm....

I'm getting an "Illegal instruction" error when I try to run any ruby scripts including Rails.

I notice that the ipk has iwmmxt in file name, could this mean that the ipk will only run on a PXA270 equiped Zaurus?

Failing that any other suggestions?
Go to the top of the page
 
+Quote Post
willgan
post Oct 20 2005, 06:33 PM
Post #12





Group: Members
Posts: 84
Joined: 9-December 04
From: KL, Malaysia
Member No.: 5,869



updated with xscale processor..
Go to the top of the page
 
+Quote Post
ltrm
post Oct 21 2005, 02:23 AM
Post #13





Group: Members
Posts: 86
Joined: 21-January 04
Member No.: 793



Looks like both Ruby and Rails are now working perfectly! biggrin.gif

Thanks again Willgan.

Gem is working for me also so now I can use that to fetch and install other ruby "stuff".
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th December 2014 - 04:56 PM