OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Connect Zaurus To Network/www Over Usb?, Can't connect zaurus 5500 to network
elwood151
post May 29 2005, 02:56 AM
Post #1





Group: Members
Posts: 27
Joined: 26-December 04
From: Pforzheim, Germany
Member No.: 6,021



Hi,

I'm trying to access the other computers in my local network with my Zaurus.

Zaurus 5500G
Sharp ROM 3.13
Cacko Kernel Patch
IP 192.168.129.201

connected over USB cradle to
PowerBook G4
OS 10.3.4
USB driver 0.2.8
USB-IP 192.168.129.1

The powerBook is connected via Airport to the WLAN/DSL-Router
IP 192.168.2.1

I can mount the Zaurus as SMB-Volume on the PowerBook, I can ping Zaurus/PowerBook,
but I can't ping the WLAN router or any other PC in the network 192.168.2.x with the Zaurus.

I tried the following on the Zaurus:

sudo route add -host 192.168.129.1 usbd0
sudo route add default gw 192.168.129.1



The routing table on the zaurus ("route") looks as follows:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.129.1 * 255.255.255.255 UH 0 0 0 usbd0
192.168.129.0 * 255.255.255.0 U 0 0 0 usbd0
default 192.168.129.1 0.0.0.0 UG 0 0 0 usbd0



Can anybody tell me what I've done wrong?
Do I have to activate anything on the PowerBook to provide the Zaurus access to the local network and also to Internet?

Unfortunately, I'm not a linux geek, I found the "route" commands on the net and tried them, but was not lucky yet..

Best regards

Martin
Go to the top of the page
 
+Quote Post
Ovi
post Jun 3 2005, 01:08 AM
Post #2





Group: Members
Posts: 27
Joined: 18-March 04
Member No.: 2,381



QUOTE(elwood151 @ May 29 2005, 02:56 AM)
Hi,

I'm trying to access the other computers in my local network with my Zaurus.

Zaurus 5500G
Sharp ROM 3.13
Cacko Kernel Patch
IP 192.168.129.201

connected over USB cradle to
PowerBook G4
OS 10.3.4
USB driver 0.2.8
USB-IP 192.168.129.1

The powerBook is connected via Airport to the WLAN/DSL-Router
IP 192.168.2.1

I can mount the Zaurus as SMB-Volume on the PowerBook, I can ping Zaurus/PowerBook,
but I can't ping the WLAN router or any other PC in the network 192.168.2.x with the Zaurus.

I tried the following on the Zaurus:

sudo route add -host 192.168.129.1 usbd0
sudo route add default  gw 192.168.129.1



The routing table on the zaurus ("route") looks as follows:

Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
192.168.129.1  *              255.255.255.255 UH    0      0        0 usbd0
192.168.129.0  *              255.255.255.0  U    0      0        0 usbd0
default        192.168.129.1  0.0.0.0        UG    0      0        0 usbd0



Can anybody tell me what I've done wrong?
Do I have to activate anything on the PowerBook to provide the Zaurus access to the local network and also to Internet?

Unfortunately, I'm not a linux geek, I found the "route" commands on the net and tried them, but was not lucky yet..

Best regards

Martin
*

if you're using a DNS server for your mac/network you should add this in your /etc/resolv.conf file on zaurus.
Go to the top of the page
 
+Quote Post
elwood151
post Jun 3 2005, 03:45 AM
Post #3





Group: Members
Posts: 27
Joined: 26-December 04
From: Pforzheim, Germany
Member No.: 6,021



QUOTE(Ovi @ Jun 3 2005, 09:08 AM)
QUOTE(elwood151 @ May 29 2005, 02:56 AM)
Hi,

I'm trying to access the other computers in my local network with my Zaurus.

Zaurus 5500G
Sharp ROM 3.13
Cacko Kernel Patch
IP 192.168.129.201

connected over USB cradle to
PowerBook G4
OS 10.3.4
USB driver 0.2.8
USB-IP 192.168.129.1

The powerBook is connected via Airport to the WLAN/DSL-Router
IP 192.168.2.1

I can mount the Zaurus as SMB-Volume on the PowerBook, I can ping Zaurus/PowerBook,
but I can't ping the WLAN router or any other PC in the network 192.168.2.x with the Zaurus.

I tried the following on the Zaurus:

sudo route add -host 192.168.129.1 usbd0
sudo route add default  gw 192.168.129.1



The routing table on the zaurus ("route") looks as follows:

Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
192.168.129.1  *              255.255.255.255 UH    0      0        0 usbd0
192.168.129.0  *              255.255.255.0  U    0      0        0 usbd0
default        192.168.129.1  0.0.0.0        UG    0      0        0 usbd0



Can anybody tell me what I've done wrong?
Do I have to activate anything on the PowerBook to provide the Zaurus access to the local network and also to Internet?

Unfortunately, I'm not a linux geek, I found the "route" commands on the net and tried them, but was not lucky yet..

Best regards

Martin
*

if you're using a DNS server for your mac/network you should add this in your /etc/resolv.conf file on zaurus.
*




Hi Ovi,

I'm not using a DNS server in my network or at least I don't know that I do. :-)

The DSL router connects to the internet, is the base station for the WLAN and the PC is connected to it via ethernet.
That's all, and I did not configure any DNS server in the router myself.

Best regards

Martin
Go to the top of the page
 
+Quote Post
mokawi
post Dec 12 2006, 12:21 PM
Post #4





Group: Members
Posts: 6
Joined: 11-September 05
Member No.: 8,085



I had the same complaint... until I realized that it was because I had not enabled internet sharing on the mac! I worked alright, right until the zaurus went to sleep... and since then, I've never had it work again.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 03:44 AM