OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

9 Pages V  « < 6 7 8 9 >  
Reply to this topicStart new topic
> I Mounted A 2 Gig Sd Card!, Surprise, it's possible! :)
pelrun
post Jul 18 2007, 04:57 PM
Post #106





Group: Members
Posts: 369
Joined: 6-September 04
From: Brisbane, Australia
Member No.: 4,488



If I recall correctly the pdaXrom module is just the official sharp module from the 3200, which luckily works just fine on the 3100 and 1000 biggrin.gif

SharpROM/pdaXrom beta3/pdaXii13 are all on 2.4.20 kernels for those models, so the module is compatible.
Go to the top of the page
 
+Quote Post
pgas
post Jul 19 2007, 12:57 AM
Post #107





Group: Members
Posts: 1,099
Joined: 17-December 03
From: Athens, Greece
Member No.: 1,210



QUOTE(pelrun @ Jul 19 2007, 02:57 AM)
If I recall correctly the pdaXrom module is just the official sharp module from the 3200, which luckily works just fine on the 3100 and 1000 biggrin.gif

SharpROM/pdaXrom beta3/pdaXii13 are all on 2.4.20 kernels for those models, so the module is compatible.
*


IIRC at some point sashz had ported a driver from somewhere module to the 2.4 kernel, and had upgraded the 2.4.18 kernel to 2.4.20 for the 760 and co (circa beta 3)

So there was another driver....and unfortunately quite buggy, at least on 760 ..and not working so well for card >1G IIRC.
Go to the top of the page
 
+Quote Post
tux
post Jul 19 2007, 04:29 AM
Post #108





Group: Members
Posts: 450
Joined: 12-August 03
From: Leeds, UK
Member No.: 346



QUOTE(xamindar @ Jul 18 2007, 09:42 PM)
I'm way late in trying this out.  But I glanced through this thread and am I right in thinking that there is no 2gb+ driver for my c3100?  Too bad sad.gif
*


cool.gif

Xamindar,

there is a file for use on the 3100 and 3000. I have attached it to this post.

To any 3200 users who, like me, use Cacko 1.23: you need to use this too! wink.gif


It is now possible to break the 1GB limit on the 5500, the cxxxs, and the cxxxxs! I don't know about the 5600. sad.gif

By the way, the attachment is a zip file containing the ipk. The gz is just the workaround we have to use because they still haven't fixed the attachment problems. rolleyes.gif
Attached File(s)
Attached File  sd_driver.zip.gz ( 27.32K ) Number of downloads: 72
 
Go to the top of the page
 
+Quote Post
pelrun
post Jul 19 2007, 06:25 AM
Post #109





Group: Members
Posts: 369
Joined: 6-September 04
From: Brisbane, Australia
Member No.: 4,488



Tux, the module in the ipk you posted is identical to the one meanie posted biggrin.gif But there are installer script differences, which I guess make meanie's better for pdaXrom and yours better for sharp/cacko.

I avoided the whole distro problem and just uploaded the bare modules... smile.gif
Go to the top of the page
 
+Quote Post
cybersphinx
post Jul 19 2007, 09:34 AM
Post #110





Group: Members
Posts: 70
Joined: 24-May 04
From: Germany
Member No.: 3,406



Short report: The C760 driver loads and seems to work (finds my 2gb card). More extensive tests when I've filled the card with stuff.
Go to the top of the page
 
+Quote Post
ogrefish
post Jul 20 2007, 06:31 AM
Post #111





Group: Members
Posts: 16
Joined: 15-January 07
Member No.: 13,966



Thank you.

2gig sandisk standard works great on the 760

1983360 kb out of 2gig with fat
1952499 kb using ext2 before running a full card including debian chrooted.

Thats so great.thanks again.
Go to the top of the page
 
+Quote Post
Zeke
post Jul 30 2007, 05:35 PM
Post #112





Group: Members
Posts: 4
Joined: 5-February 04
Member No.: 1,719



Hey Guys:

I guess the poodle is the only dog not in this luv' fest! Right?? ph34r.gif

Zeke
Go to the top of the page
 
+Quote Post
pelrun
post Jul 30 2007, 08:45 PM
Post #113





Group: Members
Posts: 369
Joined: 6-September 04
From: Brisbane, Australia
Member No.: 4,488



If the 5600 needs a different module to the 5500, send the original 5600 module my way and I'll see what I can do.
Go to the top of the page
 
+Quote Post
enclose789
post Oct 26 2007, 05:25 AM
Post #114





Group: Members
Posts: 13
Joined: 26-October 07
Member No.: 20,862



I am using SL-6000L, but I cannot make the file which under /lib/modules(&modules.com)/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o to be replaced via Tree!Explorer QT by copy & Paste. It is always showing that "Cannot write '/lib/modules/2.4.18-rmk7-pxa3-embedix/********/sharp_mmcsd_m.o'. You do not have the permission or the file may be in use", so that I could not replace it. Could you please tell me how to change this file to the fixed one?? Many Thanks!
Go to the top of the page
 
+Quote Post
Cyril92
post Oct 26 2007, 06:05 AM
Post #115





Group: Members
Posts: 122
Joined: 12-January 04
From: Paris, France
Member No.: 1,418



QUOTE(enclose789 @ Oct 26 2007, 03:25 PM) *
I am using SL-6000L, but I cannot make the file which under /lib/modules(&modules.com)/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o to be replaced via Tree!Explorer QT by copy & Paste. It is always showing that "Cannot write '/lib/modules/2.4.18-rmk7-pxa3-embedix/********/sharp_mmcsd_m.o'. You do not have the permission or the file may be in use", so that I could not replace it. Could you please tell me how to change this file to the fixed one?? Many Thanks!

Probably you should be root to have rights to change such this file.
Go to the top of the page
 
+Quote Post
enclose789
post Oct 26 2007, 06:16 AM
Post #116





Group: Members
Posts: 13
Joined: 26-October 07
Member No.: 20,862



QUOTE(Cyril92 @ Oct 26 2007, 06:05 AM) *
Probably you should be root to have rights to change such this file.


Thanks for this info. I had changed the Tree!Explorer to root when I revised this file, and it didn't work. Anything I missed? Please help me to use the 2GB SD Card on my 6000L. Thanks in advance!
Go to the top of the page
 
+Quote Post
xamindar
post Oct 26 2007, 05:05 PM
Post #117





Group: Members
Posts: 803
Joined: 30-March 04
From: California
Member No.: 2,368



QUOTE(enclose789 @ Oct 26 2007, 07:16 AM) *
QUOTE(Cyril92 @ Oct 26 2007, 06:05 AM) *
Probably you should be root to have rights to change such this file.


Thanks for this info. I had changed the Tree!Explorer to root when I revised this file, and it didn't work. Anything I missed? Please help me to use the 2GB SD Card on my 6000L. Thanks in advance!


You might have to do it at the console. Do you have the konsole program installed?
Just use "su" to become root and copy it. Make sure you make a backup of the original file first in case the new one doesn't work. "cp original_file original_file.bak"

If you are not comfortable using the konsole just ask here and we can help you out.
Go to the top of the page
 
+Quote Post
enclose789
post Oct 27 2007, 05:17 AM
Post #118





Group: Members
Posts: 13
Joined: 26-October 07
Member No.: 20,862



Thaks for your kindly answers, I am so happy that all you would like to help me to mount the 2 GB SD card. biggrin.gif

QUOTE(xamindar @ Oct 26 2007, 05:05 PM) *
You might have to do it at the console. Do you have the konsole program installed?

Do you mean "Terminal"? Yes, I had installed it, and I had installed the konsole, too. But I don't know how to use them correctly wacko.gif .

QUOTE(xamindar @ Oct 26 2007, 05:05 PM) *
Just use "su" to become root and copy it. Make sure you make a backup of the original file first in case the new one doesn't work. "cp original_file original_file.bak"
If you are not comfortable using the konsole just ask here and we can help you out.


I found that there are "Two" sharp_mmcsd_m.o files that under two different directories listed below:
/lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o, <--- this one (sharp_mmcsd_m.o) looks like linked to the other one listed below.

/lib/modules.rom/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o

Please tell me which one should be replaced??

I have tried to backup the two original files (sharp_mmcsd_m.o) via Terminal, but failed due to I am not comfortable using the Terminal. I use the description below tried to enter the /lib/xxxxxxxxxx/block/ directory first:
su
cd /lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/

when I pressed enter at that time, I got "No such file or directory" message, and I have no idea what to do then.

Please help me to mount the 2 GB SD card, thanks again.


Go to the top of the page
 
+Quote Post
cybersphinx
post Oct 27 2007, 05:32 AM
Post #119





Group: Members
Posts: 70
Joined: 24-May 04
From: Germany
Member No.: 3,406



QUOTE(enclose789 @ Oct 27 2007, 03:17 PM) *
I found that there are "Two" sharp_mmcsd_m.o files that under two different directories listed below:
/lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o, <--- this one (sharp_mmcsd_m.o) looks like linked to the other one listed below.

/lib/modules.rom/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o

Please tell me which one should be replaced??

The /lib/modules.rom/ directory is not writeable, you have to use /lib/modules/.

QUOTE
I have tried to backup the two original files (sharp_mmcsd_m.o) via Terminal, but failed due to I am not comfortable using the Terminal. I use the description below tried to enter the /lib/xxxxxxxxxx/block/ directory first:
su
cd /lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/

when I pressed enter at that time, I got "No such file or directory" message, and I have no idea what to do then.

After the cd, use Tab to complete the directory name (once if there is no other possible completion, twice to see all alternatives) to be sure you don't have a typo in there, then it should work.


By the way, the module for the C760 works flawlessly. Thanks again to pelrun for making it, 1GB was getting a bit small.
Go to the top of the page
 
+Quote Post
enclose789
post Oct 27 2007, 06:13 AM
Post #120





Group: Members
Posts: 13
Joined: 26-October 07
Member No.: 20,862



Thanks Cyril92, Xamindar, and Cybersphinx for helping me, thanks again!!

QUOTE(cybersphinx @ Oct 27 2007, 05:32 AM) *
QUOTE(enclose789 @ Oct 27 2007, 03:17 PM) *
I found that there are "Two" sharp_mmcsd_m.o files that under two different directories listed below:
/lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o, <--- this one (sharp_mmcsd_m.o) looks like linked to the other one listed below.
/lib/modules.rom/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/sharp_mmcsd_m.o
Please tell me which one should be replaced??

The /lib/modules.rom/ directory is not writeable, you have to use /lib/modules/.


Thanks for your reply, it works!!! I have backup the original files!!

However, I have further question: How could I replace the original sharp_mmcsd_m.o to the fixed one under /lib/modules/2.4.18-rmk7-pxa3-embedix/kernel/drivers/block/ ??

I guess that I may replace the original file by the following methods, please tell me which one is correct:

1. Delete the original sharp_mmcsd_m.o under /lib/modules/, and use Tree!Explorer copy and paste the fixed one to the same directory, reboot??

2. Using Terminal to replace the original file. But I do not know how to do it, could you tell me the method??

3. Should I re-link the fixed file to the original sharp_mmcsd_m.o under /lib/modules.rom/?? Or I have to create a new link?? If I have to create the new link, how to create the new link??

Please help me again. Thank you.


Go to the top of the page
 
+Quote Post

9 Pages V  « < 6 7 8 9 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th July 2014 - 08:14 PM