OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Wifi Probs, No Connection, Hostap Not Loading (fixed), I think I have a stable connection now :)
Jon_J
post Oct 1 2007, 10:02 PM
Post #1





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



I use this wifi card: Ambicom WL1100C
I have 3 hostap packages installed along with wpa_supplicant 0.4.7-2
hostap-driver 0.4.7-3
hostapd 0.4.7-1
hostap-utils 0.4.7-1
I have set up wpa and my settings in wifi-radar and network settings as discussed in several threads here.
My wifi card just blinks awhile and won't connect to my wireless router in wifi-radar. I always get no IP address acquired in wifi-radar
CODE
root-:) lsmod
Module                  Size  Used by    Tainted: P
orinoco_cs              4296   0
hermes                  4960   0  [orinoco_cs]
orinoco                40492   0  [orinoco_cs]
mousedev                4544   1
rfcomm                 33556   0  (autoclean)
l2cap                  16384   2  (autoclean) [rfcomm]
bluez                  33188   1  (autoclean) [rfcomm l2cap]
pxa27x_bi              24828   0  (unused)
net_fd                 25192   0  (unused)
usbdcore               35464   0  [pxa27x_bi net_fd]
usbdmonitor             5456   0
usb-monitor             6440   0
sharp_mmcsd_m          41032   2
bvdd                   11104   0  (unused)

I struggled with this early this year when I first installed pdaxii13 with no results. Why does my card work so smoothly in Cacko and not pdaxii13?
Go to the top of the page
 
+Quote Post
Meanie
post Oct 2 2007, 02:55 AM
Post #2





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Jon_J @ Oct 2 2007, 04:02 PM)
I use this wifi card: Ambicom WL1100C
I have 3 hostap packages installed along with wpa_supplicant 0.4.7-2
hostap-driver 0.4.7-3
hostapd 0.4.7-1
hostap-utils 0.4.7-1
I have set up wpa and my settings in wifi-radar and network settings as discussed in several threads here.
My wifi card just blinks awhile and won't connect to my wireless router in wifi-radar. I always get no IP address acquired in wifi-radar
CODE
root-:) lsmod
Module                  Size  Used by    Tainted: P
orinoco_cs              4296   0
hermes                  4960   0  [orinoco_cs]
orinoco                40492   0  [orinoco_cs]
mousedev                4544   1
rfcomm                 33556   0  (autoclean)
l2cap                  16384   2  (autoclean) [rfcomm]
bluez                  33188   1  (autoclean) [rfcomm l2cap]
pxa27x_bi              24828   0  (unused)
net_fd                 25192   0  (unused)
usbdcore               35464   0  [pxa27x_bi net_fd]
usbdmonitor             5456   0
usb-monitor             6440   0
sharp_mmcsd_m          41032   2
bvdd                   11104   0  (unused)

I struggled with this early this year when I first installed pdaxii13 with no results. Why does my card work so smoothly in Cacko and not pdaxii13?
[right][snapback]168352[/snapback][/right]


This has been discussed several times. The manfid of several cards are identical though they are different cards and need different drivers. Some cards need orinoco and some need hostap. Yours needs hostap but orinoco is being loaded. you need to edit /etc/pcmcia/config and disable the entries that have the identical manfid as your card and replace them with ones for your card so that the hostap driver is loaded for yours...
Go to the top of the page
 
+Quote Post
Jon_J
post Oct 2 2007, 05:49 AM
Post #3





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



Thank you for your reply meanie.
I have tried this previously, and I always get "unsupported card" in the cards app on the taskbar, and no lights come on, on my card.
I was hoping this would work this time, but didn't.
I commented every one of the matching manfids in /etc/pcmcia/config except this one.
CODE
card "AmbiCom WL11000C 802.11b CF-Card"
  version "AmbiComi", "WL11000C 802.11b CF-Card", "2.2"
  manfid 0xd601, 0x0002
  bind "hostap_cs"

Later I discovered 3 spelling errors and tried this setting, with no change in results.
CODE
card "AmbiCom WL1100C 802.11b CF-Card"
  version "AmbiCom", "WL1100C 802.11b CF-Card", "2.2"
  manfid 0xd601, 0x0002
  bind "hostap_cs"

(extra zero in WL1100C and Ambicom, spelled Ambicomi)
Here's lsmod
CODE
root-:) lsmod
Module                  Size  Used by    Tainted: P
mousedev                4544   1
rfcomm                 33556   0  (autoclean)
l2cap                  16384   2  (autoclean) [rfcomm]
bluez                  33188   1  (autoclean) [rfcomm l2cap]
pxa27x_bi              24828   0  (unused)
net_fd                 25192   0  (unused)
usbdcore               35464   0  [pxa27x_bi net_fd]
usbdmonitor             5456   0
usb-monitor             6440   0
sharp_mmcsd_m          41032   2
bvdd                   11104   0  (unused)

Again, thank you for your help, there must be something else preventing hostap_cs from loading.

EDIT
I thought I got it. (Since this isn't working very well, I'll probably return to my backed up hermes.conf file)
(I thought I had it working, it connected and got my IP, I checked email, got email, then surfed. After clicking a second link, my connection quit and the card started blinking)
At least I now have hostap loaded in lsmod, where before I didn't. My Ambicom card is showing on the taskbar, and only blinks once when inserted, (like in Cacko)
CODE
root-:) lsmod
Module                  Size  Used by    Tainted: P
hostap_crypt_tkip       9136   0  (autoclean)
hostap_crypt_wep        3584   0  (autoclean)
hostap                 97792   0  [hostap_crypt_tkip hostap_crypt_wep]
mousedev                4544   1
rfcomm                 33556   0  (autoclean)
l2cap                  16384   2  (autoclean) [rfcomm]
bluez                  33188   1  (autoclean) [rfcomm l2cap]
pxa27x_bi              24828   0  (unused)
net_fd                 25192   0  (unused)
usbdcore               35464   0  [pxa27x_bi net_fd]
usbdmonitor             5456   0
usb-monitor             6440   0
sharp_mmcsd_m          41032   2
bvdd                   11104   0  (unused)


Using this thread, substituting my Ambicom entry for the below entry.
http://www.oesf.org/forum/index.php?showto...amp;#entry44759 (note forum without the s)
EDIT2
I couldn't get this post to quote, but I thought it was the solution for my problem with hostap until I found out that my connection craps out after some time while online.
---------------------------------
Quoted from member "rgrep" Oct 4 2004, 02:22 AM
"I've fixed the problem now by switching drivers from orinoco to hostap. I have a Linksys WCF12 which is Prism 2 (or Prism 3?) and with the default settings in pdaXrom it uses these modules:"

CODE
# lsmod
Module                  Size  Used by    Tainted: P
orinoco_cs              4472   1
orinoco                35028   0  [orinoco_cs]
hermes                  4592   0  [orinoco_cs orinoco]
...


I'm not sure why the pdaXrom developers decided to only enable the orinoco driver (comments guys?) but it appears that's the only one it will ever use. For Prism based cards there's no need to use orinoco, especially since hostap is apparently better (and I'm hoping it will let me set my Zaurus up as an Access Point). The file you need to edit to switch drivers is /etc/pcmcia/hermes.conf. I added these lines near the top of the file:

CODE
device "hostap_cs"
  class "hermes"
  module "hostap", "hostap_cs"


Then find the definition for your card (further down in that file) and change the "orinoco_cs" reference to "hostap_cs". The definition for my card nows looks like this:

CODE
card "Linksys CompactFlash Wireless Card"
  version "Linksys", "Wireless CompactFlash Card"
  bind "hostap_cs"


(If you're not sure which entry is for your card, use 'cardctl ident' and search in /etc/pcmcia/hermes.conf for the "product info" it reports.

After editing /etc/pcmcia/hermes.conf, eject your card and restart the PCMCIA services:

CODE
cardctl eject 0
<remove card>
/etc/rc.d/init.d/pcmcia restart
<insert card>


You can test if it's worked by running lsmod again:

CODE
# lsmod
Module                  Size  Used by    Tainted: P
hostap_cs              45896   1
hostap                 85568   0  [hostap_cs]
...


This post has been edited by Jon_J: Oct 2 2007, 08:32 AM
Go to the top of the page
 
+Quote Post
Jon_J
post Oct 3 2007, 07:22 AM
Post #4





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



Here's what I did and my wifi connection seems to be working now, and works with WPA.
The wifi icon on the taskbar only shows one yellow square, (but it may be lying to me)

I commented out all entries in /etc/pcmcia/config that have matching manfid numbers to my card.
Then uncommented my Ambicom card, (if it was commented out).

I got hostap loading by doing the following:
I edited /etc/pcmcia/hermes.conf. I added these lines near the top of the file:
-----------------------
device "hostap_cs"
class "hermes"
module "hostap", "hostap_cs"
-----------------------

Then find the definition for your card (further down in that file) and change the "orinoco_cs" reference to "hostap_cs". The definition for my card nows looks like this:
-----------------------
card "AmbiCom WL1100C 802.11b CF-Card"
version "AmbiCom", "WL1100C 802.11b CF-Card", "2.2"
manfid 0xd601, 0x0002
bind "hostap_cs"
-----------------------

After editing /etc/pcmcia/hermes.conf, eject your card and restart the PCMCIA services:
-----------------------
cardctl eject 0
<remove card>
/etc/rc.d/init.d/pcmcia restart
<insert card>
-----------------------

At this point my connection was flaky when connecting with wifi-radar, so I did more tweaking.

1. I'm not sure if this action helped. I opened up /etc/pcmcia/hostap_cs.conf
I commented out all entries that matched my card, and then added my card info near the top.
My card info was NOT originally in this file.
-----------------------
card "AmbiCom WL1100C 802.11b CF-Card"
version "AmbiCom", "WL1100C 802.11b CF-Card", "2.2"
manfid 0xd601, 0x0002
bind "hostap_cs"
-----------------------

2. This may be what helped to stabilize my connection. I now use the "Network Settings" app to connect, that is only accessable through meanie's pdaxii13.config. It is located here:
/usr/bin/network.cfg (not network.py).
This app allows you to setup WPA and also has a connect button. I placed a shortcut on my desktop and just connect with this network Settings app. All seems to be working fine now with my wifi connection.
I have been surfing for about an hour and have not been disconnected. smile.gif
Go to the top of the page
 
+Quote Post
walkman
post Oct 3 2007, 07:52 AM
Post #5





Group: Members
Posts: 76
Joined: 26-September 07
Member No.: 20,757



QUOTE(Jon_J @ Oct 3 2007, 05:22 PM) *
Here's what I did and my wifi connection seems to be working now, and works with WPA.
The wifi icon on the taskbar only shows one yellow square, (but it may be lying to me)


Obviously the number of squares it shows is related to the traffic you generate on the WiFi connection. Try downloading a file and it will get to full-red-line state.

As far as your whole problem with Orinoco: this happens also on plain install of pdaXrom r198. A simple solution to the whole thing is to simply uninstall the orinoco driver if you do not need it (but I guess you are happy with one card, right?). That made it for me. Quick and clean. Might help to others in some cases, instead of heavy editing of config files.
Go to the top of the page
 
+Quote Post
Jon_J
post Oct 3 2007, 08:23 AM
Post #6





Group: Members
Posts: 1,843
Joined: 31-December 05
From: Illinois USA
Member No.: 8,821



QUOTE(walkman @ Oct 3 2007, 10:52 AM) *
QUOTE(Jon_J @ Oct 3 2007, 05:22 PM) *
Here's what I did and my wifi connection seems to be working now, and works with WPA.
The wifi icon on the taskbar only shows one yellow square, (but it may be lying to me)


Obviously the number of squares it shows is related to the traffic you generate on the WiFi connection. Try downloading a file and it will get to full-red-line state.

As far as your whole problem with Orinoco: this happens also on plain install of pdaXrom r198. A simple solution to the whole thing is to simply uninstall the orinoco driver if you do not need it (but I guess you are happy with one card, right?). That made it for me. Quick and clean. Might help to others in some cases, instead of heavy editing of config files.

I thought I read somewhere that the colored squares below the wifi icon are related to signal strength.
(more squares signify stronger signal)
I just checked the related *.png icons and this is how they are labeled:
black = broken
red = no link-0
yellow (1 square) = signal-1-40
yellow (2 squares) = signal-41-60
green (3 squares) = signal-61-80
green (4 squares) = signal-81-100

I'm going to use just one card for now, since it seems to be working, I'll "leave it as is".
Another point I may bring up.
If I use wifi-radar launched in a console, it shows it is constantly scanning or doing something busy in the background.
This is why I prefer to just use the network settings app to connect to my AP, here at home.
Go to the top of the page
 
+Quote Post
Meanie
post Oct 3 2007, 04:47 PM
Post #7





Group: Members
Posts: 2,808
Joined: 21-March 05
From: Sydney, Australia
Member No.: 6,686



QUOTE(Jon_J @ Oct 4 2007, 02:23 AM) *
QUOTE(walkman @ Oct 3 2007, 10:52 AM) *
QUOTE(Jon_J @ Oct 3 2007, 05:22 PM) *
Here's what I did and my wifi connection seems to be working now, and works with WPA.
The wifi icon on the taskbar only shows one yellow square, (but it may be lying to me)


Obviously the number of squares it shows is related to the traffic you generate on the WiFi connection. Try downloading a file and it will get to full-red-line state.

As far as your whole problem with Orinoco: this happens also on plain install of pdaXrom r198. A simple solution to the whole thing is to simply uninstall the orinoco driver if you do not need it (but I guess you are happy with one card, right?). That made it for me. Quick and clean. Might help to others in some cases, instead of heavy editing of config files.

I thought I read somewhere that the colored squares below the wifi icon are related to signal strength.
(more squares signify stronger signal)
I just checked the related *.png icons and this is how they are labeled:
black = broken
red = no link-0
yellow (1 square) = signal-1-40
yellow (2 squares) = signal-41-60
green (3 squares) = signal-61-80
green (4 squares) = signal-81-100

I'm going to use just one card for now, since it seems to be working, I'll "leave it as is".
Another point I may bring up.
If I use wifi-radar launched in a console, it shows it is constantly scanning or doing something busy in the background.
This is why I prefer to just use the network settings app to connect to my AP, here at home.


you can quit wifi-radar once you are connected and can run it again to disconnect. it does not need to be running all the time...
and yeah, I build an improved network config tool but nobody ever tested it besides myself. glad you like it smile.gif
Go to the top of the page
 
+Quote Post
harvell
post Nov 17 2007, 12:57 AM
Post #8





Group: Members
Posts: 242
Joined: 11-May 06
From: Silicon Valley, CA
Member No.: 9,831



QUOTE(Jon_J @ Oct 3 2007, 07:22 AM) *
Here's what I did and my wifi connection seems to be working now, and works with WPA.
The wifi icon on the taskbar only shows one yellow square, (but it may be lying to me)

I commented out all entries in /etc/pcmcia/config that have matching manfid numbers to my card.
Then uncommented my Ambicom card, (if it was commented out).

I got hostap loading by doing the following:
I edited /etc/pcmcia/hermes.conf. I added these lines near the top of the file:
-----------------------
device "hostap_cs"
class "hermes"
module "hostap", "hostap_cs"
-----------------------

Then find the definition for your card (further down in that file) and change the "orinoco_cs" reference to "hostap_cs". The definition for my card nows looks like this:
-----------------------
card "AmbiCom WL1100C 802.11b CF-Card"
version "AmbiCom", "WL1100C 802.11b CF-Card", "2.2"
manfid 0xd601, 0x0002
bind "hostap_cs"
-----------------------

After editing /etc/pcmcia/hermes.conf, eject your card and restart the PCMCIA services:
-----------------------
cardctl eject 0
<remove card>
/etc/rc.d/init.d/pcmcia restart
<insert card>
-----------------------

At this point my connection was flaky when connecting with wifi-radar, so I did more tweaking.

1. I'm not sure if this action helped. I opened up /etc/pcmcia/hostap_cs.conf
I commented out all entries that matched my card, and then added my card info near the top.
My card info was NOT originally in this file.
-----------------------
card "AmbiCom WL1100C 802.11b CF-Card"
version "AmbiCom", "WL1100C 802.11b CF-Card", "2.2"
manfid 0xd601, 0x0002
bind "hostap_cs"
-----------------------

2. This may be what helped to stabilize my connection. I now use the "Network Settings" app to connect, that is only accessable through meanie's pdaxii13.config. It is located here:
/usr/bin/network.cfg (not network.py).
This app allows you to setup WPA and also has a connect button. I placed a shortcut on my desktop and just connect with this network Settings app. All seems to be working fine now with my wifi connection.
I have been surfing for about an hour and have not been disconnected. smile.gif



Jon J you are da man!!!! laugh.gif I noticed that my card would not respond at all until i added

card "AmbiCom WL1100C 802.11b CF-Card"
version "AmbiCom", "WL1100C 802.11b CF-Card", "2.2"
manfid 0xd601, 0x0002
bind "hostap_cs"

to the /etc/pcmcia/host_cs.conf file. Once that was entered all was working well with the card now. Thanks buddy... rolleyes.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th April 2014 - 07:53 AM