OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

2 Pages V   1 2 >  
Reply to this topicStart new topic
> Gpsdrive Cvs Package, new version compiled (20040716)
Zumi
post Mar 31 2005, 09:26 AM
Post #1





Group: Members
Posts: 257
Joined: 1-June 04
From: Budapest, Hungary
Member No.: 3,518



New version compiled!
See the post about it here.
------
Hi,

It is a fully working, no-hack-needed CVS version. Or at least, these were my intentions. smile.gif

If your GPS card is using the /dev/ttyS3 file, then it will be working out of the box; if it doesn't, then I suggest some editing in the /usr/local/gpsdrive-run.sh script. Also, if you want to have flite (speech synthetizer) or mysql support (for a lot of waypoint, for example all Geocaches in your country), you can edit it and have them too. smile.gif

As the ipk upload part of the pdaXrom site seems to be broken, and Laze suggested to wait 'till the new site comes online, I put it up on my own website.

A sample screenshot
gpsdrive-cvs_20050330_armv5tel.ipk
(Later, I will upload it to the site, so if you don't find it here, look in the pdaXrom unstable feed)

I hope you like it,
Zumi smile.gif
Go to the top of the page
 
+Quote Post
ee_jeep
post Apr 11 2005, 03:03 AM
Post #2





Group: Members
Posts: 2
Joined: 16-January 04
Member No.: 1,458



Thanks for the great package Zumi. A functional gps program with mapping is what I needed to make my C860 complete.

I have a question about user permissions. Gpsdrive creates a user 'gps' so that it does not run as root. The problem is that user 'gps' does not have any permissions to see the SD card, so there is not a lot of space to store maps. I have tried using chmod to
change permissions on /mnt/card, but this does not work. I have also tried to use a symbolic link with no luck.

Does anyone know how I can get a non-root user to be able to use the SD card??

Thanks.
Go to the top of the page
 
+Quote Post
Zumi
post Apr 11 2005, 08:56 AM
Post #3





Group: Members
Posts: 257
Joined: 1-June 04
From: Budapest, Hungary
Member No.: 3,518



It works for me.

CODE
$ mkdir /mnt/card/mygpsdir
$ chown gps:gps /mnt/card/mygpsdir
$ mv /home/gps/.gpsdrive /home/gps/.gpsdrive.old
$ ln -s /mnt/card/mygpsdir /home/gps/.gpsdrive


I hope you can get it working this way.

Zumi smile.gif
Go to the top of the page
 
+Quote Post
fastscirocco
post Apr 19 2005, 09:00 AM
Post #4





Group: Members
Posts: 149
Joined: 17-January 05
Member No.: 6,254



QUOTE(Zumi @ Mar 31 2005, 12:26 PM)
Hi,

It is a fully working, no-hack-needed CVS version. Or at least, these were my intentions. smile.gif

If your GPS card is using the /dev/ttyS3 file, then it will be working out of the box; if it doesn't, then I suggest some editing in the /usr/local/gpsdrive-run.sh script. Also, if you want to have flite (speech synthetizer) or mysql support (for a lot of waypoint, for example all Geocaches in your country), you can edit it and have them too. smile.gif

As the ipk upload part of the pdaXrom site seems to be broken, and Laze suggested to wait 'till the new site comes online, I put it up on my own website.

A sample screenshot
gpsdrive-cvs_20050330_armv5tel.ipk
(Later, I will upload it to the site, so if you don't find it here, look in the pdaXrom unstable feed)

I hope you like it,
Zumi smile.gif
*


Will this work with a Leadtek 9534 CF Compact Flash GPS Receiver?
I have an opportunity to pickone up relatively cheaply but haven't been able to confirm it will work with my C3000.

Thanks
Chris
Go to the top of the page
 
+Quote Post
ostense
post Apr 22 2005, 01:53 AM
Post #5





Group: Members
Posts: 41
Joined: 23-December 03
Member No.: 1,259



Has anybody tried the Zaurus Serial Cable - ZThinCable with this application?

http://serialio.com/products/adaptors/ZThinCable.htm
Go to the top of the page
 
+Quote Post
Gondola
post May 18 2005, 06:10 PM
Post #6





Group: Members
Posts: 124
Joined: 11-January 05
Member No.: 6,189



Yes, just got my ZThinCable and Garmin etrex Legend today. I had to wrangle together my own null modem cable from an old mouse and a serial card, but it works.

I had to install a couple extra libs to get it going (libart, pcre) and I'm having a few issues (it's really slow, directory permissions) but it recognized the GPS data and put up the arrow where I was on the map and everything.

Once I get the details sorted out, I'll install flite for voice and maybe mysql to track waypoints.


QUOTE(ostense @ Apr 22 2005, 09:53 AM)
Has anybody tried the Zaurus Serial Cable - ZThinCable with this application?

http://serialio.com/products/adaptors/ZThinCable.htm
*
Go to the top of the page
 
+Quote Post
Gondola
post May 19 2005, 05:26 AM
Post #7





Group: Members
Posts: 124
Joined: 11-January 05
Member No.: 6,189



Just FYI this was under pdaXrom.

QUOTE(Gondola @ May 19 2005, 02:10 AM)
Yes, just got my ZThinCable and Garmin etrex Legend today.  I had to wrangle together my own null modem cable from an old mouse and a serial card, but it works.

I had to install a couple extra libs to get it going (libart, pcre) and I'm having a few issues (it's really slow, directory permissions) but it recognized the GPS data and put up the arrow where I was on the map and everything.

Once I get the details sorted out, I'll install flite for voice and maybe mysql to track waypoints.


QUOTE(ostense @ Apr 22 2005, 09:53 AM)
Has anybody tried the Zaurus Serial Cable - ZThinCable with this application?

http://serialio.com/products/adaptors/ZThinCable.htm
*

*

Go to the top of the page
 
+Quote Post
Martin
post Jul 4 2005, 11:15 AM
Post #8





Group: Members
Posts: 138
Joined: 5-October 04
From: konstanz, germany
Member No.: 4,874



Hi Zumi,

getting problems installing gpsdrive-cvs ... log of packagemanager saying ...

ldconfig: /usr/local/lib/libnautic.so.2 is not a symbolic link.

ldconfig: /usr/local/lib/libfly.so.2 is not a symbolic link.

Whats going on? I think they both were in stalled from gpsdrive-cvs pkg?!

THX
Martin
Go to the top of the page
 
+Quote Post
Zumi
post Jul 4 2005, 12:50 PM
Post #9





Group: Members
Posts: 257
Joined: 1-June 04
From: Budapest, Hungary
Member No.: 3,518



Hi Martin,

I haven't got this problem so far.
You can try to remove the package and see if those two files are still there (or symlinks for them). Try searching for them in the /mnt/card/... and /mnt/cf/... too. If you find them, delete them and try to reinstall the package after that. Try to install it in the / (root) partition, maybe that helps.

Zumi cool.gif
Go to the top of the page
 
+Quote Post
BarryW
post Jul 4 2005, 02:20 PM
Post #10





Group: Members
Posts: 693
Joined: 4-June 04
From: Ohio
Member No.: 3,570



Got it installed, it starts, then segfaults. Says map_koord.txt reloaded right before the segmentation fault. This is the cvs version.
Go to the top of the page
 
+Quote Post
Martin
post Jul 4 2005, 10:48 PM
Post #11





Group: Members
Posts: 138
Joined: 5-October 04
From: konstanz, germany
Member No.: 4,874



Hi Zumi, Hi Barry,

gpsdrive-cvs and pcre packages are installed in / ... yes I tried to remove the gpsdrive package and libnavi* and libfly* disapear with all copies like .so.2, .so.2.0.0 ...

after reinstall the problem is there again ... what's going on in packagemanager with ipkg? i although install it with ipkg direct ... same probleme :-(
ldconfig says those two files are not a symbolic link ?!

@Barry ... please look in your /usr/local/lib directory for those files could you please post your ls -l libnavi* libfly*

What about that user gps ... any problems ? removing package will not remove the user

The problem with segfault is the same to me ...with gpsdrive2.09 package ...

Thanks
Martin
Go to the top of the page
 
+Quote Post
BarryW
post Jul 4 2005, 11:00 PM
Post #12





Group: Members
Posts: 693
Joined: 4-June 04
From: Ohio
Member No.: 3,570



When I flash back to pdax I'll let you know. Only mess with it on the weekends, flash back to sharp for work...
Go to the top of the page
 
+Quote Post
Zumi
post Jul 17 2005, 09:11 AM
Post #13





Group: Members
Posts: 257
Joined: 1-June 04
From: Budapest, Hungary
Member No.: 3,518



I compiled a new CVS version. I don't know what major/minor changes are in the code, just did a cvs update and recompiled it.

I updated the post-remove script, so it removes the gps user and group that was created during install, but it doesn't delete the /home/gps directory.
Oh, and now it depends on libart-lgpl and pcre package. If it needs other ones too, please make a post about it.
I hope you like it! smile.gif

Zumi
Attached File(s)
Attached File  gpsdrive_cvs_20050716_armv5tel.ipk ( 1.08MB ) Number of downloads: 241
 
Go to the top of the page
 
+Quote Post
gab74
post Jul 18 2005, 07:12 AM
Post #14





Group: Members
Posts: 344
Joined: 24-May 04
Member No.: 3,411



I've installed on SL6000 and it works !
Go to the top of the page
 
+Quote Post
Martin
post Jul 19 2005, 03:09 AM
Post #15





Group: Members
Posts: 138
Joined: 5-October 04
From: konstanz, germany
Member No.: 4,874



Hi :-)

nice but I have problems with it ... installed ipkg llibart-lgpl and pcre package ...

after starting it from xterm (missing icons on menu) ... after splash screen main window appears ... maybe time depend or first tab on screen it crashes with "segmentation fault" ...

Any ideas?

Thanks
Martin
Go to the top of the page
 
+Quote Post

2 Pages V   1 2 >
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 10:02 AM