OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Problems With Zgcc, "source" command doesn't work for su
Fraggy
post Jan 24 2005, 08:32 AM
Post #1





Group: Members
Posts: 68
Joined: 19-July 04
From: Argentina
Member No.: 4,038



Can anybody help me out?

I'm trying to install the "ZGCC GNU Compiler Suite Release 2.02" on my Zaurus.
(http://s91215199.onlinehome.us/zaurus/)

Configuration instructions are here: http://s91215199.onlinehome.us/zaurus/zgcc2install.html

But I get stuck on the part where I have to configure the compiler sad.gif

I have to run "source zgcc.sh" as root, but root doesn't recognize the command "source"...

Any suggestions?
Go to the top of the page
 
+Quote Post
freizugheit
post Jan 24 2005, 06:40 PM
Post #2





Group: Members
Posts: 409
Joined: 7-November 03
Member No.: 811



Are you using root during the installaton?
Go to the top of the page
 
+Quote Post
holck
post Jan 25 2005, 03:30 AM
Post #3





Group: Members
Posts: 34
Joined: 10-October 03
Member No.: 611



QUOTE(Fraggy @ Jan 24 2005, 08:32 AM)
I have to run "source zgcc.sh" as root, but root doesn't recognize the command "source"...

To me it looks like this command should run the shell-script zgcc.sh. If this is true, you could try
CODE
sh zgcc.sh
Go to the top of the page
 
+Quote Post
Stubear
post Jan 25 2005, 04:05 AM
Post #4





Group: Members
Posts: 1,164
Joined: 17-December 03
From: Melbourne, AUSTRALIA
Member No.: 1,219



QUOTE(Fraggy @ Jan 25 2005, 01:32 AM)
I have to run "source zgcc.sh" as root, but root doesn't recognize the command "source"...

Any suggestions?
*


In bash source can also be done wth the . command. So you want to type
CODE
. zgcc.sh


If that still gives you erros then you are most probably not running bash but ash.
Try running
CODE
bash
at the prompt as root, then try source or . again

Stu
Go to the top of the page
 
+Quote Post
Fraggy
post Jan 25 2005, 06:32 AM
Post #5





Group: Members
Posts: 68
Joined: 19-July 04
From: Argentina
Member No.: 4,038



Freizugheit: yes I was running the installation as root.

Stu: Indeed both methods do the job, thanks!

I still haven't gotten the compiler to run, 'cause now I got a misconfiguration in the compiler config, but the source command works again!

JM.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 08:06 PM