OESF | ELSI | pdaXrom | OpenZaurus | Zaurus Themes | Community Links | Ibiblio

IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Opie Mediaplayer2, Still not playing mp3
Pyrates
post Jan 17 2005, 02:14 PM
Post #1





Group: Members
Posts: 198
Joined: 17-January 04
Member No.: 1,475



Hi there!

As the topic says... I've installed EVERYTHING a "ipkg list|grep xine" returned, which was quite a lot. Now it plays ogg's (nice smile.gif). My xmms can play mp3's (also nice), but the opie mediaplayer2 backs out with a "no input plugin found for this media type". What could I do? Thanks for any pointers..


Cheers
Philipp
Go to the top of the page
 
+Quote Post
uberjoe
post Jan 17 2005, 09:47 PM
Post #2





Group: Members
Posts: 131
Joined: 24-March 04
Member No.: 2,471



I encountered similiar problems until I ran ipkg-link. After that everything played fine. Also Did you check to see if the codec particular to mp3 playback actually got linked back to root?
Go to the top of the page
 
+Quote Post
Pyrates
post Jan 18 2005, 01:15 AM
Post #3





Group: Members
Posts: 198
Joined: 17-January 04
Member No.: 1,475



I ran ipkg-link for sure smile.gif What's the codec particular to mp3 playback? I think I checked all the mad-related stuff, but I'll do again tonight (that's what' for mp3, right?).

Cheers
Philipp
Go to the top of the page
 
+Quote Post
uberjoe
post Jan 19 2005, 08:31 AM
Post #4





Group: Members
Posts: 131
Joined: 24-March 04
Member No.: 2,471



I was going to post my command line output from

#opieplayer2 /mnt/card/music/song.mp3

but that does nothing, so I'm not sure. That used to work in previous OZ versions and I could use the output to diagnose problems with codecs. I doubt it makes a difference but did you install the ipks locally or directly from the feed?
Go to the top of the page
 
+Quote Post
Pyrates
post Jan 19 2005, 11:44 AM
Post #5





Group: Members
Posts: 198
Joined: 17-January 04
Member No.: 1,475



Directly from the feed, but I refuse to believe that has something to do with it. I can't possible download all those packages by hand, there are SO MUCH plugins for xine, and as long as I don't know which ones are the ones I need...

Your idea of starting opieplayer from the commandline is good. I did it,but I just get "ERRORCODE 1" nad "No input plugin found for this media type". Maybe you could try again, this time just starting opieplayer2 from the commandline and then play an mp3? That could provide some usefull output...

Cheers
Philipp

Update: I cannot even play oggs anymore, the same error occurs. I have no idea what's up here, could you please post the location of your plugins, so I can check mine? Thanks...
Go to the top of the page
 
+Quote Post
uberjoe
post Jan 19 2005, 08:24 PM
Post #6





Group: Members
Posts: 131
Joined: 24-March 04
Member No.: 2,471



Even invoking opieplayer2 from the command line does not start. I get the same error as if I try to play an mp3 file. Some error about not being able to open an application main window. The only way I can start omp2 is with the gui.
Go to the top of the page
 
+Quote Post
Pyrates
post Jan 20 2005, 04:45 AM
Post #7





Group: Members
Posts: 198
Joined: 17-January 04
Member No.: 1,475



That's so weird... could you check anyway where your plugins are? Mine are in some subdirectory of /usr/lib/xine, but not in /usr/lib/xine itself, maybe that's the problem?

Cheers
Philipp
Go to the top of the page
 
+Quote Post
Greg2
post Jan 24 2005, 07:25 AM
Post #8





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(Pyrates @ Jan 20 2005, 07:45 AM)
That's so weird... could you check anyway where your plugins are? Mine are in some subdirectory of /usr/lib/xine, but not in /usr/lib/xine itself, maybe that's the problem?

That's where mine are located.

I've worked with this a bit and found the following plugins to make sound from mp3s and oggs... unfortunately it's not a good sound. It plays very fast and broken up oggs and 'screechy' mp3s. If you edit the opiexine.cf file in
/root/Settings
uncomment the 'audio.oss_sync_method:softsync' line it fails to play at all.

libxine1
libxine-plugin-ao-out-oss
libxine-plugin-decode-mad
libxine-plugin-decode-mpeg2
libxine-plugin-dmx-audio
libxine-plugin-dmx-mpeg
libxine-plugin-inp-file
libvorbis
libxine-plugin-decode-vorbis
libxine-plugin-dmx-ogg

Let me know if you or anyone gets this to work properly but until then... xmms works great with both mp3s and oggs.

@uberjoe
If you have this working properly could you list your plugins?

Greg
Go to the top of the page
 
+Quote Post
uberjoe
post Jan 25 2005, 09:55 AM
Post #9





Group: Members
Posts: 131
Joined: 24-March 04
Member No.: 2,471



The codecs are in /usr/lib/xine/plugins/1.0.0. Here's the output:

$ ls /mnt/card/usr/lib/xine/plugins/1.0.0
post
xineplug_ao_out_file.so
xineplug_ao_out_none.so
xineplug_ao_out_oss.so
xineplug_decode_a52.so
xineplug_decode_bitplane.so
xineplug_decode_dts.so
xineplug_decode_dvaudio.so
xineplug_decode_ff.so
xineplug_decode_gsm610.so
xineplug_decode_image.so
xineplug_decode_lpcm.so
xineplug_decode_mad.so
xineplug_decode_mpeg2.so
xineplug_decode_nsf.so
xineplug_decode_real.so
xineplug_decode_real_audio.so
xineplug_decode_rgb.so
xineplug_decode_spu.so
xineplug_decode_spucc.so
xineplug_decode_spucmml.so
xineplug_decode_sputext.so
xineplug_decode_vorbis.so
xineplug_decode_yuv.so
xineplug_dmx_audio.so
xineplug_dmx_avi.so
xineplug_dmx_fli.so
xineplug_dmx_flv.so
xineplug_dmx_games.so
xineplug_dmx_iff.so
xineplug_dmx_image.so
xineplug_dmx_matroska.so
xineplug_dmx_mpeg.so
xineplug_dmx_mpeg_block.so
xineplug_dmx_mpeg_elem.so
xineplug_dmx_mpeg_pes.so
xineplug_dmx_mpeg_ts.so
xineplug_dmx_nsv.so
xineplug_dmx_ogg.so
xineplug_dmx_pva.so
xineplug_dmx_qt.so
xineplug_dmx_rawdv.so
xineplug_dmx_real.so
xineplug_dmx_slave.so
xineplug_dmx_sputext.so
xineplug_dmx_yuv4mpeg2.so
xineplug_dmx_yuv_frames.so
xineplug_inp_cdda.so
xineplug_inp_dvb.so
xineplug_inp_dvd.so
xineplug_inp_file.so
xineplug_inp_http.so
xineplug_inp_mms.so
xineplug_inp_net.so
xineplug_inp_pvr.so
xineplug_inp_rtp.so
xineplug_inp_rtsp.so
xineplug_inp_stdin_fifo.so
xineplug_inp_v4l.so
xineplug_inp_vcdo.so
xineplug_vo_out_none.so
Go to the top of the page
 
+Quote Post
Greg2
post Jan 25 2005, 04:27 PM
Post #10





Group: Members
Posts: 790
Joined: 28-October 03
From: USA
Member No.: 792



QUOTE(uberjoe @ Jan 25 2005, 12:55 PM)
The codecs are in /usr/lib/xine/plugins/1.0.0. Here's the output:

$ ls /mnt/card/usr/lib/xine/plugins/1.0.0
post


Thanks, I've found part of the problem.

You need to install the libxine-plugin-post-audio-filters-xxx.ipk and this creates the /post directory with the libxine-plug-post-audio-filters. You only need that one in the post directory to work. (there are 7 available)

Then you must uncomment the 'audio.oss_sync_method:softsync' line in the opiexine.cf file in /root/Settings.

The following list is installed with opie-mediaplayer2 and the skins:

libxine1
libxine-plugin-post-audio-filters
libxine-plugin-ao-out-oss
libxine-plugin-decode-mad
libxine-plugin-decode-mpeg2
libxine-plugin-dmx-audio
libxine-plugin-dmx-mpeg
libxine-plugin-inp-file
libvorbis
libxine-plugin-decode-vorbis
libxine-plugin-dmx-ogg

Now my oggs sound great but unfortunately mp3s are very choppy... but at least now they play.

Any ideas to improve the sound of the mp3s?

Thanks

Greg
Go to the top of the page
 
+Quote Post
dansawyer
post May 20 2005, 06:21 PM
Post #11





Group: Members
Posts: 293
Joined: 18-November 03
Member No.: 945



The following packages are loaded on an sd card and linked with ipkg-link. mediaplayer2 works great.

Dan

libmad0
libogg0
libvorbis
libvorbisidec1
libxine-plugin-ao-out-oss
libxine-plugin-decode-mad
libxine-plugin-dmx-audio
libxine-plugin-dmx-mpeg
libxine-plugin-inp-file
libxine
libxine1
opie-mediaplayer2-skin-default
opie-mediaplayer2
opie-sh
Go to the top of the page
 
+Quote Post
eccerr0r
post Sep 5 2005, 11:43 PM
Post #12





Group: Members
Posts: 13
Joined: 3-September 05
From: Colorado, USA
Member No.: 8,029



Reporting some weird behavior here.

I tried ipkg install opie-mediaplayer2

It runs fine from the menu, however, mp3s it plays is garbled - it seems like it's not synching, and playing off-beat, missing frames, etc. So I remove it and try opie-mediaplayer1 which works fine (except that pausing seems to have a slight delay)

just an observation... This is with a 250 poodle if it makes a difference (stock oz353 kernel).
Go to the top of the page
 
+Quote Post
lardman
post Sep 6 2005, 01:37 AM
Post #13





Group: Members
Posts: 4,515
Joined: 25-October 03
From: Bath, UK
Member No.: 464



Turn on audio.oss_sync_method:softsync in the conf file.

(Look up the page)


Si
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th July 2014 - 05:04 AM